interrupted sound with Urban Terror and pulseaudio 0.9.15

Bug #372843 reported by Claudiu Vlad on 2009-05-06
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pulseaudio

I am using Jaunty and the latest pulseaudio from PPA, and after upgrade, the ubuntu startup sound is distorted. Urban Terror sounds are distorted, interrupted and sometimes sound is lost, with error "Dropping sound". Sound was perfect with jaunty pulseaudio.
I am also interested in downgrading, if someone is so nice to give me a quick oneliner for that.

Claudiu Vlad (claudiu-vlad) wrote :

Downgraded pulseaudio.
Downgraded alsa.
Downgraded canberra.
Removed .asoundrc*
Removed .pulse*
Rebooted.
Happy.

Having this problem with the stock pulseaudio version provided in jaunty (0.9.14). After 1-2 minutes of gameplay (even just spectating), the sound cuts off entirely.

Also affects the other games, such as Tremulous.

I think I have found the solution. It seems that installing libsdl1.2debian-pulseaudio (which uninstalls libsdl1.2debian-alsa) solves the problem on my end. If this also solves the problem on your ends, maybe this package should be considered an automatically installed dependency when using pulseaudio?

aurelieng (aurelien-grosdidier) wrote :

This doesn't solve the problem for me (Jaunty).

Cory Walker (lala32) wrote :

Installing libsdl1.2debian-pulseaudio fixed it for me. I was having sound problems with all quake based games. If libsdl1.2debian-alsa is what's having the problems - why is pulseaudio 0.9.15 to blame in this bug report?

Claudiu Vlad (claudiu-vlad) wrote :

Upgrading to Karmic Koala Alpha 5 seems to bring back this bug.
Installing libsdl1.2debian-pulseaudio fixed it for me too.

Changed in pulseaudio (Ubuntu):
status: New → Fix Released
alex (1alex) wrote :

Fixed it for me too (replaced libsdl1.2debian-alsa with libsdl1.2debian-pulseaudio) in the latest Karmic Koala

alex (1alex) on 2009-09-29
Changed in pulseaudio (Ubuntu):
status: Fix Released → Confirmed
Juan Orti Alcaine (juan.orti) wrote :

Why is installed by default libsdl1.2debian-alsa? If everything is now pulseaudio, libsdl1.2debian-pulseaudio should be installed

True, but using the alsa backend for SDL still shouldn't have such
problems. I'll work on that this weekend and hopefully have a test
package for Karmic in the ubuntu-audio-dev PPA.

sebsauvage (sebsauvage) wrote :

Workaround confirmed: In Jaunty, removing libsdl1.2debian-alsa and installing libsdl1.2debian-pulseaudio fixed the problem.

azendal (trasvina) wrote :

Worked for me too, and im on the final karmik, maybe they should do a fix on this issue?

Daniel T Chen (crimsun) wrote :

On Fri, Oct 30, 2009 at 11:16 PM, azendal <email address hidden> wrote:
> Worked for me too, and im on the final karmik, maybe they should do a
> fix on this issue?

Who is "they"?

Also, please remember than neither Kubuntu nor Xubuntu have PulseAudio
installed by default, so depending on libsdl1.2debian-pulseaudio would
be a serious regression for those users.

Of course, the "proper" fix that I alluded to above is simply to fix
src/audio/{alsa,pulse} in the Ubuntu source packages -- which will be
done for 10.04 LTS and has already been done in upstream's svn trunk.

Kilimangaro (remy-dufour) wrote :

I have got the same problem after upgrading to karmic. Installing libsdl1.2debian-pulseaudio solved the bug for me

Torchmann (goodf2) wrote :
Download full text (4.6 KiB)

..."Try and install libsdl1.2-debian-pulse so that sdl uses pulseaudio directly, and see if that helps."

I actually had libsdl1.2-debian-pulse installed. changing it to alsa killed my sound. pulseaudio is just the sound server not a driver. pulse actually controls alsa from what I've read on other threads.
libsdl-sound1.2 was missing along with libsdl1.2debian which is the SIMPLE DIRECTMEDIA LAYER.

SOLVED
I tried going all alsa found out pulse is only a server between alsa and the application running alsa. screwed it all up and had to re-install.

running compiz the game was quiet

I tried debian and slackware...no luck
I installed Ultimate Edition 2.5...back to no sound. no metacity to switch to
I had better results running under metacity instead of compiz but game still crashed
Ultimate Edition might have given me a better repository or other libraries for success, anyway this is what I have going that makes UT work perfect. very perfect...

Made sure adobe 10 flashplayer that was lagging gnome and firefox wasn't the problem by leaving it out of this install.

I had to install the alsa mixer gui to get my mono base channel working on the soundcard but Urban Terror still kept crashing.

I found out that if your sound crashes instead of trying to back out of UT and locking up your system forcing a restart just hit alt+tab
and it will minimize the window and you can close the app with a right-click close

I tried switching to Libsdl-debian-alsa and I had absolutely no sound
I had to open pulse audio preferences and select the analog stereo duplex option, the digital feed was not working with my sigmatel 97 soundcard.
I tried switching to Libsdl-debian-all and that still worked for everything else but not urban terror.
I noticed that Libsdldebian1.2 (Simple Directmedia Layer) was NOT installed by default so i installed it.
No change yet...
I switched back to ubuntu 9.10 default Libsdl-debial-pulseaudio from the Libsdl-debian-all everyone was reccomending

Urban Terror works perfect,
No crash, no lag and I have compiz desktop cube active and am running under the ubuntu drivers so it was never an ati driver problem strictly audio. some people have said UT ran better under metacity and it did for me but still kept crashing the soundcard until I installed the missing 2 libraries.

Here is a list of what I have installed in synaptic under a search for sdl
libsdl-gfx1.2-4
libsdl pango1
libsdl-sound1.2
libsdl-ttf2.0-0
gambas2-gb-sdl
gambas2-gb-sdl-sound
libsdl1.2debian-pulseaudio
libsdl1.2debian
libsdlmpeg0
mplayer-skins
libsdl-image 1.2
libsdl-mixer 1.2
vlc-nox
mplayer
mplayernogui

Here is what's showing as manually altered under sdl (the ones I changed)
You have to have all 3 of these installed...
libsdl1.2debian-pulseaudio
libsdl1.2 debian
libsdl-sound1.2

and just for posterity if it had anything to do with alsa at all when I installed the alsa mixer and alsa gui...
this is what's showing up in synaptic filtering for manually installed under a search for alsa
alsamixergui
alsaplayer-common
libsd-alsa0
alsa-utils
gnome-alsamixer
alsa-oss
alsa-base
libsound2
alsa-tools-gui
libsound2-plugins
linux-sound-base
gstreamer0.10-alsa
qamix
...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers