Recording from microphone stutters when pulseaudio is running

Bug #354620 reported by Ronald McCollam
208
This bug affects 29 people
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Fix Released
High
Unassigned
Nominated for Karmic by Rodrigo Virote Kassick
Nominated for Lucid by Fernando

Bug Description

Binary package hint: pulseaudio

On an Acer Aspire One, audio recorded through either the internal microphone or a microphone plugged into the mic input skips and stutters. This does not seem to be a function of CPU load; even with nothing running but the gnome sound recorder this behavior occurs. Uninstalling pulseaudio and rebooting causes the recorded sound to work correctly. Reinstalling pulseaudio and rebooting causes the stuttering to return.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: pulseaudio 1:0.9.14-0ubuntu16
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
Uname: Linux 2.6.28-11-generic i686

Related branches

Revision history for this message
Ronald McCollam (fader) wrote :
Revision history for this message
Ronald McCollam (fader) wrote : apport-collect data

Architecture: i386
DistroRelease: Ubuntu 9.04
Package: pulseaudio 1:0.9.14-0ubuntu16
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Revision history for this message
Ronald McCollam (fader) wrote :
Revision history for this message
Ronald McCollam (fader) wrote :

The same behavior is observed on a Dell Mini 9 (aka Inspiron 910). (apport-collect data attached above)

Changed in pulseaudio (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Revision history for this message
David Mandala (davidm) wrote :

The same behavior is observed on an eee PC 1000.

Revision history for this message
Nighto (nighto-nighto) wrote :

https://help.ubuntu.com/community/AspireOne suggests "Front microphone works out-of-the-box. If it fails, check System->Preferences->Sound->Sound Capture is set to "HDA Intel ALC268 Analog(ALSA)" not "ALSA". " Tried here and it worked.

Revision history for this message
suomaf (suomaf) wrote :

https://help.ubuntu.com/community/AspireOne suggests "Front microphone works out-of-the-box. If it fails, check System->Preferences->Sound->Sound Capture is set to "HDA Intel ALC268 Analog(ALSA)" not "ALSA". " does not work with acer aspire one D250

Xan (dxpublica)
tags: added: aspireone
Revision history for this message
Paul Whipp (paul-whipp) wrote :

Using 9.04 UNR on a Dell mini 9, I'm unable to use the microphone. Tuning the settings in the sound volume control the best I get is static hiss over which can just hear a loud clap as a faint click when recorded/played back in the sound recorder device.

I'll happily provide more information or investigation to help resolve this issue.

It will be a major bonus to be able to use ekiga and skype on the mini.

Revision history for this message
Anthony Hook (anthonyhook) wrote :

System->Preferences->Sound->Sound Capture is set to "HDA Intel ALC268 Analog(ALSA)" not "ALSA". This also worked on my Asus EEE 1000.

Revision history for this message
Pha[N]toM (phantomsmcat) wrote :

Asus Eee1000H works only with Pulse audio in System->Preferences->Sound in all parameters, only Default mixer channels is to HDA Intel (ALSA).
Works fine in Ubuntu 9.04 UNR without UNR frontend.

Revision history for this message
SWedenfox (swedenfox) wrote :

thank you Pha[N]toM , your solution works also for acer aspire one ZG5

Revision history for this message
Pha[N]toM (phantomsmcat) wrote :

Your wellcome ))

Bug may changed to "solved"?

Sorry for russian screenshot...

Revision history for this message
Jeff Fortin Tam (kiddo) wrote :

This did the trick for me on my Dell Mini 9 (had to use the second "HDA Intel ALC268 Analog(ALSA)" because the first one is for the microphone jack, the second is for the built-in mic.

Phantom: no, this bug should not be marked as solved just because there is a workaround (thanks for that, by the way). It *should* work properly with pulseaudio instead of needing to do stuff like this.

Revision history for this message
BatteryKing (jmcsnyder) wrote :

I need to multiplex on a USB sound device and this doesn't seem to work with the ALSA / OSS tangle, plus it really helps to control the volume levels of each application. However with Pulsaudio having broken mic support across the board (tried three different devices and even more are listed on this thread) I am seem to be SOL. This used to work when I was on 8.10. Now I think I am going to have to go back to Windows because I can't get basic audio stuff to work under Linux anymore (and it used to work with some finagling).

Pha[N]toM (phantomsmcat)
tags: added: eeepc pulseaudio
Revision history for this message
Daniel T Chen (crimsun) wrote :

Is this symptom reproducible in current karmic?

Revision history for this message
Dylan Taylor (dylanmtaylor) wrote :

This symptom also occurs on my Eee PC 1000HA. I have not tested on Karmic.

Revision history for this message
JK (m0d) wrote :

Looks that the problem still exists. I have a Toshiba A100 with an ALC861 and recording only works during live session (with Jaunty and Karmic) but not after installation. And because audio settings have completely changed in Karmic, the workaround described above cannot be applied. Can PulseAudio even be uninstalled as easy as in Jaunty? It seems to be deeply integrated in Karmic...

However, I've already filed a bug report:

https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/434511

Revision history for this message
JK (m0d) wrote :

Apparantly, I was wrong: the bug seems to be not related to PulseAuidio in my case. I was able to reactivate the mic by adding option 'position_fix=1' to the alsa-base.conf (see my report).

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

The problem still happens on karmic with the updates of october 24th

For gstreamer applications, setting the input device to alsa/analog on gstreamer-properties works.
Skype still has major issues whenever pulseaudio is running. Sad enough, it does not present options other then "pulsaudio" on it's sound configuration.

setting position_fix=1 does make gnome-sound-recorder to work on pulseaudio, but sound quality is awful

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

Pulseaudio running, snd-hda-intel without position fix option

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

pulseaudio running, snd-hda-intel with option position_fix=1

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

pulseaudio running, no position_fix option, recording from Alsa/ALC268 Analog

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

pulseaudio not running, no position fix option

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

pulseaudio not running, snd-hda-intel with position_fix option=1

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

Acer Aspire One 150-1096 (9" 120Gb HDD)

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

**** Lista de Dispositivos CAPTURE Hardware ****
placa 0: Intel [HDA Intel], dispositivo 0: ALC268 Analog [ALC268 Analog]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0

**** Lista de Dispositivos PLAYBACK Hardware ****
placa 0: Intel [HDA Intel], dispositivo 0: ALC268 Analog [ALC268 Analog]
  Dispositivo secundário: 1/1
  Dispositivo secundário #0: subdevice #0

Simple mixer control 'Master',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 64
  Mono:
  Front Left: Playback 64 [100%] [0.00dB] [on]
  Front Right: Playback 64 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Mic Boost',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 2
  Front Left: Capture 2 [100%] [40.00dB]
  Front Right: Capture 2 [100%] [40.00dB]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 31 [100%] [31.50dB] [on]
  Front Right: Capture 31 [100%] [31.50dB] [on]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 12
  Mono:
  Front Left: Playback 0 [0%] [-24.00dB] [on]
  Front Right: Playback 0 [0%] [-24.00dB] [on]
Simple mixer control 'Digital',0
  Capabilities: cvolume
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 120
  Front Left: Capture 120 [100%] [30.00dB]
  Front Right: Capture 120 [100%] [30.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'i-Mic' 'E-Mic'
  Item0: 'i-Mic'

[ 201.441021] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x015f0900
[ 373.833595] HDA Intel 0000:00:1b.0: PCI INT A disabled
[ 380.156299] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 380.156407] HDA Intel 0000:00:1b.0: setting latency timer to 64
[ 380.216421] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input10

tags: added: regression-potential
Revision history for this message
JK (m0d) wrote :

> setting position_fix=1 does make gnome-sound-recorder to work on pulseaudio, but sound quality is awful

Yeah, that sounds familiar... In my case, however, everything worked fine (and in good quality) when booting from the live CD (without the need to configure anything). I've never found the reason for this but you may check if that's also the case for you! Maybe then I wouldn't fell so alone ;)

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

With the beta livecd, the mic worked fine without tweaks.
Pulseaudio was running, recording worked ok from both pulseaudio and alsa-analog.

Skype, on the other hand, presented the same issues as in the current distribution.

Relevant packages version as of the beta live cd:
pulseaudio 1:0.9.18-0ubuntu3
alsa-base 1.0.20+dfsg-1ubuntu4
alsa-utils 1.0.20-2ubuntu3
gstreamer0.10-alsa 0.10.24.3-1ubuntu1
libesd-alsa0 0.2.41-5
libaudio2 0.2.6-7ubuntu2 (used by skype)

Module snd-hda-intel versionmagic 2.6.31-11-generic SMP modversions 586 ; srcversion f2bc779d5d58e59fbb35f18

Revision history for this message
Luke Yelavich (themuso) wrote : Re: [Bug 354620] Re: Recording from microphone stutters when pulseaudio is running

I suggest trying the latest beta of skype, as that now has pulseaudio support.

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote : Re: [Bug 354620] Re: Recording from microphone stutters when pulseaudio is running

Luke, what version of skype? I searched the site yesterday for any version
newer then the 2.1 and couldn't find anything

On Sun, Oct 25, 2009 at 9:19 PM, Luke Yelavich
<email address hidden>wrote:

> I suggest trying the latest beta of skype, as that now has pulseaudio
> support.
>
> --
> Recording from microphone stutters when pulseaudio is running
> https://bugs.launchpad.net/bugs/354620
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Rodrigo Virote Kassick
(kàzic)
------------------------------------------------------------

Revision history for this message
Luke Yelavich (themuso) wrote : Re: [Bug 354620] Re: Recording from microphone stutters when pulseaudio is running

On Mon, Oct 26, 2009 at 10:28:38AM EST, Rodrigo Virote Kassick wrote:
> Luke, what version of skype? I searched the site yesterday for any version
> newer then the 2.1 and couldn't find anything

I don't know what they are up to I am affraid. I am only aware that there is a beta version, no idea of version number sorry.

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote : Re: [Bug 354620] Re: Recording from microphone stutters when pulseaudio is running

For clarification:

Skype version 2.1.0.47-1_i386 (skype.com calls this beta) microphone does
not work nor with the livecd image nor in the current distribution.

On Sun, Oct 25, 2009 at 10:49 PM, Luke Yelavich <<email address hidden>
> wrote:

> On Mon, Oct 26, 2009 at 10:28:38AM EST, Rodrigo Virote Kassick wrote:
> > Luke, what version of skype? I searched the site yesterday for any
> version
> > newer then the 2.1 and couldn't find anything
>
> I don't know what they are up to I am affraid. I am only aware that
> there is a beta version, no idea of version number sorry.
>
> --
> Recording from microphone stutters when pulseaudio is running
> https://bugs.launchpad.net/bugs/354620
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Rodrigo Virote Kassick
(kàzic)
------------------------------------------------------------

Revision history for this message
JK (m0d) wrote :

> With the beta livecd, the mic worked fine without tweaks.

Wow, finally somebody who can reproduce my problem! I guess we will form a bigger group after the final has been released ;)

I'd love to know what makes the difference between the live and installed system. Obviously a working configuration is destroyed during installation but I have no clue how or why that happens... I've tried to figure that out with some help from Colin from the PA mailing list but there simply was no difference in PA and ALSA setup (except for "flat volumes" being disabled in the live session). I've also filed a report tot he ALSA dev and user list but got no response. Unfortunately, I cannot do more tests because it wasn't my machine and I had to give it back to its owner. But if you'd like to do more research, here are some commands that may help:

For debugging, use the output of "amixer -c0", "pacmd list" and the "als-info" script that you can find here:
http://www.alsa-project.org/main/index.php/Help_To_Debug

If it's of any help for you, here is my conversation with Colin on the PA list:
https://tango.0pointer.de/pipermail/pulseaudio-discuss/2009-September/005031.html

Good luck!

Revision history for this message
Daniel Ellis (danellisuk) wrote :

I have just tested this issue on the Dell Mini 9 and it appears to now be fixed. I had always believed the stuttering to be due to the CPU being maxed out. See my post on this duplicate bug https://bugs.launchpad.net/ubuntu/+source/alsa-lib/+bug/275046/comments/26

On my fully up to date Karmic install, recording using gnome-sound-recorder now works, even when encoding to ogg. The CPU is no longer maxed out, (both CPU threads are about 50%).

I am only guessing here, but I expect that the process of recording from the mic, then being processed by pulse audio and finally encoding to ogg was previously too much for the ATOM processor. I would guess that the processing by pulse audio included sample rate conversion and mixing. Therefore in Jaunty, recording worked when either removing pulse, or simply by recording directly to wav rather than to ogg.

Maybe there have been improvements to pulse audio that reduces the load on the CPU caused by it's processing, maybe it no longer needs to perform sample rate conversion or mixing. I would like to find out if anyone knows. But anyway it appears to be working so excellent work, whoever was involved!

Thanks!

Revision history for this message
richard laurenson (frrichardlaurenson) wrote :

just updated ACER Aspire one... Broke recording sound totally....
GRR.... do I switch again to esound.....

Revision history for this message
Rodrigo Virote Kassick (kassick) wrote :

Richard,

Sound recording is broken on which application ?

Here is my situation at the moment:

* gnome-sound-recorder [works]
* gstreamer-properties test [works]
* twinkle soft phone [works] [1]

* skype-2.1.0.47beta [ does not work with pulse. Remove pulse, it works as a
charm]
* skype-2.0 [ does not work. recognizes alsa devices, but does
not work with current pulse ]
* ekiga [ does not work -- ptlib issues ]
* gizmo [ does not work with eighter oss nor alsa ]
* empathy [ does not work. Volume meter on call dialog show
mic as if it was ok, but I get no sound back on the echo service ] [2]
* pidgin [ almost works -- mic seems to be too low (even
on 100%) and there is lots of cracking in the audio ] [2]

[1] Tested some voip phones, twinkle was the only one that really worked. It
uses OSS api.
[2] Tested with <email address hidden> via google talk

While testing with the collabora echo service, I tried the !playmusic
command with both pidgin and empathy. I can here audio with no problem, so
it the recording issue should not be related to lack of codecs.

On Wed, Nov 4, 2009 at 5:50 PM, richard laurenson <
<email address hidden>> wrote:

> just updated ACER Aspire one... Broke recording sound totally....
> GRR.... do I switch again to esound.....
>
> --
> Recording from microphone stutters when pulseaudio is running
> https://bugs.launchpad.net/bugs/354620
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Rodrigo Virote Kassick
(kàzic)
------------------------------------------------------------

tags: added: regression-release
removed: regression-potential
Revision history for this message
blackest_knight (blackest-knight) wrote :

I am currently running karmic on a fresh install on an aspire one.
Pulseaudio doesn't give a connector to have a choice between the internal mic or external mic jack.

alsamixer does have a choice of i-mic or e-mic it just doesn't make a difference.
skype uses pulseaudio server local for audio and the only way to get input is to plug in an external mic, the sound quality sounds like a fish and chipshop reducing mic gain helps a little but then audio is far to quiet.

linphone uses alsa default device
again only the external mic input works with better audio quality than skype

switching between inputs in alsamixer makes no difference.

i am willing to carry out any tests or experiments and report back the results. I'd like to see this basic functionality restored.

Revision history for this message
Daniel T Chen (crimsun) wrote :

@blackest_knight
A fresh install has outdated linux drivers. You should install
linux-backports-modules-alsa-karmic-generic (and reboot).

Revision history for this message
blackest_knight (blackest-knight) wrote :

linux-backports-modules-alsa-karmic-generic installed

result exactly as reported in post #36

thank you for taking the time to work with this issue, what to do next?

Revision history for this message
Anthony Hook (anthonyhook) wrote :

I'm going to unsubscribe to this bug as it doesn't effect either of my laptops anymore.

Karmic Koala on:
Dell XPS M1530
Asus EEE 1000

Revision history for this message
blackest_knight (blackest-knight) wrote :

linux-backports-modules-alsa-karmic-generic-pae 2.6.31.17.30 came along in updates today
seems to be slightly worse losing the option to switch between i-mic and e-mic. in alsamixer

Revision history for this message
Daniel T Chen (crimsun) wrote :

On Sat, Dec 19, 2009 at 2:52 PM, blackest_knight
<email address hidden> wrote:
> linux-backports-modules-alsa-karmic-generic-pae 2.6.31.17.30 came along in updates today
> seems to be slightly worse losing the option to switch between i-mic and e-mic. in alsamixer

Mic autoswitching is done based on jack detection.

Revision history for this message
blackest_knight (blackest-knight) wrote :

ok with skype launched as skype using pulseaudio the only working mike was the external.

launching skype with
/bin/sh -c "PULSE_SERVER=127.0.0.1 skype" (this bypasses pulseaudio without uninstalling it)

I can confirm the autosense on the mic works and successfully switched between internal and external microphones.

Revision history for this message
Daniel T Chen (crimsun) wrote :

Resolved in lucid

Changed in pulseaudio (Ubuntu):
status: Confirmed → Fix Released
IvanS (mp5)
Changed in pulseaudio (Ubuntu):
status: Fix Released → Fix Committed
Revision history for this message
mojo risin (lamfried-morr) wrote :

Hi, I have this problem still on ubuntu 10.04. I have not found a solution yet, though .

Revision history for this message
mojo risin (lamfried-morr) wrote :

The work around postest by blackest knight works for skype , but it is only temporary solution isn't it?(it does not resolve the problem with all other sound recording after all)

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Luiz Angelo Daros de Luca (luizluca) wrote :

Is this really fixed? I get the same problem in kubuntu 10.10 (updated)
The hack from knight works but it is just a workarround.

Revision history for this message
Anton Gladky (gladky-anton) wrote :

I have also exactly the same problem with Ubuntu Lucid 10.04

knight's hack works also, thanks. But....workaround.....

Actually, the same problem occurred on 10.10. I have Dell Inspiron 1501.

Revision history for this message
Anton Gladky (gladky-anton) wrote :

Workaround works, but in this case WEB-cam does not work with Skype.

Revision history for this message
Anton Gladky (gladky-anton) wrote :

Maybe this workaround will be helpful for somebody:

http://ohioloco.ubuntuforums.org/showpost.php?p=9288726&postcount=39

-sudo gedit /etc/pulse/default.pa

and added tsched=0 to

load-module module-detect

- sudo gedit /etc/pulse/daemon.conf

changed realtime-priority = 5 to realtime-priority = 8

Revision history for this message
Joseph P. SKUDLAREK (jskud-launchpad) wrote :

I tried the PulseAudio workaround of using tsched=0 and realtime-priority=8, and that did not work for me using an up-to-date 10.10 install on an Acer Aspire One D255.

I was able to use the "PULSE_SERVER=127.0.0.1" skype workaround, and that worked well enough, and video stayed working (contrary to post #48). A call to Skype Echo / Sound Test Service worked fine.

Oddly, when I used Sound Recorder it didn't work with the internal mic, but it did with an external mic, and after I unplugged it, the internal mic worked, but it was very quiet.

Also, when I skyped to another machine, I got some automatic gain control going on (but it was disabled in Skype), so there was this throbbing effect.

Bottom Line: best results (and only real success) with "PULSE_SERVER=127.0.0.1 skype".

FYI. /Jskud

Revision history for this message
Jerryh8391 (jerryh8391) wrote :

launching skype with
/bin/sh -c "PULSE_SERVER=127.0.0.1 skype" (this bypasses pulseaudio without uninstalling it)
Worked for me.
Running 11.04

Revision history for this message
João Miguel Lopes Moreira (jmlm-1970) wrote :

The only solution to make microphone work is to install linux-backports-modules-alsa-generic...

Just go to:

Menu / System / Administration / Synaptic Package Manager

And search and mark for installation:

linux-backports-modules-alsa-generic

tip: if you have multiple versions click on the first and read the description which should inform what name to install...

If after the reboot and mic mute is off, still does not work, just go to terminal and type:

sudo nano /etc/modprobe.d/alsa-base.conf

and add or change the following:

options snd-hda-intel model=auto enable=yes

Then Ctrl+X, type Y to write and exit, reboot and mic will work.

Bye and have lots of fun with Ubuntu (the best).

Revision history for this message
Toni Aittoniemi (toni-k-aittoniemi) wrote :

Same problem still with Acer Aspire One and Asus eeePC 704, only now linux-backports-modules-alsa-generic doesn't seem available through synaptic any more.

Revision history for this message
Toni Aittoniemi (toni-k-aittoniemi) wrote :

Sorry, forgot to add, running Linux Mint 14 which is based on ubuntu 12.04. Bug still exists, but the backports not being available via Mint's Synaptic (multiverse should be enabled by default, they say) is not a Ubuntu problem..

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers