Gnome login sound has glitches

Bug #326205 reported by Patrice Vetsel on 2009-02-06
42
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: pulseaudio

For the first time since dapper, my notebook has bad gnome login sound (glitches).

kagou@satori:~$ cat /proc/asound/cards
 0 [V8235 ]: VIA8233 - VIA 8235
                      VIA 8235 with VIA1612A at 0x1400, irq 22
 1 [modem ]: VIA82XX-MODEM - VIA 82XX modem
                      VIA 82XX modem at 0x1800, irq 22
kagou@satori:~$ dpkg -l | grep pulseaudio
ii gstreamer0.10-pulseaudio 0.10.13-2 GStreamer plugin for PulseAudio
ii pulseaudio 0.9.14-0ubuntu3 PulseAudio sound server
ii pulseaudio-esound-compat 0.9.14-0ubuntu3 PulseAudio ESD compatibility layer
ii pulseaudio-module-gconf 0.9.14-0ubuntu3 GConf module for PulseAudio sound server
ii pulseaudio-module-hal 0.9.14-0ubuntu3 HAL device detection module for PulseAudio s
ii pulseaudio-module-x11 0.9.14-0ubuntu3 X11 module for PulseAudio sound server
ii pulseaudio-utils 0.9.14-0ubuntu3 Command line tools for the PulseAudio sound

kagou@satori:~$ pulseaudio --dump-conf
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
N: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
### Read from configuration file: /etc/pulse/daemon.conf ###
daemonize = no
fail = yes
high-priority = no
nice-level = -11
realtime-scheduling = no
realtime-priority = 5
disallow-module-loading = no
disallow-exit = no
use-pid-file = yes
system-instance = no
no-cpu-limit = no
disable-shm = no
exit-idle-time = 20
module-idle-time = 20
scache-idle-time = 20
dl-search-path = /usr/lib/pulse-0.9/modules/
default-script-file = /etc/pulse/default.pa
load-default-script-file = yes
log-target = auto
log-level = notice
resample-method = speex-float-1
disable-remixing = no
disable-lfe-remixing = yes
default-sample-format = s16le
default-sample-rate = 44100
default-sample-channels = 2
default-fragments = 8
default-fragment-size-msec = 10
shm-size-bytes = 0
rlimit-fsize = -1
rlimit-data = -1
rlimit-stack = -1
rlimit-core = -1
rlimit-as = -1
rlimit-rss = -1
rlimit-nproc = -1
rlimit-nofile = 256
rlimit-memlock = -1
rlimit-locks = -1
rlimit-sigpending = -1
rlimit-msgqueue = -1
rlimit-nice = 31
rlimit-rtprio = 9
rlimit-rttime = 1000000
kagou@satori:~$

 affects ubuntu/pulseaudio
 status confirmed

Changed in pulseaudio:
status: New → Confirmed
Changed in pulseaudio:
importance: Undecided → Medium
milestone: none → jaunty-alpha-5
Daniel T Chen (crimsun) wrote :

Do you find this symptom to be constant, or do the glitches resolve gradually during/after the login sound plays?

Daniel T Chen (crimsun) wrote :

Also, if you change line 61 in /etc/pulse/default.pa to read:
load-module module-hal-detect tsched=0
do the symptoms disappear when you log out and back into GNOME?

I have an identical to the OP.
For me the sound seems fine for the login drum roll; glitchy for the whole of the startup fanfare; seems fine after that.

The suggested change to line 61 makes it worse.

What versions of pulseaudio and libasound2 are installed?

4listair <email address hidden> wrote:

>I have an identical to the OP.
>For me the sound seems fine for the login drum roll; glitchy for the whole of the startup fanfare; seems fine after that.
>
>The suggested change to line 61 makes it worse.
>
>--
>Gnome login sound has glitches
>https://bugs.launchpad.net/bugs/326205
>You received this bug notification because you are a member of Ubuntu
>Audio Team, which is subscribed to pulseaudio in ubuntu.

versions:
pulseaudio - 0.9.14-0ubuntu4
libasound2 - 1.0.18-1ubuntu4

Patrice Vetsel (vetsel-patrice) wrote :

@Daniel T Chen :

Do you find this symptom to be constant, or do the glitches resolve gradually during/after the login sound plays?
-> glitches only in gnome login

Also, if you change line 61 in /etc/pulse/default.pa to read:
load-module module-hal-detect tsched=0
do the symptoms disappear when you log out and back into GNOME?
-> yes after modifications+reboot

What versions of pulseaudio and libasound2 are installed?
-> libasound2 1.0.18-1ubuntu4 + pulseaudio 0.9.14-0ubuntu4 and gstreamer0.10-pulseaudio 0.10.13-2

Artem Popov (artfwo) wrote :

I've been having glitches not only with the login sound, but with ogg123 (default settings) as well. Guess it had something to do with PulseAudio's ALSA emulation, because switching ogg123 to ALSA device hw:0,0 got rid of the glitches.

The "load-module module-hal-detect tsched=0" line fixed the login sound and ogg123 as well. Thanks for the tip!

Daniel T Chen (crimsun) wrote :

lowering severity due to extant workaround

Changed in pulseaudio:
importance: Medium → Low
Daniel T Chen (crimsun) on 2009-02-14
Changed in pulseaudio:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 0.9.14-0ubuntu6

---------------
pulseaudio (0.9.14-0ubuntu6) jaunty; urgency=low

  * 0004_disable_autospawn.patch: Disable this patch. Doing so
    allows the daemon to spawn if not already running, which
    works around LP: #191027, #204272
  * 0012_clarify_driver_error_redirect_to_alsa_devs.patch:
    - Only log POLL* being set if tsched is used so that syslog
      isn't filled with innocuous messages when we set tsched=0
      (see 0030 below) (LP: #323712),
    - Hint 'linux' source package instead of 'alsa-driver' for
      Launchpad bug reports,
    - The debug-specific portion is only applicable to 0.9.14;
      0.9.15 enables a rate limiting module by default to work
      around this (and other) issues
  * 0029_fix_suspend_on_idle_null_race.patch: Handle sink case,
    too
  * 0030_set_tsched0.patch: Work around a shedload of (driver)
    bugs by falling back to interrupt-based buffer semantics
    (LP: #190754, #292880, #295519, #298494, #301755, #302964,
     LP: #319118, #323976, #324103, #326205, #326864)
  * Backport fixes from git HEAD:
    - 0031_fix_6chan_map.patch,
    - 0032_reinit_proplist.patch,
    - 0033_fix_pa-gcc-packedmalloc.patch,
    - 0034_bt_fixes.patch
  * Make invoking the stop target in the initscript not fail an
    upgrade (LP: #317921)
  * Previous upload (0.9.14-0ubuntu3) fixed LP: #321357
  * 01PulseAudio: use sudo -H to ensure that $HOME is, in fact,
    the user's when invoking pacmd for suspend/resume

 -- Daniel T Chen <email address hidden> Sun, 15 Feb 2009 02:35:26 -0500

Changed in pulseaudio:
status: Fix Committed → Fix Released

Hmm...I've got pulse-audio 0.9.14-0ubuntu10 (on a 9.04-system) installed here. Log-in sound is cracking again.
Bug should be re-opened.
cat /proc/asound/cards
 0 [Intel]: HDA-Intel - HDA Intel
                HDA Intel at 0xfe220000 irq 17

Seems to be solved, with the latest updates. :-D

Tobias Krais (tux-spam) wrote :

Hi all,

having same issue here: Gnome login sound (only login soung) is glitching (first thought there is something sparkling in my notebook). The suggested fix does not work for me.

Please reopen.

Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
pulseaudio 1:0.9.14-0ubuntu20

Greetings, Tobias

Tobias Krais (tux-spam) wrote :

Hi again,

false comment from me: I was affected by bug 316125 (https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/316125)

No use for me to reopen.

Sorry, Tobias

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers