Comment 89 for bug 275998

Rocko (rockorequin) wrote :

The notes from https://bugs.launchpad.net/dell/+bug/309508 say it's for a different subsystem id from the XPS M1530 (which is 022e instead of 0271) so I wouldn't have thought it would help.

However, haven't said that, I did briefly manage to get working with this combination:

* kernel 2.6.27-11
* alsa-base 1.0.18.dfsg-1ubuntu2
* alsa-utils 1.0.18-1ubuntu3
* linux-sound-base 1.0.17.dfsg-2ubuntu1
* pulseaudio 0.9.13-2ubuntu3 [although pulseaudio fromis not currently running - it segment faults if I try to run it]
* Audio conferencing sound capture set to ALSA (not the HDA intel card)

With this setup, the digital capture control changed the volume recording level in gnome-sound-recorder as I adjusted it. I then (foolishly) tried to run pulseaudio (which segment faulted) and subsequently the ALSA capture device stopped working - only the HDA Intel source works now, and the digital capture volume control doesn't adjust the level for this capture source. (The digital capture volume control doesn't even always appear when I restart alsa.)

The alsa 1.0.18 packages are from the jaunty repository. I tried removing everything to do with sound to revert to alsa 1.0.17 but couldn't because when I tried to revert libasound2, synaptic wanted to remove just about every other package including unrelated ones like compiz, and I ran into a problem installing libasound2-plugins (to get pulseaudio back) without uninstalling libasound2 first.