Comment 32 for bug 192888

latest update seems to have broken Michael's package, it's not recognised by firefox at all... Grrrr!

Installing newest updated version leads to crash-fest.

Installing Michaels package makes me unable to use any flash...

Showstopper, definitely.