The analogue audio does not work on the Dell USB Dock

Bug #1718824 reported by Hui Wang on 2017-09-22
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HWE Next
Critical
Hui Wang
OEM Priority Project
Critical
Alex Tu
pulseaudio (Ubuntu)
High
Hui Wang
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned

Bug Description

SRU Document:

[Impact]

If users use the latest Dell USB Dock, e.g. TB16, they will found the analog audio (lineout jack) can't work under ubuntu linux

[Test Case]

After applying the fix, users can play sound via analog speaker or lineout freely. Without the fix, users can't play sound from lineout jack.

[Regression Potential]

No any possibility to introduce regression since this fix just adding a new dock's support, it does not change any existing code.

[Other Info]

No more info here

Steps:
1. Cold boot system with BME/IE connected
2. Plug in a speaker to Line-out jack
3. Set Analog Stereo Output from Sound settings

Expected results: Line-out port can work

Actual results: Line-out port not work

Hui Wang (hui.wang) on 2017-09-22
Changed in hwe-next:
assignee: nobody → Hui Wang (hui.wang)
importance: Undecided → Critical
Hui Wang (hui.wang) on 2017-09-22
tags: added: originate-from-1715596 somerville xenial
Hui Wang (hui.wang) on 2017-09-25
Changed in hwe-next:
status: New → In Progress
Changed in pulseaudio (Ubuntu):
status: New → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed for xenial:
https://git.launchpad.net/~ubuntu-audio-dev/pulseaudio/commit/?h=ubuntu-xenial&id=312b9b8d36b90c6bae520722cf68e01b53832eeb

But I forgot to ask: Does the same fix exist in artful already? It's part of the SRU process that the next release needs to have the fix first, before xenial.

Hui Wang (hui.wang) wrote :

@Daniel,

The fix is not in the artful and zesty, they also need this patch.

And here is the merge request for Artful and Zesty.
https://code.launchpad.net/~hui.wang/pulseaudio/+git/pulseaudio/+merge/331390

If you need me to do anything, please let me know.

Thanks.

Daniel van Vugt (vanvugt) wrote :

Sorry for the delay. More comments in the merge request.

Hui Wang (hui.wang) wrote :

Got it, i will change the merge request.

Hui Wang (hui.wang) wrote :

The new merge request for Artful and Zesty is here:
https://code.launchpad.net/~hui.wang/pulseaudio/+git/pulseaudio/+merge/332335

thanks.

Daniel van Vugt (vanvugt) wrote :
Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Committed
importance: Critical → High
Daniel van Vugt (vanvugt) wrote :

In theory next step is to create a debdiff, attach it here, and subscribe ubuntu-sponsors to the bug.

In practice being release week for 17.10 this might now be called an SRU so you might also be asked to add SRU documentation in the bug description:

https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

Hui Wang (hui.wang) on 2017-10-18
description: updated
Hui Wang (hui.wang) on 2017-10-18
description: updated
Hui Wang (hui.wang) wrote :

debdiff for Artful and Zesty

Hui Wang (hui.wang) wrote :

This is for Xenial.

tags: added: ubuntu-sponsors
Hui Wang (hui.wang) wrote :

@ubuntu-sponsors team,

We added a fix to pulseaudio (xenial and artful), Please help build a new SRU version.

thx.

Hui Wang (hui.wang) wrote :

@Daniel,

Who will trigger the SRU build for pulseaudio?

thx.

Daniel van Vugt (vanvugt) wrote :

A member of ubuntu-sponsors will. That's all I know :)

https://launchpad.net/~ubuntu-sponsors

Jonathan Riddell (jr) wrote :

I added your xenial debdiff to the one from #1728791 and uploaded

Your artful/zenial debdiff seems to be confused and removes 0001-Cherrypick-one-upstream-commit-to-support-audio-on-t.patch and stuff from debian/changelog

Jonathan Riddell (jr) on 2017-11-09
tags: added: verification-needed
tags: added: verification-needed-xenial
removed: verification-needed
Hui Wang (hui.wang) wrote :

@Daniel,

OK, will do it today.

Hui Wang (hui.wang) wrote :

Upgraded the pulseaudio from -proposed, and verified the dock analog audio (lineout + speaker) worked well.

changed verification-needed-xenial to verification-done-xenial

tags: added: verification-done-xenial
removed: verification-needed-xenial
Changed in hwe-next:
status: In Progress → Fix Committed
Jonathan Riddell (jr) wrote :

I'm afraid I had to upload it again as the bug 1728791 patch was incorrect. Please verify again
https://launchpad.net/ubuntu/+source/pulseaudio/1:8.0-0ubuntu3.6

tags: added: verification-needed-xenial
removed: verification-done-xenial
Hui Wang (hui.wang) wrote :

Sorry, forgot to add conf file to build sys, then the conf file (dell-dock-tb16-usb-audio.conf) is not installed to /usr/share/pulseaudio/profile-sets/.

I will send a patch to upstream to fix it first, then backport it to Xenial and Artful.

Changed in pulseaudio (Ubuntu):
status: Fix Committed → Triaged
tags: added: verification-failed-xenial
removed: verification-needed-xenial
Changed in hwe-next:
status: Fix Committed → Triaged
Hui Wang (hui.wang) on 2017-11-14
Changed in pulseaudio (Ubuntu):
status: Triaged → In Progress
Changed in hwe-next:
status: Triaged → In Progress
Hui Wang (hui.wang) wrote :

@Daniel,

The commit https://git.launchpad.net/~ubuntu-audio-dev/pulseaudio/commit/?h=ubuntu-xenial&id=312b9b8d36b90c6bae520722cf68e01b53832eeb is not sufficient to fix this problem, this commit only adds the conf file in the source repository, but forgot to add the conf in the build-sys. I already submitted a simple patch to upstream to fix it, but looks like the maintainer is on vacation, he has not shown up in the maillist for several days.

I am wondering if we could merge this simple fix ahead of upstream, if we could, may I send an independent commit and set the version to 1:8.0-0ubuntu3.6; or you revert my previous commit, then I send one commit which contains both my previous commit and this new simple fix?

And the simple fix like this:

src/Makefile.am | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/src/Makefile.am b/src/Makefile.am
index e610db7..0348250 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1312,7 +1312,8 @@ dist_alsaprofilesets_DATA = \
   modules/alsa/mixer/profile-sets/native-instruments-korecontroller.conf \
   modules/alsa/mixer/profile-sets/kinect-audio.conf \
   modules/alsa/mixer/profile-sets/sb-omni-surround-5.1.conf \
- modules/alsa/mixer/profile-sets/steelseries-arctis-usb-audio.conf
+ modules/alsa/mixer/profile-sets/steelseries-arctis-usb-audio.conf \
+ modules/alsa/mixer/profile-sets/dell-dock-tb16-usb-audio.conf

 if HAVE_UDEV
 dist_udevrules_DATA = \
--
2.7.4

Alex Tu (alextu) on 2017-12-27
tags: added: lp1732372
Alex Tu (alextu) on 2017-12-27
Changed in oem-priority:
assignee: nobody → Alex Tu (alextu)
importance: Undecided → Critical
status: New → Triaged
tags: added: sru
Hui Wang (hui.wang) wrote :

@ubuntu-sponsors team,

This is debdiff generated against the old version 3.7, it is for Xenial. The OEM project is waiting for the version 3.8 to be ready to fix an OEM bug.

thx.

Hui Wang (hui.wang) wrote :

@ubuntu-sponsors team,

This is for Artful, it is generated against the version 10.0-2ubuntu3.

thx.

Timo Aaltonen (tjaalton) wrote :

is this fixed in bionic?

Daniel van Vugt (vanvugt) wrote :

Presently it appears the answer is no.

Looks like I dropped it accidentally from bionic during the upgrade to 11.1 here:
https://git.launchpad.net/~ubuntu-audio-dev/pulseaudio/commit/?h=ubuntu&id=8ae405b0045cda62d74e736c8969a8ee3f034938

Although the fixes are upstreamed in master, I don't think they're upstreamed in 11.x.

Daniel van Vugt (vanvugt) wrote :

Let's see if I can give you a debdiff to fix bionic right now...

Daniel van Vugt (vanvugt) wrote :

Debdiff for bionic. Includes LP: #1732629 too, which was awaiting sponsorship already.

Hui Wang (hui.wang) wrote :

@Daniel,

To fix this issue, we also need an extra commit for Bionic: https://git.launchpad.net/~ubuntu-audio-dev/pulseaudio/commit/?h=ubuntu-artful&id=756ecf3f69932d79eebf604899283266bd28f5de

I added it into the xenial(#21) and artful(#22) already, but looks like this commit is missing in the #26.

Daniel van Vugt (vanvugt) wrote :

Ah OK. So me accidentally removing the patch didn't matter so much. That new part was always missing from bionic. Feel free to fix it up in git...

Daniel van Vugt (vanvugt) wrote :

Actually it seems the fix for this bug was never released in bionic. Only partially committed in git.

Daniel van Vugt (vanvugt) wrote :

Hui,

To be sure we have everything, please add to the 'ubuntu' branch for bionic:
https://git.launchpad.net/~ubuntu-audio-dev/pulseaudio/log/?h=ubuntu

Timo Aaltonen (tjaalton) wrote :

ping me on irc once x/a/b are ready for sponsoring :)

Hui Wang (hui.wang) wrote :

This is for bionic.

Timo Aaltonen (tjaalton) wrote :

all sponsored, with minor edits to xenial & artful changelogs

Daniel van Vugt (vanvugt) wrote :

Thanks Timo.

Hui: It's now in bionic-proposed. Can you test it with the Dell dock?

https://launchpad.net/ubuntu/+source/pulseaudio/1:11.1-1ubuntu3

Daniel van Vugt (vanvugt) wrote :

And verification failed. See bug 1742750 now.

Hui Wang (hui.wang) wrote :

@Daniel,

Got it, waiting for 1:11.1-1ubuntu4 is ready. Then will do the test.

Hui Wang (hui.wang) wrote :

@Alex,

1:11.1-1ubuntu4 is ready for bionic, when you have time, please help test it.

thx.

Robie Basak (racb) wrote :

I see pulseaudio in the SRU queue for stable releases. But this bug doesn't appear to be fixed in Bionic yet, and AFAICT you have tried multiple times to fix it in Bionic so it isn't clear to me that the uploads for the stable releases are still current.

Please confirm what you want doing with the existing stable uploads in their queues, and please make sure the bug is Fix Released (and confirmed fixed) in Bionic before uploading anything more to the stables to avoid confusion.

Daniel van Vugt (vanvugt) wrote :

Indeed we need to get this fix released in bionic first.

Possibly confusing is that "LP: #1718824" is only mentioned in the changelog entry for "1:11.1-1ubuntu3" and not "1:11.1-1ubuntu4". But the fix is still there in both.

Brian Murray (brian-murray) wrote :

I believe what Robie is looking for is an answer to the question - "Should we reject the uploads currently in the -proposed queue?"

From my skimming of the bug report it seems like the fix in 1:11.1-1ubuntu3 was incomplete hence the need for the upload of 1:11.1-1ubuntu4 and why we are asking about the existing SRUs.

Hui Wang (hui.wang) wrote :

Just checked the pulseaudio_11.1-1ubuntu4_amd64.deb, the dell-dock-tb16-usb-audio.conf is in it, and will be put to the folder /usr/share/pulseaudio/alsa-mixer/profile-sets when installing this package. That is expected, so the bug 1718824 should be fixed in this version.

I didn't test it on real hardware since I don't have the hardware, the hardware is in Taipei office.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pulseaudio (Ubuntu Artful):
status: New → Confirmed
Changed in pulseaudio (Ubuntu Xenial):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Does the fix also work for WD15? (see bug 1745765)

Daniel van Vugt (vanvugt) wrote :

Please note pulseaudio 1:11.1-1ubuntu4 is stuck in bionic-proposed due to an unrelated bug in gsequencer (bug 1743511). It appears that will be resolved and unblocked by gsequencer 1.3.6-1 getting out of proposed and into bionic proper.

An upload of pulseaudio to artful-proposed has been rejected from the upload queue for the following reason: ""Based off comment #42 it seems the fix in bionic doesn't match the SRU i.e. the SRUs are still missing whatever change went into 1:11.1-1ubuntu4 so I'm rejecting this upload."".

Brian Murray (brian-murray) wrote :

An upload of pulseaudio to xenial-proposed has been rejected from the upload queue for the following reason: ""Based off comment #42 it seems the fix in bionic doesn't match the SRU i.e. the SRUs are still missing whatever change went into 1:11.1-1ubuntu4 so I'm rejecting this upload."".

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:11.1-1ubuntu4

---------------
pulseaudio (1:11.1-1ubuntu4) bionic; urgency=high

  * 0030-load-module-switch-on-connect.patch: Correct typo in default.pa
    causing pulseaudio startup failure. (LP: #1742750, LP: #1732629)
  * Refresh patches to apply more cleanly:
    - 0802-alsa-mixer-Add-support-for-usb-audio-in-the-Dell-doc.patch
    - 0803-build-sys-add-the-Dell-dock-TB16-configuration.patch

 -- Daniel van Vugt <email address hidden> Fri, 12 Jan 2018 10:23:11 +0800

Changed in pulseaudio (Ubuntu):
status: In Progress → Fix Released
Changed in pulseaudio (Ubuntu):
status: Fix Released → In Progress
status: In Progress → Fix Released
Daniel van Vugt (vanvugt) wrote :

Sorry for the confusion. Comment #49 appeared at a time when 1:11.1-1ubuntu4 had _vanished_ from the archive. So for a while it was not "released".

Then minutes later, vorlon uploaded a new proposed version 1:11.1-1ubuntu5, and 1:11.1-1ubuntu4 reappeared too:

https://launchpad.net/ubuntu/+source/pulseaudio

Now released.

Hui Wang (hui.wang) wrote :

Reply comment #45:

Yes, it also fix the bug 1745765.

tags: removed: verification-failed-xenial
Hui Wang (hui.wang) wrote :

Tested Bionic 1:11.1-1ubuntu6, this bug is fixed by pulseaudio 1:11.1-1ubuntu6.

Please put artful 1:10.0-2ubuntu4 and xenial 1:8.0-0ubuntu3.8 to proposed channel.

I will test them later.

thanks.

tags: added: verification-done-bionic
Timo Aaltonen (tjaalton) wrote :

hwang: They need to be recreated to match what went in bionic, also the artful version should be -2ubuntu3.1

Hui Wang (hui.wang) wrote :

This is debdiff for xenial, it is generated against pulseaudio_8.0-0ubuntu3.7.dsc.

Thanks.

Hui Wang (hui.wang) wrote :

This is debdiff for artful, it is generated against pulseaudio_10.0-2ubuntu3.dsc.

Thanks.

Hui Wang (hui.wang) wrote :

reply #47 and #48:

To fix this bug (#1718824), the pulseaudio_11.1-1ubuntu3.debdiff is enough. As a result, the pulseaudio_8.0-0ubuntu3.8.debdiff and the pulseaudio_10.0-2ubuntu3.1.debdiff are basically identical to pulseaudio_11.1-1ubuntu3.debdiff.

They do not contain the content of pulseaudio_11.1-1ubuntu4.debdiff because the 1ubuntu4.debdiff want to fix a regression introduced by commit 41782240, this commit is not applied to artful and xenial, so for 0ubuntu3.8.debdiff and 2ubuntu3.1.debdiff, they don't need the content of 1ubuntu4.debdiff.

Hello Hui, or anyone else affected,

Accepted pulseaudio into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:10.0-2ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pulseaudio (Ubuntu Artful):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Hello Hui, or anyone else affected,

Accepted pulseaudio into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pulseaudio/1:8.0-0ubuntu3.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in pulseaudio (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed-xenial
Alex Tu (alextu) wrote :

verified on Italia (201712-26024) with image X84, it passed with pulseaudio/1:8.0-0ubuntu3.8

tags: added: verification-done-xenial
removed: verification-needed-xenial
Hui Wang (hui.wang) on 2018-02-22
tags: added: verification-done-artful
removed: verification-needed-artful
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:10.0-2ubuntu3.1

---------------
pulseaudio (1:10.0-2ubuntu3.1) artful; urgency=medium

  * Cherrypick fixes for supporting audio on Dell dock TB16:
    - 60c0edd5: Add support for usb audio on the Dell dock TB16 (LP: #1718824)
    - 2f1dcea3: build-sys: add the Dell dock TB16 configuration (LP: #1718824)

 -- Hui Wang <email address hidden> Tue, 19 Dec 2017 15:16:57 +0800

Changed in pulseaudio (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for pulseaudio has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pulseaudio - 1:8.0-0ubuntu3.8

---------------
pulseaudio (1:8.0-0ubuntu3.8) xenial; urgency=medium

  [Hui Wang]
  * Cherrypick fixes for supporting audio on Dell dock TB16:
    - 60c0edd5: Add support for usb audio on the Dell dock TB16 (LP: #1718824)
    - 2f1dcea3: build-sys: add the Dell dock TB16 configuration (LP: #1718824)

  [Daniel van Vugt]
  * Tidy up: Rename 0901-droid-fix-crash-on-module-load.patch to
                    0803-droid-fix-crash-on-module-load.patch

 -- Daniel van Vugt <email address hidden> Tue, 12 Dec 2017 11:44:08 +0800

Changed in pulseaudio (Ubuntu Xenial):
status: Fix Committed → Fix Released
Hui Wang (hui.wang) on 2018-03-08
tags: added: verification-done
removed: verification-needed
Alex Tu (alextu) on 2018-03-20
Changed in oem-priority:
status: Triaged → Fix Released
Hui Wang (hui.wang) on 2018-05-13
Changed in hwe-next:
status: In Progress → Fix Released
benste (benste) wrote :

It looks like this fix actually created a regression bug wich might be related to the workaround implemented before ... Not sure but curent situation is that it does no longer work correctly ...

benste (benste) wrote :

Regression bug occured because the line-out was working before, only the headphones out didn't now neither of them work

Hui Wang (hui.wang) wrote :

@benste,

Please upload the log of "pactl list". Let me take a look.

thx.

benste (benste) wrote :

here you go... Would it be ok to reopen the status of the bug and tag it with regression?

Daniel van Vugt (vanvugt) wrote :

This bug is closed. If a regression has occurred then please open a new bug by running:

ubuntu-bug pulseaudio

Hui Wang (hui.wang) wrote :

@benste,

The log in the #67 looks good, I can't find problem in it.

After we confirmed this is a problem/regression, then reopen the status. But I don't think the change can make line-out stop working if it works before.

If you want line-out or headphone of dock station to work, after plug it, please verify "pactl info" first, make sure the "Default Sink" is "alsa_output.usb-Generic_USB_Audio..." instead of "alsa_output.pci-0000_00_1f...", And if you want to change the default sink or the output profile (headphone or lineout0 of usb dock, you can open sound-settings to choose (system settings--->sound settings).

If the description of above doesn't work, please upload an alsa-info.txt (run alsa-info.sh to generate alsa-info.txt).

thx.

benste (benste) wrote :

Hi there, i've created another new bug - https://bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1772383 and subscribed you to it. looking forward to any ideas.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers