Brother p-touch ql 550 foomatic-rip failed in 12.04

Bug #990638 reported by Peter Martin on 2012-04-28
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ptouch-driver (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

after upgrading to 12.04 i got the message "foomatic-rip failed" when printing to Brother P-Touch QL 560. It was running without any problems in 11.10

Peter Martin (peter-m--art--in) wrote :

see attachment for more details

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in foomatic-filters (Ubuntu):
status: New → Confirmed
Martin Dunn (dunn-martin) wrote :

Confirming - Same printer model working with ql-550 ptouch-driver in 11.04 and 11.10, failing exactly as described above in fresh 12.04 install (not an upgrade)

evins (evins) wrote :

Confirming - Same problem with QL-500. Works with 11.10 but not in 12.04.

I have managed to get it working, mostly*:

By setting the cups logLevel to debug2, I get "/bin/bash: rastertoptch: command not found." rastertoptch is installed in /usr/lib/i386-linux-gnu/cups/filter but all other filters are installed in /usr/lib/cups/filter. So I tried creating a symbolic link to it in /usr/lib/cups/filter. Now I get "/bin/bash: /usr/lib/cups/filter/rastertoptch: Permission denied."

A little more digging, I found that apparmor is not allowing access to this lone filter. So rather than the symbolic link, I actually copied the executable to /usr/lib/cups/filter. Now the printer works.

So it appears that the 12.04 package throws the rastertoptch filter under /usr/lib/i386-linux-gnu/cups rather than /usr/lib/cups and cups is not configured to look for it there.

* Although I now have the printer working, it does not always advance between labels.

Martin Dunn (dunn-martin) wrote :

Thanks evins,

This fix works for me too. In 64bit, rastertoptch is under /usr/libs/x86_64-linux-gnu/cups/filter/

The advancing between labels problem was present in the previous versions, although I could live with that by printing each label singularly. I also need to open/close the lid to use the cutter - again a 'feature' of previous versions.

Martin Dunn (dunn-martin) wrote :

Not entirely out of the woods with this one. Print quality is awful..
Tried a number of options in the print dialog.. no improvement.

affects: foomatic-filters (Ubuntu) → ptouch-driver (Ubuntu)
Changed in ptouch-driver (Ubuntu):
importance: Undecided → Medium
status: Confirmed → In Progress
Till Kamppeter (till-kamppeter) wrote :

Uploaded fix to Quantal. Note that this only fixes the wrongly placed filter, not the print quality.

Changed in ptouch-driver (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ptouch-driver - 1.3-3ubuntu1

---------------
ptouch-driver (1.3-3ubuntu1) quantal; urgency=low

  * debian/rules: Override automatic multiarch for all files in /usr/lib
    which is used in dh with compat 9, by using
    "dh_auto_configure -- --libdir=/usr/lib" (LP: #990638).
 -- Till Kamppeter <email address hidden> Fri, 25 May 2012 20:29:23 +0200

Changed in ptouch-driver (Ubuntu):
status: Fix Committed → Fix Released
Changed in ptouch-driver (Ubuntu):
importance: Medium → High
Changed in ptouch-driver (Ubuntu Precise):
status: New → Fix Committed
importance: Undecided → High
milestone: none → precise-updates
Till Kamppeter (till-kamppeter) wrote :

Fixed package uploaded to precise-proposed. As soon as it gets approved, another comment with installation instructions will be posted. Please test the package then on your 12.04 (Precise) system and tell us your result. Only with your feedback we can make this package an official update.

debdiff of the changes is attached.

Hello Peter, or anyone else affected,

Accepted ptouch-driver into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Dunn (dunn-martin) wrote :

Still have problem with print quality compared to 11.10. Is anyone else having this issue? The printer remains unusable on 12.04 for me.

Martin, the print quality issues are not covered by this SRU. Please make sure you get the SRU for cups-filters (1.0.18, already released) and for CUPS (1.5.3, in -proposed) installed on your system and check whether this solves the quality issue.

The problem of the location of the filter file seems to be fixed for you, marking bug as verified.

Thank you for testing.

tags: added: verification-done
removed: verification-needed
Martin Dunn (dunn-martin) wrote :

Till,

Print quality issues solved by cups updates in -proposed.
Installation on additional fresh 12.04 machine and -proposed enabled resulted in satisfactory operation of printer as per previous Ubuntu releases.

Thank you very much, Martin, so I know that all is fine now with ptouch.

Michael Markstaller (makki) wrote :

Installed ptouch 1.3-3ubuntu0.1 from precise-proposed but still:
/usr/lib/i386-linux-gnu/cups/filter/rastertoptch
-> manually copied to /usr/lib/cups/filter/ works though

Michael, I have checked the binary packages for i386, 1md64, and armhf on Launchpad now and they all have the filter correctly placed in /usr/lib/cups/filter.

To find this out I went to

https://launchpad.net/ubuntu/+source/ptouch-driver/1.3-3ubuntu0.1

clicked on the architectures under "Builds" and on the page which appears then I downloaded the binary package via the links under "Built files". These packages I checked with

dpkg -L <package file name>

Please check on your system whether you have the correct version of the printer-driver-ptouch package installed. Please run the commands

dpkg -l | grep printer-driver-ptouch
dpkg -L printer-driver-ptouch
dpkg -S /usr/lib/i386-linux-gnu/cups/filter/rastertoptch

in a terminal window and post the output.

please also do

sudo rm /usr/lib/i386-linux-gnu/cups/filter/rastertoptch /usr/lib/cups/filter/rastertoptch
sudo apt-get install --reinstall printer-driver-ptouch

and check whether the filter gets placed correctly now.

Colin Watson (cjwatson) wrote :

"These packages I checked with

dpkg -L <package file name>"

For the record, if you're dealing with a .deb file, you need to use 'dpkg -c <package file name>', not -L. (But I checked too and I agree this looks fine.)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ptouch-driver - 1.3-3ubuntu0.1

---------------
ptouch-driver (1.3-3ubuntu0.1) precise-proposed; urgency=low

  * debian/rules: Override automatic multiarch for all files in /usr/lib
    which is used in dh with compat 9, by using
    "dh_auto_configure -- --libdir=/usr/lib" (LP: #990638).
 -- Till Kamppeter <email address hidden> Fri, 25 May 2012 20:29:23 +0200

Changed in ptouch-driver (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers