pstoedit cannot convert to SVG any more

Bug #364319 reported by thsths on 2009-04-20
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
pstoedit (Debian)
Fix Released
Unknown
pstoedit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pstoedit

pstoedit used to be able to convert to the SVG format with libplot. Now it no longer links against libplot, and so all output formats only available via libplot do not work any more.

Example:

$ pstoedit -f svg fig.eps
pstoedit: version 3.45 / DLL interface 108 (build Jan 21 2009 - release build - g++ 4.3.3 20090119 (prerelease)) : Copyright (C) 1993 - 2007 Wolfgang Glunz
Unsupported output format svg
Available formats :
...

This causes the SVG import in inkscape to fail, so it is a serious problem.

This bug may be related to https://bugs.launchpad.net/ubuntu/+source/pstoedit/+bug/343369 .

Debian (upstream?) does not have the same problem: http://packages.debian.org/sid/libpstoedit0c2a .

About me:
I am using an up to date (not quite released) Jaunty installation on AMD64.

$ apt-cache policy pstoedit
pstoedit:
  Installed: 3.45-5
  Candidate: 3.45-5
  Version table:
 *** 3.45-5 0
        500 http://uk.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

$ uname -a
Linux nvidia 2.6.28.4 #3 SMP Fri Feb 13 13:27:27 GMT 2009 x86_64 GNU/Linux

Andrew King (anders-king-00) wrote :

I can confirm this, also on Jaunty.

As a workaround I rebuilt the package (as it is - no changes/patches applied), and it now works.

(ie apt-get source pstoedit -> apt-get build-dep pstoedit -> dpkg-buildpackage -> dpkg -i).

pstoedit now has various 'plot-*' filters, in particular, plot-svg.

This also fixes latex rendering in inkscape. (see bug #123499)

Possibly only a rebuild is required?

Cheers,
Andrew

thsths (thomas-steffen+ubuntu) wrote :

Hi Andrew

No, actually a rebuild does not change anything for me. I have to install libplot-dev (which is not a build dependency), and then a rebuild will include the plot-* filters.

So I think the dependencies need to be changed, probably to include libplot-dev as build dependency, and libplot2c2 as run time dependency, but I may be missing something.

Andrew King (anders-king-00) wrote :

Hi,

You're right - I also had installed libplot-dev, and librsvg2-dev (from bug #123499). I didn't install libplot2c2, but probably had it already.

Cheers,
Andrew

Luca Citi (knulp79) wrote :

Hi!
I was also experiencing this problem.
I am using the same version as above.
I followed the workaround suggested here and it works.
But please do fix it.
Thanks,
Luca

cd /tmp/
apt-get source pstoedit
sudo apt-get build-dep pstoedit
sudo apt-get install libplot-dev librsvg2-dev
cd pstoedit-*/
dpkg-buildpackage
sudo dpkg -i ../*pstoedit*.deb

thsths (thomas-steffen+ubuntu) wrote :

I anything happening concerning this bug? It has been confirmed, it is a packaging bug, it is easy to fix... what else do we need?

Glyphobet (glyphobet) wrote :

Here is a patch to add the missing build dependencies to the debian/control file.

For people following Luca Citi's helpful instructions on how to rebuild the package properly, note that you'll need to install all three .deb package files generated by dpkg-buildpackage. Under Ubuntu 9.04, they will be named like this: libpstoedit0c2a_*_i386.deb, libpstoedit-dev_*_i386.deb, pstoedit_*_i386.deb

pliz (pliz) wrote :

Luca Citi gave a perfect solution 3 months ago and it the bug status is still undecided :( forget about fixing it using the solution. Is anyone working on it?

James Oakley (electron100) wrote :

Rebuilding also worked for me. This is really a much needed fix as Inkscape's import/export ability is severely crippled without it

Sam Liddicott (sam-liddicott) wrote :

I wish launchpad had the ability to let us offer bounty's on bugs, then canonical could hire staff based on demand.

However, I generally find for any ubuntu bug that if you wait two or three releases it gets fixed (or goes away of it's own accord).

I get this error while trying to build pstoedit with dpkg-buildpackage:

c++ -Wl,--as-needed -Wl,-O1 -shared -nostdlib /usr/lib/gcc/i486-linux-gnu/4.3.3/../../../../lib/crti.o /usr/lib/gcc/i486-linux-gnu/4.3.3/crtbeginS.o .libs/dynload.o .libs/callgs.o .libs/lexyy.o .libs/miscutil.o .libs/cbstream.o .libs/psimage.o .libs/drvbase.o .libs/base64writer.o .libs/poptions.o .libs/subpath.o .libs/pstoedit.o -ldl -L/usr/lib/gcc/i486-linux-gnu/4.3.3 -L/usr/lib/gcc/i486-linux-gnu/4.3.3/../../../../lib -L/lib/../lib -L/usr/lib/../lib -L/usr/lib/gcc/i486-linux-gnu/4.3.3/../../.. -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/i486-linux-gnu/4.3.3/crtendS.o /usr/lib/gcc/i486-linux-gnu/4.3.3/../../../../lib/crtn.o -Wl,--as-needed -Wl,-O1 -Wl,-Bsymbolic-functions -Wl,-z -Wl,defs -Wl,-O1 -Wl,-soname -Wl,libpstoedit.so.0 -o .libs/libpstoedit.so.0.0.0
/usr/lib/gcc/i486-linux-gnu/4.3.3/../../../../lib/libdl.a(dlopen.o): In function `dlopen':
(.text+0x1b): undefined reference to `__dlopen'
/usr/lib/gcc/i486-linux-gnu/4.3.3/../../../../lib/libdl.a(dlclose.o): In function `dlclose':
(.text+0x5): undefined reference to `__dlclose'
/usr/lib/gcc/i486-linux-gnu/4.3.3/../../../../lib/libdl.a(dlsym.o): In function `dlsym':
(.text+0x1b): undefined reference to `__dlsym'
/usr/lib/gcc/i486-linux-gnu/4.3.3/../../../../lib/libdl.a(dlerror.o): In function `dlerror':
(.text+0x5): undefined reference to `__dlerror'
collect2: ld returned 1 exit status

Julio Rojas (jcredberry) wrote :

I have followed Luca's procedure to solve Inkscape's problem with textext. When I try to render a equation using textex a black box appears covering the whole page. The problem is not solved by this method. Is it really related?
Thanks in advance.

bartgenuit (bartgenuit) wrote :

I tried Luca's procedure but get the error:

error in mkstemp for psin5FIFVH 13

Tillmo (till-mossakowski) wrote :

Works for me on Karmic:

~$ pstoedit -f plot-svg -page 1 -ssp -mergetext calculi.pdf calculi.svg
pstoedit: version 3.45 / DLL interface 108 (build Sep 6 2009 - release build - g++ 4.4.1) : Copyright (C) 1993 - 2007 Wolfgang Glunz
[...]

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in pstoedit (Ubuntu):
status: New → Fix Released
Nick L (nick00name) wrote :

> This bug report is being closed due to your last comment regarding this being fixed with an update.

I have Ubuntu 9.04 (Jaunty) and pstoedit version 3.45-5 (amd64 architecture) which I installed from the repository today. The format "plot-svg" does not work. I don't think it was fixed.

The status "Fix released" means it is fixed in the current development release (see [1]) -- although in this case it seems to be fixed in 9.10 and 10.04 as well. If you need a fix for the bug in previous versions of Ubuntu, please do steps 1 and 2 of the SRU Procedure [2] to bring the need to a developer's attention.

[1]: https://wiki.ubuntu.com/Bugs/Status
[2]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Changed in pstoedit (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.