psi craches on "Configure room"

Bug #664020 reported by ap0stol on 2010-10-20
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
PSI+
New
Undecided
Unassigned
psi (Ubuntu)
Undecided
Unassigned
psi-plus (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: psi

After press button "Configure room":

Program received signal SIGSEGV, Segmentation fault.
0x00e32904 in ?? () from /usr/lib/libQtGui.so.4
(gdb) bt
#0 0x00e32904 in ?? () from /usr/lib/libQtGui.so.4
#1 0x00e32a73 in QSortFilterProxyModel::mapToSource(QModelIndex const&) const
    () from /usr/lib/libQtGui.so.4
#2 0x00e2bd37 in ?? () from /usr/lib/libQtGui.so.4
#3 0x00e2becd in ?? () from /usr/lib/libQtGui.so.4
#4 0x0829357b in ?? ()
#5 0x0837fa7b in ?? ()
#6 0x013f48ca in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#7 0x014076ad in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#8 0x0837f1cb in ?? ()
#9 0x0828b006 in ?? ()
#10 0x0837f413 in ?? ()
#11 0x013f48ca in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#12 0x014076ad in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#13 0x08424c67 in ?? ()
#14 0x083cfbc3 in ?? ()
#15 0x083cfce7 in ?? ()
#16 0x0828f459 in ?? ()
#17 0x083cfdbc in ?? ()
---Type <return> to continue, or q <return> to quit---
#18 0x083c0d6c in ?? ()
#19 0x083c1b19 in ?? ()
#20 0x08424257 in ?? ()
#21 0x013f48ca in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#22 0x014076ad in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#23 0x08424a47 in ?? ()
#24 0x083906ad in ?? ()
#25 0x0842465d in ?? ()
#26 0x013f48ca in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
#27 0x013ffdf6 in QMetaCallEvent::placeMetaCall(QObject*) ()
   from /usr/lib/libQtCore.so.4
#28 0x014016a2 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
#29 0x007c5fdc in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/libQtGui.so.4
#30 0x007cc04e in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libQtGui.so.4
#31 0x013eeb3b in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /usr/lib/libQtCore.so.4
#32 0x013f1d8b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
---Type <return> to continue, or q <return> to quit---
#33 0x013f1f4d in QCoreApplication::sendPostedEvents(QObject*, int) ()
   from /usr/lib/libQtCore.so.4
#34 0x0141da74 in ?? () from /usr/lib/libQtCore.so.4
#35 0x019a2855 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#36 0x019a6668 in ?? () from /lib/libglib-2.0.so.0
#37 0x019a6848 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#38 0x0141d565 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#39 0x00887be5 in ?? () from /usr/lib/libQtGui.so.4
#40 0x013ed609 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#41 0x013eda8a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /usr/lib/libQtCore.so.4
#42 0x013f200f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#43 0x007c4e07 in QApplication::exec() () from /usr/lib/libQtGui.so.4
#44 0x08368aa3 in ?? ()
#45 0x01783ce7 in __libc_start_main () from /lib/libc.so.6
#46 0x08089621 in ?? ()
(gdb) continue
Continuing.
[Thread 0xb69d7b70 (LWP 8842) exited]
[Thread 0xb7327b70 (LWP 8841) exited]
[Thread 0xb7c0fb70 (LWP 8840) exited]
[Thread 0xb5fffb70 (LWP 8844) exited]

Program terminated with signal SIGSEGV, Segmentation fault.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: psi 0.14-2
ProcVersionSignature: Ubuntu 2.6.35-22.34~phc0-generic-phc 2.6.35.4
Uname: Linux 2.6.35-22-generic-phc i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Wed Oct 20 22:39:28 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: psi

ap0stol (x777ozon) wrote :
ap0stol (x777ozon) on 2010-10-20
tags: added: psi psi-plus
tags: added: qt segmentation
Ivan Borzenkov (ivan1986) wrote :

fixed version here

https://launchpad.net/~ivan1986/+archive/ppa

please upload in ubuntu, i can not upload in ubuntu and debian now

Ivan Borzenkov (ivan1986) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package psi-plus - 0.15~svn3910-1

---------------
psi-plus (0.15~svn3910-1) unstable; urgency=low

  * Uploader became maintainer. (Closes: #620034)
  * File debian/copyright was completely rewrited. (Closes: #610338)
  * File debian/control was updated:
    - psi-plus now depends from psi-plus-common (= ${source:Version})
    - psi-plus-webkit now depends from psi-plus-common (= ${source:Version})
    - psi-plus-plugins now depends from psi-plus-common (= ${source:Version})
      (Closes: #613232)
    - removed ${shlibs:Depends} dependences from psi-plus-common and
      psi-plus-skins packages
  * Here are no appreciable memory leaks now. (Closes: #610024)
  * File psi2psi-plus.patch was removed.
  * File debian-watch was updated.
  * New upstream release.

psi-plus (0.15~svn3775-0ubuntu1) natty; urgency=low

  * New upstream release
  * rename psi to psi-plus (9996 upstream patch)
    - add psi2psi-plus.patch for reverting if need
    - remove conflict whis psi

psi-plus (0.15~svn3753-0ubuntu1) natty; urgency=low

  * New upstream release
  * add --enable-whiteboarding

psi-plus (0.15~svn3447-1) experimental; urgency=low

  * New upstream release
  * Fixed short descriptions for psi-plus and psi-plus-webkit packages

psi-plus (0.15~svn3410-1) experimental; urgency=low

  * New upstream release (Closes: #598944, #588669)
  * Fixed lintian remarks:
    I: duplicate-long-description
    I: debian-watch-file-is-missing
    I: extended-description-is-probably-too-short
    I: conflicts-with-version psi-plus (<< 0.15~svn3057)

psi-plus (0.15~svn3396-0ubuntu1) natty; urgency=low

  * New upstream release
  * Close old Launchpad bugs (LP: #653802, #664020)
  * stop build when errors on apply patches

psi-plus (0.15~svn3386-0ubuntu1) natty; urgency=low

  * New upstream release
  * psi-plus-skins - skin plugin move to all plugins

psi-plus (0.15~svn3325-1) experimental; urgency=low

  * Upload to Debian

psi-plus (0.15~svn3325-0ubuntu1) natty; urgency=low

  * New upstream release

psi-plus (0.15~svn3216-0ubuntu1) natty; urgency=low

  * New upstream release
  * add debug packages (thanks Stefan Zerkalica)
  * psi-plus and psi-plus-webkit not conflict
  * remove libproxy-dev depend

psi-plus (0.15~svn3111-0ubuntu1) natty; urgency=low

  * New upstream release
  * update build scripts
    - fix compiled icons
    - fix change to natty

psi-plus (0.15~svn3088-0ubuntu1) natty; urgency=low

  * New upstream release
  * separate icons in other source package
  * change maverick to natty

psi-plus (0.15~svn3057-1) maverick; urgency=low

  * New upstream release
  * add webkit version
  * new package psi-plus-common

psi-plus (0.15~svn3040-1) maverick; urgency=low

  * New upstream release
  * add libproxy-dev for contentdownloader
  * separate contentdownloader plugin
  * separate icons

psi-plus (0.15~svn2774-1) maverick; urgency=low

  * New upstream release
  * Bump Standards-Version to 3.9.1
  * rename README.sources -> README.source
  * fix short description
  * remove libqca2 conflicts
 -- Ubuntu Archive Auto-Sync <email address hidden> Fri, 27 May 2011 23:17:35 +0000

Changed in psi-plus (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in psi (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers