psi crashes when registering an account

Bug #237733 reported by Luke Faraone on 2008-06-05
4
Affects Status Importance Assigned to Milestone
psi (Ubuntu)
Medium
Unassigned
Nominated for Hardy by goto
Nominated for Intrepid by goto

Bug Description

Binary package hint: psi

1) Start PSI and go to add an account
2) Set it to "register"
3) Enter any server (in this case xochat.org)
4) Click "next"

And it quits: Segmentation fault

ProblemType: Bug
Architecture: i386
Date: Thu Jun 5 15:58:05 2008
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: nvidia
Package: psi 0.11-3
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
SourcePackage: psi
Uname: Linux 2.6.24-17-386 i686

Luke Faraone (lfaraone) wrote :
Luke Faraone (lfaraone) wrote :
Richard Seguin (sectech) wrote :

I managed to get a few more symbols for the crashlog... The problem is that psi doesn't have any debugging symbols

Richard Seguin (sectech) wrote :

Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here. Thanks for taking the time to make Ubuntu better!

Changed in psi:
status: New → Confirmed
Ralph Janke (txwikinger) on 2008-06-07
Changed in psi:
importance: Undecided → Medium
goto (gotolaunchpad) wrote :

Psi 0.11 is not compatible with QT 4.4. There are serveral more or less problematic issues, and there are a few tries to solve these issues with later sub versions of 0.11. But in gerneral you can say, Psi 0.11 is simply not compatible to QT 4.4.
Psi 0.12 is compatible again with QT 4.4 and it will be out today or so, I'd suggest to replace Psi 0.11 with Psi 0.12. And there are not so many changes from Psi 0.11 to 0.12, compared to the step from 0.10 to 0.11.

goto (gotolaunchpad) wrote :

I think the problem could have also been that there was the ssl plugin missing. And I think this bug should be fixed in 0.13 dev if not even in 0.12 already.

Richard Seguin (sectech) on 2008-12-24
Changed in psi:
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers