Ubuntu

prboom hangs a few second after starting a game

Reported by Pascal de Bruijn on 2007-09-16
6
Affects Status Importance Assigned to Milestone
prboom (Ubuntu)
Undecided
Unassigned

Bug Description

When starting prboom (with both freedoom, as well as the real doom2.wad), it hangs a few seconds after starting the game.

How to reproduce:
- Start prboom
- Select New Game
- Select a difficulty
- Walk around a little bit, picking up some items, killing some sergeants...
- Hang!

Martin Vysny (vyzivus) wrote :

It seems that it hangs on sound output: if you start it with -nofullscreen -nojoy -nomouse and it hangs, try to close its window. The console output will halt on a sound system deinit routine. Leave the window be, it will close itself eventually. Or you can kill it with kill -9 prboom

Rob Watson (r-watson) wrote :

I can confirm this. X hangs as soon as the opening level starts. I can switch to a text console and 'kill -9 <prboom PID>', but switching back, X is in 640x480 resolution (if I'm lucky?). Didn't run it with '-nofullscreen' (shouldn't have to).

This might be a dupe of Bug #101936, but without the sigsegv. Then again, it might not.

Rob Watson (r-watson) wrote :

P.s. (sorry) running prboom with -nosound, it works fine (well, no sound, of course), so it definitely appears to be a sound problem.

jmorahan (wunderland) wrote :

I had the same problem and I noticed that there was also no music. So I installed timidity, and not only did the music start working but the hangs went away too.

Brett Sealey (brett-sealey) wrote :

Hardy 8.10 on an eee. Followed jmorahan's suggestion - it worked. Is prboom missing a dependency on timidity.

onli (onli) wrote :

I can confirm this. On hardy, prboom needs timidity. It should be added as a dependency.

lol1972 (lol1972) wrote :

Disabled music in the prboom config file worked:
(via terminal)
gedit /home/(username)/.prboom/prboom.cfg

edited the below line to say:
music_card 0

saved (no music but still got sound effects, however rhythmbox piping Ennio Morricone does the job).

Ansus (neptunia) wrote :

The same problem. Also mouse cursor sometimes disappears when the game stucks, which requires xorg restart.

Changed in prboom:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers