Powertop doesn't scroll within 'tunable' page

Bug #911387 reported by Cefn on 2012-01-03
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
powertop (Ubuntu)
Undecided
Unassigned

Bug Description

I'm running powertop on more-or-less stock Oneiric, and the 'tunables' page is entirely full, perhaps because it's reporting on so many cores (it's an 8 thread Intel i7).

Unfortunately, I'm pretty sure there are extra entries but the terminal cannot show them and there appears to be no way to page or scroll within the tunables page. Dragging the terminal window and refreshing gets you a few more lines, but it's impossible to make the window big enough to see all of them. When scrolling the highlighted line to the bottom, it eventually arrives at highlighting the VI/EMACS style command line, and hence won't scroll further.

On the plus side I think the 'bad' entries are pushed to the top.

Can I suggest some kind of scrolling behaviour or some simple and intuitive interaction to page? Perhaps it's there but I can't trigger it.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: powertop 1.97-2
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic 3.0.13
Uname: Linux 3.0.0-15-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Tue Jan 3 17:33:03 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: powertop
UpgradeStatus: No upgrade log present (probably fresh install)

Cefn (6-launchpad-net-cefn-com) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in powertop (Ubuntu):
status: New → Confirmed

Hi PowerTop-Mailing-List,

I have a problem with powertop: It doesn't scroll in "Tunables".
I sometimes have to deactivate the powersaving of my WiFi card.
This isn't possible if I can't find the option (because it is out of view in my Terminal)

Related Launchpad-Bug:
https://bugs.launchpad.net/ubuntu/+source/powertop/+bug/911387

Best regards
Simon

Francesco Bussi (frenbu) wrote :

Hello,
the issue is still present in powertop 2.1-0ubuntu1 (compile date Aug 23 2012), I'm running Kubuntu 12.10 with kernel 3.5.0-31-generic.
Is there any chance to get this fixed?
I've found this relatively old patch on the powertop mailing list but didn't test it:
https://lists.01.org/pipermail/powertop/2012-September/000378.html

Cheers
Francesco

Simon K (octav14n) wrote :

At least in Ubuntu 14.10 and 15.04 this bug is fixed. Could someone confirm this for 14.04?

If It is fixed in 14.04 this bug should be marked as "fix released".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers