i18n coding issues displaying postgresql-8.4 server messages

Bug #544114 reported by Ricardo Pérez López on 2010-03-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Low
Ubuntu Spanish Translators
postgresql-8.4 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: postgresql-8.4

Postgresql-8.4 on Lucid has a i18n coding issues when displays server messages.

postgresql-8.4 template is fully translated into Spanish in Launchpad:

  https://translations.launchpad.net/ubuntu/lucid/+source/postgresql-8.4/+pots/postgres-8.4/es/+translate

and the translations are included in the /usr/share/locale-langpack/es/LC_MESSAGES/postgresql-8.4.mo.

Among others, the error messages about "authentication failed" are fully translated, as you can see here:

  https://translations.launchpad.net/ubuntu/lucid/+source/postgresql-8.4/+pots/postgres-8.4/es/+translate?batch=10&show=all&search=autentificaci%C3%B3n

For example, the string:

  password authentication failed for user "%s"

is translated into Spanish this way:

  la autentificación password falló para el usuario «%s»

However, if I do a mistake during authentication, the server shows the error message in this way:

  ricardo@kadath:~$ psql -U ricardo datos
  Contraseña para usuario ricardo:
  psql: FATAL: la autentificaci?n password fall? para el usuario <<ricardo>>

Please, note:

  1. The ó char is replaced by ?.
  2. The « and » chars has been replaced by << and >>.

Another example: the string:

  database "%s" does not exist

is translated into Spanish as

  no existe la base de datos «%s»

as you can see here:

  https://translations.launchpad.net/ubuntu/lucid/+source/postgresql-8.4/+pots/postgres-8.4/es/314/+translate

However, the error message is displayed like this:

  ricardo@kadath:~$ psql -U ricardo datos
  Contraseña para usuario ricardo:
  psql: FATAL: no existe la base de datos <<datos>>

Again, the « and » chars has been replaced by << and >>.

This issue is not psql related, because I tried using pgadmin3 with the same results.

This issue can't be reproduced using postgresql-8.3 in Karmic.

Ricardo Pérez López (ricardo) wrote :

As you can see, the .mo file have included the right translated message:

  ricardo@kadath:~$ strings -eS /usr/share/locale-langpack/es/LC_MESSAGES/postgres-8.4.mo | grep "autentificación password"
  la autentificación password falló para el usuario «%s»

David Planella (dpm) wrote :

Has the PO file the right encoding (i.e. utf-8)? I see for example that a suggestion in https://translations.launchpad.net/ubuntu/lucid/+source/postgresql-8.4/+pots/postgres-8.4/es/314/+translate is not correctly encoded.

Changed in ubuntu-translations:
status: New → Incomplete
importance: Undecided → Low
assignee: nobody → Ubuntu Spanish Translators (ubuntu-l10n-es)

Ricardo, David: do you know if this is still an issue on Maverick? Please respond if it it is.

Ricardo Pérez López (ricardo) wrote :

@David: I've just download the PO file from Launchpad and the encoding is UTF-8. I've tried converting it to ISO-8859-1 (using "recode utf8..iso8859-1 src_backend_po_postgres-8.4-es.po", then "msgfmt src_backend_po_postgres-8.4-es.po", then copying the .mo generated file into /usr/share/locale-langpack/es/LC_MESSAGES) but I got exactly the same result.

@Mohamed: The issue is still present in Lucid (I can't test it on Maverick because I'm not testing it by now).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers