Impress freezes the computer when printing slides with embedded spreadsheets

Bug #739233 reported by karaluh on 2011-03-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
KDE Base
Won't Fix
Medium
OpenOffice
Invalid
Undecided
Unassigned
Poppler
Unknown
Medium
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Undecided
Unassigned
poppler (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: openoffice.org

As in summary. The computer becomes unresponsive because heavy disk load.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: openoffice.org-impress 1:3.2.1-7ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.35-28.49-generic 2.6.35.11
Uname: Linux 2.6.35-28-generic i686
Architecture: i386
Date: Mon Mar 21 09:40:50 2011
ProcEnviron:
 LANGUAGE=pl_PL:pl:en_GB:en
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: openoffice.org
---
Architecture: i386
DistroRelease: Ubuntu 11.04
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
Package: cups 1.4.6-5ubuntu1.2
PackageArchitecture: i386
Papersize: a4
ProcEnviron:
 LANGUAGE=pl_PL:pl:en_GB:en
 PATH=(custom, user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-9-generic root=UUID=d6d9b55b-2a61-4793-a5ba-982b43f9a7f4 ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 2.6.38-9.43-generic 2.6.38.4
Tags: natty
Uname: Linux 2.6.38-9-generic i686
UpgradeStatus: Upgraded to natty on 2011-05-09 (31 days ago)
UserGroups: adm admin audio cdrom dialout dip floppy fuse libvirtd lpadmin plugdev sambashare scanner video
dmi.bios.date: 06/11/2004
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1002.002
dmi.board.name: P4P800-MX
dmi.board.vendor: ASUSTek Computer Inc.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1002.002:bd06/11/2004:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASUSTekComputerInc.:rnP4P800-MX:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

karaluh (karaluh) wrote :

karaluh, thank you for reporting this bug and helping make Ubuntu better. Could you please attach a spreadsheet that when printed demonstrates this problem? Does this occur in LibreOffice Impress?

sudo add-apt-repository ppa:libreoffice/ppa && sudo apt-get update && sudo apt-get -y upgrade && sudo apt-get -y install libreoffice-impress

Changed in openoffice.org (Ubuntu):
status: New → Incomplete
Changed in libreoffice (Ubuntu):
status: New → Incomplete
karaluh (karaluh) wrote :

It doesnt look like office issue anymore. The odp is printed fine on windows, and when I generate pdf and try to print that it also freezes.

Changed in libreoffice (Ubuntu):
status: Incomplete → Invalid
Changed in openoffice.org (Ubuntu):
status: Incomplete → Invalid
karaluh (karaluh) wrote :
karaluh (karaluh) wrote :

karaluh, we need some more information from you before we can start working on this bug. Please run in a Terminal:

apport-collect -p cups 739233

Please include the information requested at https://wiki.ubuntu.com/DebuggingPrintingProblems as separate attachments.

Changed in cups (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected natty
description: updated

apport information

apport information

apport information

karaluh (karaluh) wrote : Locale.txt

apport information

karaluh (karaluh) wrote : Lpstat.txt

apport information

karaluh (karaluh) wrote : Lspci.txt

apport information

karaluh (karaluh) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

apport information

karaluh (karaluh) wrote : UdevDb.txt

apport information

apport information

karaluh (karaluh) wrote :

Two different things happen, depending if you try to print the odp or pdf:

1. odf - Libreoffice becomes unresponsive, windows goes gray, swap and becouse of that hdd usage increases a lot. After several secconds system becomes unresponsive - mouse cursor moves realy slow, keyboard doesn't seem to work, I cannot even switch ttys. After several more secconds libreoffice crashes or is killed.

2. pdf - i print it using Okular. At first okular takes lots of cpu, but can be killed. After i killed it gs proces started to take lots of cpu, but i killed it. After that i had to manualy remove the failed job from the queue. the cups error log seems to be from the seccond scenario.

Please let me know if you need any more info.

Changed in cups (Ubuntu):
status: Incomplete → New

Can save all important work (to be prepared for a reboot if needed) and then you run "top" in a terminal window and after that try to print your odf file from libreoffice again, taking care that the terminal window running "top" is visible. Please tell which processes are at the top of the list in "top". These are the most CPU-consuming. Especially processes owned by the user "lp" are important.

Do the same procedure also for the second case. With a visible "top" print your PDF file out of Okular.

If in one or both of the above cases "top" does not show any CPU-consuming processes (see CPU percentage in the listing), repeat above procedure for the two cases but right after starting "top" and before tyrying to print your files, press Shift+M to get "top" into memory consumption mode. Then you have the most memory-consuming processes at the top of the list. Please tell which these are.

In addition, follow the instructions of the sections "CUPS error_log" and "Capturing print job data" on https://wiki.ubuntu.com/DebuggingPrintingProblems for both cases.

Changed in cups (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium
karaluh (karaluh) wrote :

As for the odp there's no conclusive answer, because top also stopped refreshing the data. However, soffice.bin was on the top in both cpu and memory usage, but the numbers weren't big. It didn't produce the print job file, attached cups error log.

karaluh (karaluh) wrote :

As for the pdf for the 100% cpu ussage Okular was responsible, it took for about a minute to drop the ussage, then cups and lpr showed for less than a seccond. The generated print job is over 156 MB, so I'm not going to attach it, unless you want me to. Attached error log. I'll try to print the generated job and post the results.

karaluh (karaluh) wrote :

After enabling the printer gs took 100% cpu for more than five minutes. The document was sent to the printer eventualy, because it appeared in the queue on the printer itself. I deleted it but i beleive it would print fine after several more minutes.

Changed in cups (Ubuntu):
status: Incomplete → New

Here seem to be problems in several different programs: Comment #24 makes the impression that LibreOffice is taking up to much memory/CPU to generate the print job, comment #25 proves a fault in Okular, generating too big print jobs (we discussed already in other bugs with evince that a PDF viewer should simply pass through the input PDFs for printing), and comment #26 shows the known problem of Ghostscript being slow on PDF (bug 668800, but probably every PDF interpreter is slow on a 156 MB PDF). Another problem can be a memory leak in the pdftopdf filter, but this is already fixed and will soon appear as an update for Natty, see bug 790378.

Moving to Okular due to the large print output file and reopening LibreOffice task as there is also perhaps still a problem. The CUPS task is not needed any more as the problems are known and treated in other bug reports.

Changed in libreoffice (Ubuntu):
status: Invalid → New
affects: cups (Ubuntu) → okular (Ubuntu)
Changed in okular (Ubuntu):
status: New → Incomplete

To investigate whether there is a problem with LibreOffice, please try to print into a file from LibreOffice. Do not use "Export to PDF" in the File menu. Use "Print" and in the print dialog mark the option to print into a file. Please run "top" in a terminal and watch CPU and memory usage. Does it go up also in this case? Please also attach the resulting file.

Changed in libreoffice (Ubuntu):
status: New → Incomplete
importance: Undecided → Medium

karaluh, regarding LibreOffice, your crash report is missing. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in libreoffice (Ubuntu):
importance: Medium → Undecided
status: Incomplete → Invalid
karaluh (karaluh) on 2011-06-13
Changed in okular (Ubuntu):
status: Incomplete → New
karaluh (karaluh) wrote :

I've filled a bug upstream against Okular, it got assigned somehow to openoffice here, and I'm unable to reassign it to Okular.

When trying to print in Libreoffice to file, symptoms are simmilar to the ones when printing directly to the printer. Libreoffice crashes and the file is not generated. Also, soffice.bin is the most cpu intensive process, however xorg cpu ussage also increases, but i don't know if it's directly related. Also, kswapd0 shows up, although its cpu ussage isn't that big. During the proces system also became unresponsive and the hdd went crazy.

Changed in openoffice:
importance: Unknown → Medium
status: Unknown → New
karaluh (karaluh) wrote :

I tried to generate the Libreofice crash report. After enabling apport

sudo service apport start force_start=1

i reproduced the bug. However, no crash dialog appeared. There's also no files in /var/crash. Also, I don't beleive it's crash, because kontact and firefox - both cpu and memory hungry apps are killed along with Libreoffice, so I'll reopen.

Changed in libreoffice (Ubuntu):
status: Invalid → New

karaluh, as the documentation posted to you when you first reported this bug states, you also need to have the appropriate -dbg symbols installed for the package(s) you have crashing: https://wiki.ubuntu.com/DebuggingProgramCrash Marking back to Invalid. If you have further questions please use the support tracker https://answers.launchpad.net/ubuntu For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs.

Changed in libreoffice (Ubuntu):
status: New → Invalid
Changed in openoffice:
importance: Medium → Undecided
status: New → Invalid

karaluh, can you please post the link to the upstream bug in Okular here in a comment? Than I add the correct bug watch link for you.

With all the infor collected here up to now we know that there are two problems:

1. Trying to print the attached .odp makes LibeOffice taking up to much memory and CPU resources, making the computer unresponsive and making processes (including LibreOffice) getting killed because there is not enough free memory for them. => Bug in LibreOffice

2. Using the remaining possibility to get the file out of LibreOffice for printing via "Export to PDF" one hits the problem that the exported PDF (also attached) when trying to print it with Okular gives a too big file which is sent to CUPS for doing the actual print job. The CUPS filters and also PostScript/PDF interpreters in printers cannot cope with such a huge, inefficient input file. => Bug in Okular or in a library used by Okular

As in summary. For certain pdf files the generated ps is over 100 MB. See also:
https://bugs.kde.org/show_bug.cgi?id=275515
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/739233
for additional information and test files.

karaluh (karaluh) wrote :

@Christopher M. Penalver
I've installed all the debug packages provided by list-symbols-packages-v2.sh, except ure-dbg because of the dependency problem:

  libreoffice-core-dbgsym: Jest w konflikcie z: uno-libs3-dbg ale zaplanowana jest instalacja wersji 1.7.0+LibO3.3.2-1ubuntu5.
                           Jest w konflikcie z: ure-dbg ale zaplanowana jest instalacja wersji 1.7.0+LibO3.3.2-1ubuntu5.
  libreoffice-impress-dbgsym: Jest w konflikcie z: uno-libs3-dbg ale zaplanowana jest instalacja wersji 1.7.0+LibO3.3.2-1ubuntu5.
                              Jest w konflikcie z: ure-dbg ale zaplanowana jest instalacja wersji 1.7.0+LibO3.3.2-1ubuntu5.

After enabling apport and reproducing still no crash dialog and reports in /var/crash. Reopening.

@ Till Kamppeter
It appears to be poppler bug. Links to the bug reports:
https://bugs.kde.org/show_bug.cgi?id=275515
https://bugs.freedesktop.org/show_bug.cgi?id=38278

Changed in libreoffice (Ubuntu):
status: Invalid → New

Thank you for the links. I have added the missing bug watches now.

affects: okular (Ubuntu) → poppler (Ubuntu)
Changed in poppler:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in kdebase:
importance: Unknown → Medium
status: Unknown → Won't Fix
Changed in libreoffice (Ubuntu):
status: New → Invalid

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/10.

Changed in poppler:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.