Drop down forms can't be selected

Bug #279167 reported by Daniel on 2008-10-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Evince
Unknown
Medium
poppler (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: evince

As seen in New York State voter registration form, drop down menu options in PDF forms can't be selected with evince.

See the "County" option on page 2 of the voter registration form.
Form is available here http://www.elections.state.ny.us/NYSBOE/download/voting/voteform_enterable.pdf

Form has also been uploaded as an attachment.

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 6 12:22:21 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/evince
NonfreeKernelModules: nvidia
Package: evince 2.22.2-0ubuntu1
PackageArchitecture: amd64
ProcEnviron:
 PATH=/home/username/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
Uname: Linux 2.6.24-19-generic x86_64

Daniel (daniel123+launchpad) wrote :
Dimitrios Symeonidis (azimout) wrote :

confirmed. a very small horizontal scrollbar appears, but no drop down list

Changed in evince:
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

does it work with another pdf viewer like acroread or xpdf? i've tested the pdf with both and none of them worked for me.

Changed in evince:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Confirmed → Incomplete
Dimitrios Symeonidis (azimout) wrote :

nope, doesn't work with any of them.
what are you suggesting, that the pdf is broken?
i don't have a windows system handy to test it...

the file is the New York State voter registration form
on the second page there's a field where you select your county
this field works well when opened in windows with adobe reader, but not in linux: not with evince or xpdf, not even with acroread for linux

the report was initially filed under ubuntu's launchpad:
https://bugs.launchpad.net/ubuntu/+source/evince/+bug/279167

Next time please give me all the info, specifically the link to the pdf

i tried to attach it, but it's >1MB, so it was dropped, but without any message, so i thought it was attached...

here's the link to it:
http://www.elections.state.ny.us/NYSBOE/download/voting/voteform_enterable.pdf

Dimitrios Symeonidis (azimout) wrote :

in fact i checked on a windows machine with adobe reader, and it works.
you don't see a drop down list, instead you get up and down arrows next to the county.
i pressed them and they work.
should we go upstream?

Changed in evince:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

ubuntu has no change to evince or poppler that could create a such issue so upstream is the right way to go there

Dimitrios Symeonidis (azimout) wrote :

i reported it on bugs.freedesktop:
http://bugs.freedesktop.org/show_bug.cgi?id=18003

Changed in evince:
status: Confirmed → Triaged
Changed in evince:
status: Unknown → Confirmed
Dimitrios Symeonidis (azimout) wrote :

i was wrong earlier: with acroread on linux, you can use the form correctly, but you need to install acroread-plugins...

Changed in evince:
importance: Unknown → Medium
Changed in evince:
importance: Medium → Unknown
Changed in evince:
importance: Unknown → Medium

*** Bug 24997 has been marked as a duplicate of this bug. ***

Still occurring with poppler 0.18.4-1ubuntu2

Still occurring with libpoppler28 0.20.4-0ubuntu1 and libcairo2 1.12.2-1ubuntu2.1

here is a similar form, with a drop-down list (in Dutch)

http://www.nshispeed.nl/nl/na-de-reis/compensatie-bij-vertraging

it is the clickable box under 'Geld terug bij vertraging'

it should give, I guess, a list of train stations, but none are visible nor selectable. Maybe it will help chase the bug..

madbiologist (me-again) wrote :

This is fixed on Ubuntu 14.04 "Trusty Tahr". As well as a very small horizontal scrollbar, there is also what is either an even smaller vertical scrollbar or up and down arrows which work.

evince 3.10.3-0ubuntu10
poppler 0.24.5-2ubuntu4

Changed in poppler (Ubuntu):
status: Triaged → Fix Released

The first document (New York State voter registration form) is working with poppler 0.24.5-2ubuntu4. As well as a very small horizontal scrollbar under the County field, to the right of the field there is also what is either an even smaller vertical scrollbar or up and down arrows which work.

The second document from comment #6 also works with poppler 0.24.5-2ubuntu4, albeit with visual bug. The "Gegevens over uw reis/Your journey" fields can now be dropped down into a selectable list of train stations by clicking on the right hand end of the field. No down arrow is visible, but there is a faint separator bar near the end of the field. It might be advisable to file a new bug report for the remaining visual issue.

-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/70.

Changed in evince:
status: Confirmed → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.