[Hardy] Unable to save manual network configurations using network-admin

Bug #188349 reported by sChTeFaN on 2008-02-02
88
Affects Status Importance Assigned to Milestone
policykit (Ubuntu)
Undecided
Unassigned
system-tools-backends (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: gnome-system-tools
Version: 2.21.90-0ubuntu1

When trying to change some network configurations using network-admin (e.g. setting a Static IP address or using DHCP) and after authentication by PolicyKit you get an error message saying: "The configuration could not be saved. You are not allowed to modify the system configuration"

Steps to reproduce:
Go to the networkmanager applet and left click and choose "manual configuration" unlock the applet (using the policykit button) and select wired connection and click properties, uncheck free roaming and choose DHCP and press okay and you will see the error message described above.

sChTeFaN (stefan-sickert) wrote :
verb3k (verb3k) on 2008-02-06
description: updated
Changed in network-manager:
status: New → Confirmed
description: updated
verb3k (verb3k) wrote :

Thanks for reporting, I can confirm this bug in Hardy Alpha4.
I've changed the description of the bug report to give more details and changed status to "confirmed".

David Tomic (young-einstein) wrote :

I'm having the same problem as well.

Is there any way to work around this in the short term?

Me too! I confirm this bug.

Ubuntu Hardy Heron Alpha4 system installed directly from the LiveCD
gnome-system-tools 2.21.90-0ubuntu1

I really need a workaround to be able to configure my wireless interface!

This bug appears ONLY after you close the network-admin tool and then RE-OPEN it! When you open the tool for the first time after reboot, everything is OK and you can choose any location and apply any settings. However, if you close the tool and then re-open it, the bug appears and you can't modify ANYTHING! So, to reproduce this bug you need to do the following:

First, open the tool - unlock - enter the password - change anything - wait for changes to take effect - close the tool
Then, open the tool again - unlock - enter the password - try to change anything - here appears the bug!

PS: If you don't EVER close the tool you can change the settings as many times as you would desire; this seems to be a good workaround; just keep the tool open after authentication till the session ends.

Changed in gnome-system-tools:
assignee: nobody → desktop-bugs

Islam Badrel-Dein wrote:
> This bug appears ONLY after you close the network-admin tool and then
> RE-OPEN it! When you open the tool for the first time after reboot,
> everything is OK and you can choose any location and apply any settings.
> However, if you close the tool and then re-open it, the bug appears and
> you can't modify ANYTHING! So, to reproduce this bug you need to do the
> following:
>
> First, open the tool - unlock - enter the password - change anything - wait for changes to take effect - close the tool
> Then, open the tool again - unlock - enter the password - try to change anything - here appears the bug!
>
> PS: If you don't EVER close the tool you can change the settings as many
> times as you would desire; this seems to be a good workaround; just keep
> the tool open after authentication till the session ends.

I've seen this too, but haven't had time to debug it yet.

hello world! o.O

Changed in gnome-system-tools:
importance: Undecided → High

I can add additional scenario to this. As Islam pointed out, error message appears only after second opening of network-admin. However, interesting is that manual configuration of PPP is silently dropped even in first time. In second time it ends with already mentioned error message.

1. Open network-admin
2. Authentificate to change settings
3. Double click on PPP device, enable this connection and create settings. Press OK;
4. Configuration is disabled and some data lost
5. Exit network-admin, Launch it again
6. Try to configure PPP again
7. Get error message

However I think it could be easily two different bugs, I will probably know better after some debugging tomorrow.

klemen (klemen-grozina-gmail) wrote :

The same problem here.

When Hardy was installed "Enable roaming mode" was selected. However I have somehow managed to save static address in Network settings manager (when comp starts if I go and look in the setting all the values are there), but when the computer starts the network does not work. If I want it to work I have to start network manually from terminal with command:
         sudo ifup eth0
then everything works.

This is my short term workaround for the moment ;)

Martin Pitt (pitti) wrote :

Not a PolicyKit bug

Changed in policykit:
status: New → Invalid
Martin Pitt (pitti) wrote :

Fixed upstream.

Changed in gnome-system-tools:
assignee: desktop-bugs → pitti
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-tools-backends - 2.5.9-0ubuntu1

---------------
system-tools-backends (2.5.9-0ubuntu1) hardy; urgency=low

  * New upstream release:
    - Add I/O functions to PolicyKit, so its internal caches are properly
      updated. This fixes the "can't do anything after the first time I
      authenticate" bug. (LP: #188349)
    - Actually install GPRS chatscript.

 -- Martin Pitt <email address hidden> Fri, 07 Mar 2008 16:24:30 +0100

Changed in system-tools-backends:
status: Fix Committed → Fix Released
Carlos Garnacho (carlosg) wrote :

Martin, just to clear things up, I still tend to think it's still a PolicyKit bug :). if an application doesn't set I/O watch functions for config changes, PolicyKit shouldn't make use of its internal caches, as they aren't going to be updated properly, leading to serious (and unobvious) malfunctioning in that application, as we could see here...

Martin Pitt (pitti) wrote :

Carlos,

ah, thanks for the followup. I didn't actually analyze the bug, I just read your upstream changelog. In this case, since you seem to understand the problem exactly, could you please file a bug at https://bugs.freedesktop.org/enter_bug.cgi?product=PolicyKit ? Thank you!

Changed in policykit:
status: Invalid → New
Ariyau (hawaii5o) wrote :

The exact same also happens when trying to change the time and time zone using the time and date tool. After authentication it allows me to make changes but do not save them and gives the your are not allowed to change system settings error.
Thanks
Umesh

Chow Loong Jin (hyperair) wrote :

Please update your system completely. I believe it is fixed. At least, I no longer encounter this bug.

Ariyau (hawaii5o) wrote :

Hyperair, yep fully updated alpha 5 and the time and date tool allows me to save the changes.

Thanks
Umesh

Tony Yarusso (tonyyarusso) wrote :

Updated today, fixed here as well.

Tim (timjones) wrote :

I'm running Alpha 6 with a significant upgrade (approx 240mb) just installed.

Bug still seems to be occurring for me.

Set the Password type to WPA2 and the network password and click OK. Can now connect wirelessly.

Close Network Settings and re-open, or re-boot, and the settings are back to WPA, with no wireless connection.

Tim

Chow Loong Jin (hyperair) wrote :

You should file a new bug report. This isn't the same issue as the one
referenced by this bug report. This issue was:

1. Open network-admin
2. Unlock
3. Change some setting. (Success)
4. Close network-admin
5. Open network-admin
6. Unlock
7. Try to change a setting
8. Some access denied error.

5-8 will continue to happen as long as you don't reboot. After a reboot,
it starts from 1 again.

Tim wrote:
> I'm running Alpha 6 with a significant upgrade (approx 240mb) just
> installed.
>
> Bug still seems to be occurring for me.
>
> Set the Password type to WPA2 and the network password and click OK.
> Can now connect wirelessly.
>
> Close Network Settings and re-open, or re-boot, and the settings are
> back to WPA, with no wireless connection.
>
> Tim
>
>

Savvas Radevic (medigeek) wrote :

Ubuntu hardy heron 8.04 amd64 / x86_64
(from alpha 5 up to beta through updates)

I still get this bug,
network-admin > press unlock, type in your password > select your connection (mine is wired, eth0) > properties > (change something) > press ok

Results in an error:
The configuration could not be saved.
You are not allowed to modify the system configuration.

However, although the error pops up, the information for wired mode mentioned in the main "network settings" window seem changed when I altered it in the properties. But the nm-applet resets and gets the old configuration, so I think it doesn't save the changes.

$ apt-cache policy policykit policykit-gnome system-tools-backends
policykit:
  Installed: 0.7-2ubuntu5
  Candidate: 0.7-2ubuntu5
  Version table:
 *** 0.7-2ubuntu5 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
policykit-gnome:
  Installed: 0.7-2
  Candidate: 0.7-2
  Version table:
 *** 0.7-2 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status
system-tools-backends:
  Installed: 2.6.0-0ubuntu2
  Candidate: 2.6.0-0ubuntu2
  Version table:
 *** 2.6.0-0ubuntu2 0
        500 http://archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

Changed in system-tools-backends:
status: Fix Released → Confirmed
Martin Pitt (pitti) wrote :

Savvas, can you please check if you can do changes in users-admin? (Just try to create a new user, use "id username" in a Terminal to verify that it exists, and delete it again). Or try to change your clock in time-admin? If that works, then it is likely a problem in network-manager. I don't think it is related to this report anyway, since the cause of this has already been fixed.

If users-admin etc. work, then please file a new bug against network-manager. If it doesn't work, then we can reopen this and debug further. Thank you!

Changed in system-tools-backends:
status: Confirmed → Fix Released

Why this bug is still open against policykit? Yes, it was caused by some confusion about policykit design, but I think devs will be informed other way :)

I think it can be marked as 'invalid' for policykit, because bug was really in s-t-b.

James Westby (james-w) wrote :

Hi,

I think the reason that it is still open against policykit is that
it was argued that there was a bug there: that if I/O watch
functions aren't set policykit shouldn't use it's caches, as they
will be out of date.

The other issues with network-admin should be moved to
new bug reports, as this one is indeed fixed.

Thanks,

James

James Westby (james-w) wrote :

Hi,

For reference the commit that fixed this in system-tools-backends
can be seen at

  http://gitweb.freedesktop.org/?p=system-tools-backends.git;a=commitdiff;h=b035419670b7a4c356f864766a172efc052aab8b

I don't feel I understand the problem well enough to file a bug upstream
on policykit.

Thanks,

James

I installed Gnome Network admin from the repositories in Ubuntu 9.04 Jaunty (final).

It is not possible to save any locations; after entering a location name and clicking "save", the tool always crashes.

In Ubuntu 10.04, the problem persist.

In Network Configuration -> Manuallly:

When I configure the net parameters in 'manually' the Apply button does not apply what indicated in the menus. It is necessary to restart Ubuntu in order to get it configured.

So this bug is marked as fixed, please can someone unmark it as fixed?

Changed in policykit (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments