pmount-hal: replace slashes in labels

Bug #46536 reported by Tomohisa Kusano
12
Affects Status Importance Assigned to Milestone
pmount (Ubuntu)
Fix Released
Medium
Martin Pitt

Bug Description

Binary package hint: nautilus

Running 6.06 with latest upgrade at 2006-05-25 2:35AM PDT.

nautilus 2.14.1-0ubuntu9

When I plug in USB HDD, with 3 partitions in there, 2 of them that have labels mount fine, but 1 drive that has no label fails to mount.

The HDD works fine on WinXP Home SP2.

Revision history for this message
Tomohisa Kusano (tkusano) wrote : Screenshot: What happens if I plug it in

Screenshot: What happens if I plug it in

description: updated
Revision history for this message
Tomohisa Kusano (tkusano) wrote : Screenshot: Error dialog I get when I double-click to try to mount
Revision history for this message
Sebastien Bacher (seb128) wrote : Re: USB HDD FAT32 partition without label doesn't mount

Thanks for your bug. Could you follow https://wiki.ubuntu.com/DebuggingRemovableDevices and provide useful details for that?

Changed in nautilus:
assignee: nobody → pitti
status: Unconfirmed → Needs Info
Revision history for this message
Tomohisa Kusano (tkusano) wrote : gvm.log

gnome-volume-manager -n 2>&1 | tee gvm.log

Revision history for this message
Tomohisa Kusano (tkusano) wrote : udev.log

sudo udevmonitor -e | tee udev.log

Revision history for this message
Tomohisa Kusano (tkusano) wrote : lshal.txt

lshal > lshal.txt

Revision history for this message
Tomohisa Kusano (tkusano) wrote : dmesg.txt

dmesg > dmesg.txt

Revision history for this message
Tomohisa Kusano (tkusano) wrote : devices.txt

ls -l /dev/sd* > devices.txt

Revision history for this message
Tomohisa Kusano (tkusano) wrote : hal.log

sudo hald --daemon=no --verbose=yes 2>&1 | tee hal.log

Revision history for this message
Tomohisa Kusano (tkusano) wrote : Re: USB HDD FAT32 partition without label doesn't mount

... and here are the rest; hope this helps:

$ id
uid=1000(mizna) gid=1000(mizna) groups=4(adm),20(dialout),24(cdrom),25(floppy),29(audio),30(dip),44(video),46(plugdev),106(lpadmin),110(scanner),112(admin),1000(mizna),1001(hamachi)

$ id hal
id: hal: No such user

$ id haldaemon
uid=108(haldaemon) gid=108(haldaemon) groups=108(haldaemon),24(cdrom),25(floppy),46(plugdev)

$ uname -a
Linux tykho 2.6.15-23-386 #1 PREEMPT Tue May 23 13:49:40 UTC 2006 i686 GNU/Linux

Revision history for this message
Martin Pitt (pitti) wrote :

It's due to the pretty stange label on /dev/sda1:

  volume.label = 'BODY>
  </HT' (string)

I'll fix pmount-hal to replace slashes in the device label with another character (underscore, perhaps). In the meantime, you can change the label of the first partition (under Windows, perhaps, since there is unfortunately no tool in Linux to change the label of a FAT partition).

Changed in gnome-volume-manager:
status: Needs Info → Confirmed
Revision history for this message
Tomohisa Kusano (tkusano) wrote :

Thanks, giving the partition a label (and removing it again) in Windows worked.
Oddly, even Windows doesn't let me use slashes in disk labels, so this must be a truly exceptional case... but that's something else. (The only suspect so far is Acronis True Image; I'll ask the support there)

Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in bzr head, will upload a new version soon.

Changed in pmount:
status: Confirmed → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

Fixed in pmount 0.9.12 in edgy.

Changed in pmount:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers