Ubuntu

Plymouth hangs after installation of nvidia drivers on natty alpha1

Reported by Fabio Marconi on 2010-12-02
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Canonical Foundations Team
Natty
High
Canonical Foundations Team

Bug Description

Binary package hint: plymouth

HelloNatty 20101202 amd64
Installing propetary nvidia driver cause Plymouth hang, it start, then black screen and never goes on.
****From grub menu deleting quiet and splash fix the problem and the login screen appear.*****
Fabio

ProblemType: BugDistroRelease: Ubuntu 11.04
Package: plymouth 0.8.2-2ubuntu6
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Dec 2 11:41:22 2010
DefaultPlymouth: /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.plymouthInstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101202)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 0718:0628 Imation Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ProcEnviron:
 LANG=it_IT.utf8
 SHELL=/bin/bash
ProcFB:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.37-7-generic root=UUID=46111216-ce23-4c42-b3fd-38bc69b623aa roSourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/ubuntu-text/ubuntu-text.plymouth
dmi.bios.date: 11/03/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: P1.50
dmi.board.asset.tag: 00000000
dmi.board.name: K8NF4G-SATA2
dmi.board.version: 1.00
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrP1.50:bd11/03/2005:svn:pnK8NF4G-SATA2:pvr1.00:rvn:rnK8NF4G-SATA2:rvr1.00:
dmi.product.name: K8NF4G-SATA2
dmi.product.version: 1.00

Fabio Marconi (fabiomarconi) wrote :
summary: - Plymouth hangs after installation of nvidia drivers on natty
+ Plymouth hangs after installation of nvidia drivers on natty 20101202
tags: added: iso-testing
Fabio Marconi (fabiomarconi) wrote :
Download full text (9.2 KiB)

Dec 2 11:35:52 localhost gdm-binary[907]: WARNING: Unable to load file '/etc/gdm/custom.conf': Nessun file o directory
Dec 2 11:35:53 localhost gdm-binary[907]: WARNING: Unable to find users: no seat-id found
Dec 2 11:35:53 localhost gdm-simple-slave[988]: WARNING: Unable to load file '/etc/gdm/custom.conf': Nessun file o directory
Dec 2 11:35:53 localhost acpid: client connected from 993[0:0]
Dec 2 11:35:53 localhost acpid: 1 client rule loaded
Dec 2 11:35:54 localhost kernel: [ 33.315524] EXT4-fs (sda1): re-mounted. Opts: errors=remount-ro,commit=0
Dec 2 11:35:56 localhost acpid: client connected from 993[0:0]
Dec 2 11:35:56 localhost acpid: 1 client rule loaded
Dec 2 11:35:56 localhost kernel: [ 35.703679] Xorg:993 conflicting memory types d0000000-d0480000 write-combining<->uncached-minus
Dec 2 11:35:56 localhost kernel: [ 35.703687] reserve_memtype failed 0xd0000000-0xd0480000, track write-combining, req write-combining
Dec 2 11:35:56 localhost kernel: [ 35.704239] Xorg:993 conflicting memory types d0000000-d0480000 write-combining<->uncached-minus
Dec 2 11:35:56 localhost kernel: [ 35.704243] reserve_memtype failed 0xd0000000-0xd0480000, track write-combining, req write-combining
Dec 2 11:35:56 localhost gdm-simple-slave[1017]: WARNING: Unable to load file '/etc/gdm/custom.conf': Nessun file o directory
Dec 2 11:35:56 localhost acpid: client 993[0:0] has disconnected
Dec 2 11:35:56 localhost acpid: client 993[0:0] has disconnected
Dec 2 11:35:56 localhost acpid: client connected from 1019[0:0]
Dec 2 11:35:56 localhost acpid: 1 client rule loaded
Dec 2 11:35:57 localhost acpid: client connected from 1019[0:0]
Dec 2 11:35:57 localhost acpid: 1 client rule loaded
Dec 2 11:35:57 localhost kernel: [ 36.675463] Xorg:1019 conflicting memory types d0000000-d0480000 write-combining<->uncached-minus
Dec 2 11:35:57 localhost kernel: [ 36.675470] reserve_memtype failed 0xd0000000-0xd0480000, track write-combining, req write-combining
Dec 2 11:35:57 localhost kernel: [ 36.676016] Xorg:1019 conflicting memory types d0000000-d0480000 write-combining<->uncached-minus
Dec 2 11:35:57 localhost kernel: [ 36.676021] reserve_memtype failed 0xd0000000-0xd0480000, track write-combining, req write-combining
Dec 2 11:35:57 localhost gdm-binary[907]: WARNING: GdmDisplay: display lasted 0,946769 seconds
Dec 2 11:35:57 localhost gdm-simple-slave[1023]: WARNING: Unable to load file '/etc/gdm/custom.conf': Nessun file o directory
Dec 2 11:35:57 localhost acpid: client 1019[0:0] has disconnected
Dec 2 11:35:57 localhost acpid: client 1019[0:0] has disconnected
Dec 2 11:35:57 localhost acpid: client connected from 1025[0:0]
Dec 2 11:35:57 localhost acpid: 1 client rule loaded
Dec 2 11:35:58 localhost acpid: client connected from 1025[0:0]
Dec 2 11:35:58 localhost acpid: 1 client rule loaded
Dec 2 11:35:58 localhost kernel: [ 37.614237] Xorg:1025 conflicting memory types d0000000-d0480000 write-combining<->uncached-minus
Dec 2 11:35:58 localhost kernel: [ 37.614244] reserve_memtype failed 0xd0000000-0xd0480000, track write-combining, req write-combining
Dec 2 11:35:58 localhost kernel: [ 37.614791] Xorg:1025 con...

Read more...

summary: - Plymouth hangs after installation of nvidia drivers on natty 20101202
+ Plymouth hangs after installation of nvidia drivers on natty alpha1
description: updated
Colin Watson (cjwatson) wrote :

Does it make a difference if you set GRUB_GFXPAYLOAD_LINUX=keep in /etc/default/grub and run 'sudo update-grub'?

(Speculation: plymouth has trouble dealing with the framebuffer type changing in mid-flight.)

Changed in plymouth (Ubuntu):
status: New → Incomplete
importance: Undecided → High
Fabio Marconi (fabiomarconi) wrote :

Hello Colin.
The suggested line don't fix this issue, but i've found that this bug is reproducible only if we have one operating system in the disk,becouse if we have two ubuntu (regarding one ubuntu and one windows i don't know) on the same disk , then grub menu appear, this issue don't happen and everythings works.
Tomorrow i'm going to test with two Ubuntu on two disks (one at disk).
This on 20101206 amd64
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

Update:
Bug is reproducible in this cases:
One ubuntu at disk, if we have two ubuntu on the same disk it don't affect, but if we have two ubuntu on two disk (one at disk) bug appear.
Thanks
Fabio

Fabio Marconi (fabiomarconi) wrote :

still present in 20101215 amd64

Fabio Marconi (fabiomarconi) wrote :

Update:
I found a switch, during grub screen if I press a key, bug appear (with two disks), but if I lay pass the delay time byself, system boot correctly.
If I have just one disk with one ubuntu, bug appear because grub delay is set to 0.
Now I dpn't have time to install more systems, tomorrow or saturday i'll do it, can you give me some suggestion to point this pig ?
Thanks
Fabio

Colin Watson (cjwatson) wrote :

I apologise - I misspoke earlier. Could you please try GRUB_GFXPAYLOAD_LINUX=text (not keep) in /etc/default/grub and run update-grub?

Your comments about this depending on what GRUB does to the display suggest to me that this will probably work.

Changed in plymouth (Ubuntu):
status: Incomplete → Confirmed
Colin Watson (cjwatson) wrote :

(I do have a spare nvidia system here, so I'll see what I can reproduce locally.)

Fabio Marconi (fabiomarconi) wrote :

Hello Colin
This line fix the issue, also plymouth now show right dimension of characters, before they was too big.
Only things that between grub menu and plymouth we have, for some seconds a blinking cursor.
Thanks
Fabio

Well, yes, of course, the point of gfxpayload=keep is to eliminate the
phase when the console is in text mode at boot. :-)

Colin Watson (cjwatson) wrote :

I tried installing the nvidia drivers on an up-to-date natty system, and everything worked more or less perfectly (plymouth wasn't at a particularly great resolution, but it did display fsck output, and X came up fine).

We've been working on a number of graphical boot problems, and it's possible that we managed to fix this one by accident. Can you undo the GRUB_GFXPAYLOAD_LINUX=text workaround, rerun update-grub, upgrade everything (especially grub-pc, the kernel, and plymouth) to current natty, and try again? Feel free to set this bug back to Confirmed if it's still broken, and we can figure out what to investigate next.

Changed in plymouth (Ubuntu Natty):
status: Confirmed → Incomplete
Doug Bates (coloneldare) wrote :

Excuse me if not relevant, but I tried Natty for the 1st time today (using daily build), and seemed to work OK until I selected hardware drivers available (Nvidia on AMD64x4 hardware using the 386 iso). On re-boot system hangs at 'Ubuntu (dot-dot-dot' logo).

Couldn't to a error report 'cus no system :-( Sorry

Doug

pvdeynse (vandeynse) wrote :

@Doug

the "nvidia" driver is currently broken in Natty, see Bug #711409
you should be able to boot in "recovery mode" and rename file "/etc/X11/xorg.conf" (e.g. "/etc/X11/xorg.conf_backup")
this should allow to boot the system using the fallback "nouveau" video driver, at least thats how it worked for me.
we have to wait till bug #711409 is fixed.

Changed in plymouth (Ubuntu Natty):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
status: Incomplete → Confirmed
Fabio Marconi (fabiomarconi) wrote :

[ 1074.272314] nvidia: module license 'NVIDIA' taints kernel.
[ 1074.272322] Disabling lock debugging due to kernel taint
[ 1075.357137] NVRM: The NVIDIA probe routine was not called for 1 device(s).
[ 1075.357146] NVRM: This can occur when a driver such as nouveau, rivafb,
[ 1075.357151] NVRM: nvidiafb, or rivatv was loaded and obtained ownership of
[ 1075.357155] NVRM: the NVIDIA device(s).
[ 1075.357161] NVRM: Try unloading the conflicting kernel module (and/or
[ 1075.357165] NVRM: reconfigure your kernel without the conflicting
[ 1075.357169] NVRM: driver(s)), then try loading the NVIDIA kernel module
[ 1075.357173] NVRM: again.
[ 1075.357177] NVRM: No NVIDIA graphics adapter probed!

Seems related.

Robbie Williamson (robbiew) wrote :

I have the latest nvidia driver working fine with my amd64 64bit Ubuntu Desktop installation. Can someone please confirm this bug still exists.

Changed in plymouth (Ubuntu Natty):
status: Confirmed → Incomplete

I think I may be seeing this issue - upgraded to 11.04 today have nvidia drivers (MSI 7253 m/board) and can't get it to boot - if I use gfxpayload=text it appears to get further but still doesn't complete boot - stopping after scripts/init-bottom.
I have two ubuntu installations on the same disk
Same prob with both recovery mode and normal mode - or is this diff and need to open new bug?

Fabio Marconi (fabiomarconi) wrote :

Hello
In Ubuntu 20110402 amd64 the proposed nvidia driver (270.30-0ubuntu3) are working fine.
Is there someone that still affecting ?

Erçin EKER (ercineker) wrote :

i think its something to do with uvesafb

when i use "video=uvesafb:mode_option=1600x900-24,mtrr=3,scroll=ywrap" in the command live the console isnt shown and when i switch from x to a terminal it locks up when i remove that from boot it words but not pretty with a big screen :(

anujahooja (anuj-ahooja) wrote :

Hung yesterday after installing the proprietary NVIDIA driver for the GeForce G210M on my Sony Vaio VPCCW17FD.

Driver downloaded here: http://www.nvidia.com/object/linux-display-ia32-260.19.44-driver.html

Side Note: This driver worked properly on Lucid, but had problems in Maverick. In Maverick it never hung, it just didn't configure for 3D graphics; for Natty it hangs completely at the Plymouth bootsplash.

Robbie Williamson (robbiew) wrote :

@anujahooja

Please use the approved proprietary driver we provide via the "Additional Drivers" application from within the system settings. You can also launch this application from the command line by typing:
  sudo jockey-gtk

We cannot be responsible nor effectively debug systems using drivers we have not provided, sorry.

anujahooja (anuj-ahooja) wrote :

@robbie

Unfortunately my video card isn't compatible with the recommended proprietary driver. It's been an issue since 9.10 for me - I've been using the one I referenced earlier and worked fine for 9.10 and 10.04. I'll try and debug myself, thanks anyways!

Erçin EKER (ercineker) wrote :

@anujahooja

260 and 270 drivers are compatible with your graphics card according to nvidia :) i have 270.30 installed from ubuntu archive... Suggest that u try what Robbie told :)

anujahooja (anuj-ahooja) wrote :

@Ercin

I looked into 270 drivers for the G210M and the only one I could find was the 270.18, but it's only for AMD. I'm currently running an x86_64 machine. Is there a compatibility page for the 270.30 I can see?

Thanks for the help! :)

Erçin EKER (ercineker) wrote :

check it on synaptic :) nvidia-current is the driver

anujahooja (anuj-ahooja) wrote :

Awesome! Thanks, Ercin! It worked on Natty Beta 1 for you?

anujahooja (anuj-ahooja) wrote :

Never mind - it worked! Thanks Ercin!

german (germandiago) wrote :

I keep having the same problem. It hangs when booting. My model of NVIDIA card is a Geforce 7300 GT.

madbiologist (me-again) wrote :

@german - Are you using the default Nouveau driver or the proprietary NVIDIA driver?

I'm closing this report because the issue is fixed for the original reporter. Other users with different graphics card/hardware/driver may experience all kind of different issues with similar symptoms. Please file a new report instead.

Thanks for your help to make Ubuntu better.

Changed in plymouth (Ubuntu Natty):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers