Remove plymouth destroying system

Bug #531331 reported by Artur Rona on 2010-03-03
74
This bug affects 16 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: plymouth

I did remove plymouth by Synaptic and it removed ubuntu-desktop and *image*generic package. Then grub have only Memory test and WindowsXP in menulist.

Hernando Torque (htorque) wrote :

Did you remove the package plymouth or libplymouth2? I cannot confirm problems with removing the former.

plymouth:
  Installed: 0.8.0~-10ubuntu1
  Candidate: 0.8.0~-10ubuntu1
  Version table:
 *** 0.8.0~-10ubuntu1 0
        500 http://archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

Artur Rona (ari-tczew) wrote :

I did remove libplymouth2. Try it in Synaptic, then going to remove important packages like acpid, cups, dbus, dkms, gdm, xserver* and others.

Steve Langasek (vorlon) wrote :

Well, don't do that.

Obviously when you remove core packages that other important packages depend on, it makes a mess of the system.

Changed in plymouth (Ubuntu):
status: New → Invalid
philinux (philcb) wrote :

Surely a splash screen that is displayed for approx 5 seconds can't be a core package that has nearly 2 gig of dependencies.

philinux (philcb) wrote :

Wish I could edit the above. I meant to say it's more than splash screen but a few weeks back you could remove it no problem.

On Wed, 2010-03-03 at 16:52 +0000, Steve Langasek wrote:

> Well, don't do that.
>
You can't say that on bug reports ;-) Reddit get upset.

Scott
--
Scott James Remnant
<email address hidden>

Maurus (maurus-rman2) wrote :

There should be a very easy way during installation to switch on or off grub2 and Plymouth. Lets get rid of this useless splashscreens and boot up with a nice resolution on the framebuffer screen.

Dylan McCall (dylanmccall) wrote :

mountall has a hard dependency on Plymouth, as of version 2.10.
( https://edge.launchpad.net/ubuntu/+source/mountall/2.10 )

> * Add hard dependency on Plymouth; without it running, mountall will
> ignore any filesystem which doesn't show up within a few seconds or that
> fails to fsck or mount. If you don't want graphical splash, you simply
> need not install themes.

Hope that helps.

Damjan Georgievski (gdamjan) wrote :

I can't understand how you can't remove:
libdrm-intel1
libdrm-nouveau1
libdrm-radeon1
libdrm2
libplymouth2
plymouth
on a Ubuntu sever, that I run in a virtual machine. Doesn't make any sense.

mehabox (mehabox) wrote :

Confirmed on an x86 Lucid installed two days before. The reason I wanted to remove plymouth was its incompatibility with fglrx (proprietary Radeon driver that I need).
Trying to remove plymouth results in about a half of the system nominated for deletion, including Xorg, alsa, etc.

alexeagar (alexeagar) wrote :

This isn't a direct solution to this problem, but I suspect that a few of you who are affected by this problem would be satisfied if the splash screen displayed at the proper resolution while booting with a proprietary graphics driver enabled. Here are instructions for just such a solution. http://idyllictux.wordpress.com/2010/04/26/lucidubuntu-10-04-high-resolution-plymouth-virtual-terminal-for-atinvidia-cards-with-proprietaryrestricted-driver/

Plymouth is not working properly on my ubuntu box, so i would like to remove it. When I was running the 9.10 release, I uninstalled usplash and xsplash, 'cause I like verbose/text boot. Unfortunately this is not possible with plymouth, or is it?

UnstableGhost (unstableghost) wrote :

Plymouth is not working for me either. I have to run Nvidia proprietary driver (nouvaeu does not work at all for Quadro FX380m), and plymouth can't handle that. I dont see why user is *forced* to have plymouth, especially on servers. I now have to rebuild whole bunch of software to get rid of plymouth.

Steve Langasek (vorlon) wrote :

On Wed, May 26, 2010 at 06:46:33AM -0000, UnstableGhost wrote:
> Plymouth is not working for me either. I have to run Nvidia proprietary
> driver (nouvaeu does not work at all for Quadro FX380m), and plymouth
> can't handle that.

Please file a separate bug report, detailing how plymouth "doesn't handle"
nvidia drivers for you. For the vast majority of users, it's working as
intended.

> I dont see why user is *forced* to have plymouth, especially on servers.

Because plymouth isn't a splash screen, it's a boot I/O multiplexer.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

UnstableGhost (unstableghost) wrote :

> Please file a separate bug report, detailing how plymouth "doesn't handle"
> nvidia drivers for you. For the vast majority of users, it's working as
> intended.

As far as I know KMS is not available for NVIDIA\ATI proprietary drivers, and plymouth without KMS is 16 color ugliness (ignoring that fact that I see blank screen for like 10 seconds, then ugly splash for 3 and then blank screen again). That is what I call "does not handle", and if I understand right, that is what you call "working as intended". How many can have 16/24 bit splash, without blank screens, on a proprietary graphics drivers?

> Because plymouth isn't a splash screen, it's a boot I/O multiplexer.

Why not to split actual I/O multiplexer and graphical splash into two separate packages? So that the ones that dont need (on server) or don't want splash (KMSless users) can completely remove it.

Don't get me wrong, I really appreciate all the work that is being put into plymouth and KMS. I just don't want plymouth (splash part of it at least) on my system before all the problems with it are solved. Do a 'plymouth' search on ubuntu forums and you will see how many are struggling. If I can't get 24 bit, smooth splash on 10.04 - fine, I would like to get console with messages from kernel - but I can't get that, even when I remove "quite splash", it is still displaying blank screen, and sometimes I can see damaged console text during shutdown.

Steve Langasek (vorlon) wrote :

On Wed, May 26, 2010 at 09:53:38PM -0000, UnstableGhost wrote:
> > Please file a separate bug report, detailing how plymouth "doesn't handle"
> > nvidia drivers for you. For the vast majority of users, it's working as
> > intended.

> As far as I know KMS is not available for NVIDIA\ATI proprietary
> drivers, and plymouth without KMS is 16 color ugliness (ignoring that
> fact that I see blank screen for like 10 seconds, then ugly splash for 3
> and then blank screen again). That is what I call "does not handle", and
> if I understand right, that is what you call "working as intended". How
> many can have 16/24 bit splash, without blank screens, on a proprietary
> graphics drivers?

Yes, that's as intended. It's not optimal, but there are a variety of
practical limitations that constrain us from providing the identical
experience with the proprietary drivers as with the free ones.

> > Because plymouth isn't a splash screen, it's a boot I/O multiplexer.

> Why not to split actual I/O multiplexer and graphical splash into two
> separate packages? So that the ones that dont need (on server) or don't
> want splash (KMSless users) can completely remove it.

Er, they are split in separate packages. If you don't want the graphical
splash, you can remove the plymouth-theme-ubuntu-logo package. Or you can
boot without the 'splash' option to get a text-only view, which is in fact
the default on new installs of Ubuntu 10.04 LTS Server; though this causes
some problems in the rare cases when you *do* need to interact at boot time,
as documented in the release notes.

> If I can't get 24 bit, smooth splash on 10.04 - fine, I would like to get
> console with messages from kernel - but I can't get that, even when I
> remove "quite splash", it is still displaying blank screen, and sometimes
> I can see damaged console text during shutdown.

If you're still having this problem even when booting without the "quiet
splash" options, then that's something quite different, and not, I think,
related to plymouth itself.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

cdmiller (cdmiller) wrote :

For Lucid Server edition we "disabled" Plymouth by removing the /etc/init/plymouth*.conf scripts. That and some other changes resulted in a nicer console for servers: http://staff.adams.edu/~cdmiller/posts/Ubuntu-Lucid-server-disable-plymouth/ In the post is our list of packages that apt reports "depend" on Plymouth. The list of packages is nonsensical.

Pragmatically, Plymouth needs a different default configuration for server releases. An aside, my wife's Lucid workstation boots up screamingly fast now with the upstart/Plymouth combo.

Floyd Wan (fwonce) on 2010-12-29
Changed in plymouth (Ubuntu):
status: Invalid → New
status: New → Incomplete
status: Incomplete → Invalid

According to Steve in #16: "If you don't want the graphical
splash, you can remove the plymouth-theme-ubuntu-logo package. Or you can
boot without the 'splash' option to get a text-only view, which is in fact
the default on new installs of Ubuntu 10.04 LTS Server; though this causes
some problems in the rare cases when you *do* need to interact at boot time"

In other words, if I have a server and I don't want a graphical boot, there will be problems.
I have already migrated 18 of my 38 Ubuntu servers over to Debian because this splash crap keeps causing issues. So no, this bug is not invalid. Admins (like me) are politely requesting that plymouth be an optional part of the boot process--expecially for servers. I for one like to see exactly what's going on while my system is booting. If I wanted the boot process to be a hidden and total mystery, I'd switch to Windows 7.

Changed in plymouth (Ubuntu):
status: Invalid → Confirmed
Steve Langasek (vorlon) wrote :

> So no, this bug is not invalid.

Yes, it is. The other issue I referred to is a separate bug, bug #563916, which has been resolved.

Changed in plymouth (Ubuntu):
status: Confirmed → Invalid

My apologies Steve, I didn't see bug 563916 referenced here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers