Ubuntu

Only see X mouse cursor on VT during boot

Reported by Martin Pitt on 2010-02-18
142
This bug affects 37 people
Affects Status Importance Assigned to Milestone
plymouth (Ubuntu)
High
Scott James Remnant (Canonical)
Lucid
High
Scott James Remnant (Canonical)

Bug Description

Binary package hint: plymouth

For a few weeks now, I get random startup failures like this:

 - KMS starts up with large VT and some fsck/mountall spewage (normal)
 - plymouth starts up, showing black screen with Ubuntu logo (normal)
 - X starts up on top of plymouth, showing mouse cursor (normal)
 - I get back to a VT with X mouse cursor on top of it; Moving the mouse changes the cursor according to the underlying widget (like an input box from keyring password question), but I don't see anything from the X session
 - Ctrl+Alt+F1 gets me to a functional VT
 - Ctrl+Alt+F7 switches back to X, now with full UI. However, as soon as I press Enter in the input box of keyring, X freezes, and I can only powercycle. This part was already described in bug 516412, but that got closed already.

I was playing around with improving boot speed, and removing /etc/rc2.d/S50cups seems to make the Dell Mini 10 boot fast enough to reproduce this bug with almost 100% reliability. It also happens on my Dell Latitude D430 (utterly slow hard disk, boot time about 50 s, and on the recent platform team sprint about half of the people had this symptom as well.

As a first step I added an "fuser -v /dev/tty7" to the gdm upstart job, which shows this in a case when booting _works_:

                     USER PID ACCESS COMMAND
/dev/tty7: root 321 F.... plymouthd

When booting fails (with this bug), I also get plymouthd (which is presumably correct), but in addition a large number of error messages like "/proc/NNN/fd/MMM: No such file or directory". I'll attach the file in a bit.

ProblemType: Bug
Architecture: i386
Date: Thu Feb 18 14:02:49 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Alpha i386 (20100208)
MachineType: Dell Inc. Inspiron 1011
NonfreeKernelModules: wl
Package: plymouth 0.8.0~-10ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-13-generic root=UUID=ab9095e7-3dec-474c-b2f6-c473e5df8ae1 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcFB:
 0 inteldrmfb
 1 VGA16 VGA
ProcVersionSignature: Ubuntu 2.6.32-13.19~usbhublockingapw1-generic
SourcePackage: plymouth
Uname: Linux 2.6.32-13-generic i686
dmi.bios.date: 07/29/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A06
dmi.board.name: CN0Y53
dmi.board.vendor: Dell Inc.
dmi.board.version: A06
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A06
dmi.modalias: dmi:bvnDellInc.:bvrA06:bd07/29/2009:svnDellInc.:pnInspiron1011:pvrA06:rvnDellInc.:rnCN0Y53:rvrA06:cvnDellInc.:ct8:cvrA06:
dmi.product.name: Inspiron 1011
dmi.product.version: A06
dmi.sys.vendor: Dell Inc.

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

Please note that this apport information is from a working boot. If it helps, I can try and collect it from a failing one.

Martin Pitt (pitti) wrote :

This time I only got one error message from fuser:

------------- 8<------------------
Cannot stat file /proc/96/fd/10: No such file or directory
                     USER PID ACCESS COMMAND
/dev/tty7: root 313 F.... plymouthd
------------- 8<-----------

pid 96 is the bootchart collector process.

Sebastien Bacher (seb128) wrote :

I can confirm the issue on several lucid boxes too

Changed in plymouth (Ubuntu):
status: New → Confirmed
Ralph Ulrich (eulenreich) wrote :

I can confirm this using:
lucid
nvidia drivers
pam_mount for mounting encrypted /home partition

Ralph Ulrich (eulenreich) wrote :

this update solved my issue:
2010-02-19 16:01:49 configure metacity 1:2.28.1-0ubuntu2 1:2.28.1-0ubuntu2
2010-02-19 16:01:49 status unpacked metacity 1:2.28.1-0ubuntu2
2010-02-19 16:01:49 status half-configured metacity 1:2.28.1-0ubuntu2
2010-02-19 16:01:50 update-alternatives: run with --install /usr/bin/x-window-manager x-window-manager /u
sr/bin/metacity 60 --slave /usr/share/man/man1/x-window-manager.1.gz x-window-manager.1.gz /usr/share/man
/man1/metacity.1.gz
2010-02-19 16:01:50 status installed metacity 1:2.28.1-0ubuntu2
2010-02-19 16:01:50 configure virtuoso-nepomuk 6.1.0-0ubuntu3 6.1.0-0ubuntu3
2010-02-19 16:01:50 status unpacked virtuoso-nepomuk 6.1.0-0ubuntu3
2010-02-19 16:01:50 status half-configured virtuoso-nepomuk 6.1.0-0ubuntu3
2010-02-19 16:01:50 status installed virtuoso-nepomuk 6.1.0-0ubuntu3
2010-02-19 16:01:50 configure xserver-common 2:1.7.5-1ubuntu1 2:1.7.5-1ubuntu1
2010-02-19 16:01:50 status unpacked xserver-common 2:1.7.5-1ubuntu1
2010-02-19 16:01:50 status half-configured xserver-common 2:1.7.5-1ubuntu1
2010-02-19 16:01:50 status installed xserver-common 2:1.7.5-1ubuntu1
2010-02-19 16:01:50 configure xserver-xorg-core 2:1.7.5-1ubuntu1 2:1.7.5-1ubuntu1
2010-02-19 16:01:50 status unpacked xserver-xorg-core 2:1.7.5-1ubuntu1
2010-02-19 16:01:50 status half-configured xserver-xorg-core 2:1.7.5-1ubuntu1
2010-02-19 16:01:51 status installed xserver-xorg-core 2:1.7.5-1ubuntu1
2010-02-19 16:01:51 configure soprano-daemon 2.4.0.1+dfsg.1-0ubuntu4 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 status unpacked soprano-daemon 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 status half-configured soprano-daemon 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 status installed soprano-daemon 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 configure libsoprano4 2.4.0.1+dfsg.1-0ubuntu4 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 status unpacked libsoprano4 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 status half-configured libsoprano4 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 status installed libsoprano4 2.4.0.1+dfsg.1-0ubuntu4
2010-02-19 16:01:51 trigproc libc-bin 2.11.1-0ubuntu2 2.11.1-0ubuntu2
2010-02-19 16:01:51 status half-configured libc-bin 2.11.1-0ubuntu2
2010-02-19 16:01:51 status installed libc-bin 2.11.1-0ubuntu2

Nicolò Chieffo (yelo3) wrote :

This issue is not solved by those updates in my installation.

Martin Pitt (pitti) wrote :

Confirmed more by duplicates, targetting to lucid.

Changed in plymouth (Ubuntu Lucid):
importance: Undecided → High
tags: added: iso-testing
Usama Akkad (damascene) wrote :

I didn't understand the whole report because it's too tecniacl for me

some time on my system I get the mouse only working on the X and I need to switch to VT and to go back to X to solve it.
then I suddenly I get kicked out to the login screen

I'm using auto login

elaveriao (elaveriao) wrote :

Usama Akkad. You get kicked out because of #522692. See more information.

https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/522692

I can confirm this and #522692 on my Dell Vostro 1710. I don't know if it's related, but both bugs affects me when using Broadcom STA (privative license) driver. Which seems to be Martin's case.

But both bugs seem to go away if I use b43 (free license) driver (unfortunattly, then I get hit by #502433).

godhika (godhika) wrote :

I can confirm this behaviour also on a Dell studio 15 laptop without any propietary driver and ATI HD 3450 card, but would also like to share another observation: This bug does not appear when ureadahead is in "data-collection-mode" (so for example after a kernel update) only when it is doing what it is supposed to do - speed up the boot process (at least on my box). That also might be an explanation why people seem to report (in the ubuntuforum) that the bug disappears after some updates.

Steve Langasek (vorlon) on 2010-03-12
Changed in plymouth (Ubuntu Lucid):
milestone: none → ubuntu-10.04-beta-1
assignee: nobody → Scott James Remnant (scott)

I'v reported my bug #510524 as a duplicate of this bug.

KJ4OHH (kj4ohh) wrote :

I'm having similar problems on my System76 Starling netbook.

I get the Ubuntu splash screen, then it goes back to a text screen with cursor blinking at the top left and mouse cursor visible.

I'm able to switch back to full X screen by pressing ctrl-alt-F7.

I seem to have no other problems and the system seems to be working besides having to switch back to X after boot. In face I'm using my netbook to file this bug report now.

Launchpad Janitor (janitor) wrote :
Download full text (4.1 KiB)

This bug was fixed in the package plymouth - 0.8.0~-13

---------------
plymouth (0.8.0~-13) lucid; urgency=low

  [ Steve Langasek ]
  * Don't attach /proc/cmdline to apport reports, this is already in the
    standard info that gets collected...

  [ Alberto Milone ]
  * ubuntu_logo theme:
    - New logo from Otto Greenslade.
    - Switch off dots starting from the ones on the left instead of
      switching them off all at once.

  [ Scott James Remnant ]
  * Move the Ubuntu logo up as discussed with Otto, this makes the mouse
    cursor appear between the logo and dots and solves the optical illusion
    of the logo being too low. LP: #535014.
  * Don't include message about disk checks, which can come from mountall.
  * Drop the rc script splash functions, we don't want the SysV-rc compat
    stuff messing around with the splash screen - this can be entirely
    managed by Upstart now. LP: #528787, #537262.

  * Plymouth Fix Mega Patch:
    - This hasn't yet been broken up into enough bits to send upstream, and
      doesn't *quite* address all the issues yet, but it's a major step.

    - Rewrite the VT handling, rather than abusing /dev/tty0 keep all VT
      operations on the actual VT (tty7), this avoids issues where we set
      the graphics mode of the wrong VT or put the wrong VT into VT_PROCESS
      mode. LP: #520460, #522598, #526321, #533135
    - Don't attempt VT switch when using non-VT consoles.
    - Make VT mandatory for renderer plugins, so we fallback gracefully to
      text when the console is not a VT. LP: #516825, #527083.
    - Restore VT when finished displaying the splash unless plymouth quit
      is called with --retain-splash. LP: #506297.
    - Activate VT from text and details plugins, rather than haphardly in
      the main code, this means the textual boot is also on VT7.
      LP: #518352, #520122.
    - Add a --has-active-vt command that can let gdm inquire whether it
      should reuse Plymouth's VT; fixes the issue where Plymouth has no
      visible splash screen and X ends up on VT1. LP: #519641, #533572.

    - Don't open terminal device in X11, fixes the issue where X will crash
      when debugging plugins using the X11 renderer.
    - Add --tty option to plymouthd for debugging when X is running and
      thus using an alternate VT.

    - Improve deactivate command so that the terminal is no longer watched
      for keyboard input, session is closed, etc. LP: #528787, #531650.
    - Ignore mode changes while deactivated, otherwise we can end up
      resetting the VT back into text mode while X is starting up.
      LP: #523788, #502509.

    - Fix races with simultaneous quit and deactivate commands, or multiples
      of those commands.
    - Ignore --show-splash, --hide-splash, etc. commands while deactivated.
    - Add reactivate command for testing purposes.

    - Don't scan out drm buffer contents to fbcon when not called with
      quit --retain-splash. LP: #527180.

    - Avoid resetting the terminal to unbuffered mode on every write, this
      results in setting X's VT into raw mode and results in the X server
      crashing on key presses. LP: #532047, #534861, #519460, #520...

Read more...

Changed in plymouth (Ubuntu Lucid):
status: Confirmed → Fix Released

It's not solved for me with daily iso desktop amd64
http://cdimage.ubuntu.com/daily-live/20100313.1/
which use plymouth 0.8.0 -14

I set the bug to "confirmed", problem is still here on 20100314 netbook and desktop iso

Changed in plymouth (Ubuntu Lucid):
status: Fix Released → Confirmed

Patrice: I'd appreciate it if you could file a new bug for me, your problems aren't the same as Martin's (since he has identical hardware to me) - and it'd help me debug if I could read your collected information (use ubuntu-bug to file it)

Also please describe in as much detail as you can everything you see during boot.

Thanks

Changed in plymouth (Ubuntu Lucid):
status: Confirmed → Fix Released
Steve Langasek (vorlon) wrote :

Well, Patrice did already have his own bug, so unmarking bug #510524 as a duplicate.

@Scott : indeed, I thought it was the same bug. I'v already reported my bug with files and a video on #510524

@Steve : thanks

Patrice: that was with a much older plymouth - I'd appreciate it if you could do the same again for the current version, and file a new bug with a new video

@Scott, okay. I will do this tonight.

@Scott : reported #510524 with a new video and datas.

Oups I mean #539507

memartin (memartin) wrote :

I'm reporting here because #527009 is marked as duplicate as this one. I get the exact behavior described there. I see X start with the rolling circles, then my login screen flashes up und suddenly goes dark again, showing only some wrong-coloured watermark version of my background image (I'm using plain kdm logon). Doing something like Ctrl+Alt+F1 and then Ctrl+Alt+F7 "refreshes" teh login screen to display correctly (I already knew this trick because PartedMagic requires me to do the same when I start it.)

This is on a do-release-upgrade'd lucid beta form karmic on my ThinkPad T42. lspci says this is my graphics adapter:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]

PS: I've also noticed a sudden X restart after having played a video. Maybe it relates, someone "upstairs" mentioned behavior like this. I've only upgraded this morning, so I cannot say very much more.

memartin (memartin) wrote :

Thanks for the Fix, it solved my problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers