Comment 22 for bug 1794292

Gert van de Kraats (gkraats) wrote :

Problem not solved.

I think I got 4 problems:

1)
I think the second ppa (*mtrudel2*) has exacly same contents as the first one.
At least the binaries and shared loadlibraries have the same time stamp (15 october).
So this will not contain the last version.

2)
I have the idea the shared loadlibs are not overwritten at the install.

3)
The file /etc/plymouth/plymouthd.cfg, containing local settings was overwritten.
I do not know if this is caused by "apt-get install" or by "make install" on localcode.
According to contents of this file, this should not occur.

4)
My proposed fix solves a bug, but probably not the problem.
To verify updating of the loadlibs I did "make install" with my own local code including an extra tracing message.
This crashed again with the usual stacktrace.
I include the plymouth trace plymouth-debug_GK91.log.
After the 5 seconds device timeout (caused by the missing setting to 10 seconds at /etc/plymouth/plymouthd.cfg)
the frame buffer device /dev/fb0 is activated, because drm still not initialized.
Also keyboard is activated for fb0.
Later on the is en event: got remove event for device fb0,
causing "ply_renderer_free:Unloading renderer backend plugin".
At the end the keyboards are deactivated including the one for fb0,
which is pointing to a non-existing backend.
So I think also the keyboard should be removed (if present)
if a device is removed.
This should avoid the crash. but I doubt the splash will be displayed correctly.
At my slow PC the problem is always reproducable by setting the timeout to 1.