"libpeas-WARNING **: Failed to run internal Python hook 'find_extension_type':" on enabling of 'External tools' plugin

Bug #1743133 reported by Norbert on 2018-01-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pluma (Ubuntu)
Medium
Martin Wimpress

Bug Description

Steps to reproduce:
1. Install Ubuntu 17.10 MATE
2. Install Pluma dependencies to fix neighbor bug 1743132 - `sudo apt-get install libpeas-1.0-python2loader gir1.2-pluma-1.0`
3. Launch Pluma text editor from terminal
4. Go to Edit->Preferences, Plugins tab, check "External Tools" plugin

Expected results:
"External Tools" plugin enabled successfully and shows no warnings

Actual results:
"External Tools" plugin enabled but, shows warning:

(pluma:3817): libpeas-WARNING **: Failed to run internal Python hook 'find_extension_type':
Traceback (most recent call last):
  File "peas-python-internal.py", line 71, in call
  File "peas-python-internal.py", line 130, in find_extension_type
AttributeError: 'module' object has no attribute 'UniqueById'

Notes:
1. `sudo apt-file search peas-python-internal.py` returns nothing.
2. unable to find peas-python-internal.py from Midnight Commander, so it seems to be packaging issue.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: pluma 1.18.2-1
ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
Uname: Linux 4.13.0-25-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: MATE
Date: Sat Jan 13 20:02:11 2018
InstallationDate: Installed on 2017-12-23 (21 days ago)
InstallationMedia: Ubuntu-MATE 17.10 "Artful Aardvark" - Release amd64 (20171018)
SourcePackage: pluma
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
description: updated
Norbert (nrbrtx) on 2018-01-13
tags: added: bionic
Norbert (nrbrtx) wrote :

18.04 LTS with all updates, bug exists.

Norbert (nrbrtx) wrote :

18.04 LTS with all updates, bug exists.

Changed in pluma (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Martin Wimpress (flexiondotorg)
status: In Progress → Triaged
Changed in pluma (Ubuntu):
status: Triaged → In Progress
Changed in pluma (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pluma - 1.20.1-3ubuntu1

---------------
pluma (1.20.1-3ubuntu1) bionic; urgency=medium

  * debian/patches:
    + Add 0001_disable_python_plugins.patch. Disable Python plugins because
      libpeas only supports Python3 and the Python plugins in Pluma only
      support Python2. (LP: #1743133) (LP: #1743137)

 -- Martin Wimpress <email address hidden> Wed, 25 Apr 2018 11:51:50 +0100

Changed in pluma (Ubuntu):
status: Fix Committed → Fix Released
John Pye (jdpipe) wrote :

Not a very good solution! FWIW I see that libpeas is supposed to support Python2:

https://github.com/GNOME/libpeas/blob/master/README

So perhaps there is a better solution here?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers