Unable to enable 'External Tools', 'Python Console', 'Quick Open', 'Snippets' plugins on Bionic

Bug #1743136 reported by Norbert on 2018-01-13
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pluma (Ubuntu)

Bug Description

Steps to reproduce:
1. Install Ubuntu 18.04 LTS
2. Install Pluma with `sudo apt-get install pluma`
3. Launch Pluma text editor from terminal
4. Go to Edit->Preferences, Plugins tab, make right click and click "Enable All", then click "Close"

Expected results:
Pluma enabled all plugins without problems

Actual results:
Pluma does not enable the following plugins and reports the following to the terminal:

** (pluma:3988): WARNING **: Could not load Pluma repository: Typelib file for namespace 'Pluma', version '1.0' not found

(pluma:3988): libpeas-WARNING **: Failed to load module 'pythonloader': /usr/lib/x86_64-linux-gnu/libpeas-1.0/loaders/libpythonloader.so: cannot open shared object file: No such file or directory

(pluma:3988): libpeas-WARNING **: Could not load plugin loader 'python'

1. the first problem is known as bug 1723259 and may be solved by `sudo apt-get install gir1.2-pluma-1.0`
2. the second problem is known as bug 1743132 and may be solved by `sudo apt-get install libpeas-1.0-python2loader` and the following `sudo apt-get install python-gi`, but this produces another error/warning about "peas-python-internal.py" as described in bug 1743133

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: pluma 1.18.3-2
ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
Uname: Linux 4.13.0-25-generic x86_64
ApportVersion: 2.20.8-0ubuntu6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Jan 13 20:20:18 2018
InstallationDate: Installed on 2017-12-22 (21 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20171221)
SourcePackage: pluma
UpgradeStatus: No upgrade log present (probably fresh install)

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

18.04 LTS with all updates, bug exists.

tags: removed: wayland-session
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers