Kubuntu 16.04.1 discover empty after fresh install

Bug #1663695 reported by Damien on 2017-02-10
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
appstream (Ubuntu)
Undecided
Unassigned
Xenial
High
Matthias Klumpp
packagekit (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned
plasma-discover (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * A previous update made AppStream use modern-style component-ids, thereby breaking the Qt library if it is reading data from the cache and if that data happens to be a desktop-application.
 * This leads to KDE's Discover not displaying applications.
 * The issue was introduced by a patch to the Xenial version of AppStream, and is not present in any other version of the package in Ubuntu, affecting Xenial only.

[Test Case 1]

 * Update the libappstream-qt package, run Discover: All apps should be loaded correctly.

[Regression Potential]

 * Low, this change affects only the Qt bindings and nothing else. The change is also a simple string value change.

Damien (damien.kde) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-discover (Ubuntu):
status: New → Confirmed

Please:

1. Install the "muon" package.
2. If that fixes the problem, mark this report as duplicate of bug #1577918.
3. If it doesn't, in bug #1577918, say this report isn't a duplicate.
4. In this report, for the "packagekit" package, set status back to "confirmed".

Thank you.

description: updated
Changed in plasma-discover (Ubuntu):
status: Confirmed → Invalid
importance: Undecided → High
Changed in packagekit (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Changed in packagekit (Ubuntu):
status: Confirmed → Incomplete
Damien (damien.kde) wrote :

Please read the bug description. I installed muon and that did not solve the problem.
Related bug: https://bugs.kde.org/show_bug.cgi?id=376241 (note that this affects many users).

Carlo Vanini (silhusk) wrote :

All packages are marked as "technical" and therefore are hidden from the list in Discover. That's because libAppstreamQt looks for type "desktop" where instead it is "desktop-application" in the metadata.

Matthias Klumpp (ximion) wrote :

I just wanted to reject that assumption because the version of AppStream in Xenial was too old, but it turns out you're right: A backport from a newer version broke this, and I didn't notice because my AppStreamQt is also newer (and using a better architecture where this bug can't happen anymore).
So, +1 on the patch. I would probably when we are patching this, also add a few minor fixes to the autopkgtests in Xenial (I might do that tomorrow).

The attachment "change type string from "desktop" to "desktop-application"" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Matthias Klumpp (ximion) wrote :

Added a version of this patch which also fixes the automatic tests.

Changed in appstream (Ubuntu):
status: New → Fix Committed
Changed in packagekit (Ubuntu):
status: Incomplete → Fix Released
status: Fix Released → Invalid
Iain Lane (laney) on 2017-03-31
Changed in appstream (Ubuntu):
status: Fix Committed → Fix Released
Changed in appstream (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Changed in packagekit (Ubuntu Xenial):
status: New → Invalid
Changed in plasma-discover (Ubuntu Xenial):
status: New → Invalid
Matthias Klumpp (ximion) on 2017-03-31
description: updated
Iain Lane (laney) on 2017-03-31
Changed in appstream (Ubuntu Xenial):
status: Triaged → In Progress
assignee: nobody → Matthias Klumpp (ximion)
Brian Murray (brian-murray) wrote :

Does this not need fixing in Zesty? If that is the case please explain why not in the bug description.

Changed in appstream (Ubuntu Xenial):
status: In Progress → Incomplete
Matthias Klumpp (ximion) wrote :

I added an explanation (basically, a previous bugfix fixing GNOME Software broke this for the Qt bindings).

description: updated
Changed in appstream (Ubuntu Xenial):
status: Incomplete → In Progress

Hello Damien, or anyone else affected,

Accepted appstream into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/appstream/0.9.4-1ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in appstream (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Anonymous (cicerone55) wrote :

Tested Xenial (0.9.4-1ubuntu3), didn't work.

tags: added: verification-failed
removed: verification-needed
Matthias Klumpp (ximion) wrote :

@cicerone55: Are you sure you updated the right package? Please check if libappstreamqt1 is at that particular version, because that's where the bug is located.

Carlo Vanini (silhusk) wrote :

It works for me updating libappstreamqt1 to 0.9.4-1ubuntu3 on Xenial 16.04.2.

Can someone else confirm, please?

Matthias Klumpp (ximion) on 2017-04-11
tags: added: verification-needed
removed: verification-failed
Mario Badr (marioabdr) wrote :

Muon did not work.

sudo apt install libappstreamqt1/xenial-proposed did work after following the EnableProposed on Xenial 16.04.2.

Thanks!

Matthias Klumpp (ximion) wrote :

Okay, 3:1 for the "the update works" camp, as it looks like ;-)

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.