Kubuntu Discover search returns no results

Bug #1577918 reported by Peter Hewett on 2016-05-03
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
plasma-discover (Ubuntu)
High
Unassigned

Bug Description

Fresh install of Kubuntu 16.04. In the Discover app (software installer), any search returns no results, even when searching for apps I know are there, such as VLC. Similar symptoms reported by other users, for example https://www.reddit.com/r/Kubuntu/comments/4gt77k/i_cant_search_for_anything_in_the_app_store/ .

Revision history for this message
Matthias Klumpp (ximion) wrote :

Does running `sudo appstreamcli refresh --force` fix that for you?

Revision history for this message
Peter Hewett (peter-hewett) wrote :

No, that command did not change Discover. Still no search results at all.

~$ sudo appstreamcli refresh
[sudo] password for ###:
AppStream cache update is not necessary.
~$ sudo appstreamcli refresh --force
AppStream cache update completed, but some metadata was ignored due to errors.
~$

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in plasma-discover (Ubuntu):
status: New → Confirmed
Revision history for this message
Marco Dalla Libera (marco-dallas95) wrote :

hi, installing "muon" may solve the problem, for me it worked.

Revision history for this message
Jeffrey J. Martin (dogshed) wrote :

Just downloaded and installed Kubuntu. Not working for me either.

Revision history for this message
Graham Perrin (grahamperrin-gmail) wrote :

> installing "muon" may solve the problem, for me it worked.

The same for me; a quit from Discover then in a terminal window,

    sudo apt-get install muon

– after which, Discover began discovering what was sought.

Related
-------

http://kubuntu.org/news/kubuntu-16-04-lts-release-anouncement/

> Our new software center: **Plasma Discover** brim-full of software to choose from.

https://forum.kde.org/viewtopic.php?f=225&t=133288

> Issues with "Discover" (software utility) in Kubuntu 16.04

http://askubuntu.com/q/765130/25036 is now linked to a duplicate question http://askubuntu.com/q/761824/25036 with one answer but not (yet) the suggestion to simply install

muon

Revision history for this message
huseby (huseby) wrote :

Installing muon worked for me, thank you. Very annoying bug when your fresh to a new distro.

Revision history for this message
ryan (raiian12362) wrote :

Same issue. Installing Muon fixed, but occasionally issue returns requiring Discover to be closed and reopened.

Revision history for this message
Flamewart (mojinopocoescozio) wrote :

Same issue here.

Revision history for this message
Samuel Sol (yohanleafheart) wrote :

Another user with the same user.

This does not happen on my machine that was updated from 15.10 to 16.04. On my 16.04 machine the search functions ONCE every boot of MUON.

For example, let's say I search for PHP, I will find everything that is there. If I go and search again for something else, the search want work anymore. I need to restart either muon/discovery to work again.

Revision history for this message
Matteo Sechi (tomateschie) wrote :

I've installed Kubuntu 16.04.1 LTS a few days ago. I found this problem too. I've resolved as is written n the top of this thread.
sudo apt-get install muon

Thank you very much for your support and your help.

Revision history for this message
Ivan Borisov (borisov87) wrote :

i have same problem
sudo apt-get install muon
fix problem

Revision history for this message
Dimitrios Giorkas (j-georkas) wrote :

Same here. I wonder... It's been so long that haw been released, why you don't publish an update to fix the problem... It would be nice for everyone...

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :
tags: added: xenial
Changed in plasma-discover (Ubuntu):
importance: Undecided → High
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

It could be a consequence of (https://github.com/hughsie/PackageKit/issues/177).

Revision history for this message
Jeremy Bicha (jbicha) wrote :

This might be https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=845575

If so, it will be fixed in Ubuntu 17.04 Beta with LP: #1673302

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.