Please merge to pidgin 2.5.4-2

Bug #316636 reported by Hew on 2009-01-13
68
This bug affects 5 people
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Wishlist
Unassigned
Nominated for Jaunty by Johnathon

Bug Description

Binary package hint: pidgin

Pidgin 2.5.4 has been released, which contains a number of bugfixes.

http://developer.pidgin.im/wiki/ChangeLog

 pidgin (1:2.5.4-2ubuntu1) jaunty; urgency=low
 .
   * Merge from debian, remaining changes: (LP: #316636)
     - debian/control:
       + Add Build-Deps on liblaunchpad-integration-dev, intltool,
       network-manager-dev
       + Add epoch in dependencies
       + Drop the libpurple0 dependency on libpurple-bin
     - debian/libpurple0.symbols: add epoch to symbol
     - debian/pidgin-dbg.preinst, debian/pidgin-dev.preinst,
       debian/pidgin.preinst: add epoch
     - Update debian/prefs.xml to set the notify plugin prefs
       /plugins/gtk/X11/notify/*, set /pidgin/plugins/loaded to load
       the notify plugin and enable the standard logging options by default
     - debian/rules:
       + remove --disable-nm as nm has been fixed in Ubuntu
       + Add X-Ubuntu-Gettext-Domain to the desktop file and update the
         translation templates in common-install-impl::
     - debian/patches:
       + 02_lpi.patch for LP integration
       + 04_let_crasher_for_apport.patch to stop catching the SIGSEGV signal
         and let apport handle it
       + 05_default_to_irc_ubuntu_com.patch to set the default IRC
         server to irc.ubuntu.com
       + 70_autoconf.patch
       + fix-icons-backport-from-2.5.5mtn.diff:
         Fix to see buddy icons for new Windows Live users.
         The patch will be included in pidgin-2.5.5
 .
 pidgin (2.5.4-2) unstable; urgency=low
 .
   * Upload to unstable
 .
 pidgin (2.5.4-1) experimental; urgency=low
 .
   * New upstream version
   * Remove version-specific shlibdep generation, and add libgnt to
     libpurple0.symbols
 .
 pidgin (2.5.3-1) experimental; urgency=low
 .
   * New upstream release
     - Tries to fix treating special characters as html entities
       (Closes: #502802)

Related branches

Hew (hew) on 2009-01-13
Changed in pidgin:
importance: Undecided → Wishlist
Changed in pidgin:
status: New → Confirmed
Ivan Zorin (iaz) wrote :

In attachment - diff for upstream version.
Also it closes another bug - https://bugs.launchpad.net/pidgin/+bug/319547 (upstream - http://developer.pidgin.im/ticket/8198)
Included patch available here: http://developer.pidgin.im/attachment/ticket/8198/pidgin-NOT-UPSTREAM-2.5.4-icq-russia.patch
The upstream version can be downloaded here - http://downloads.sourceforge.net/pidgin/pidgin-2.5.4.tar.bz2

Ivan Zorin (iaz) wrote :

I've compiled pidgin (2.5.4) packages - looks like it works fine. This packages available in my ppa:
deb http://ppa.launchpad.net/iaz/ubuntu jaunty main
deb-src http://ppa.launchpad.net/iaz/ubuntu jaunty main
This packages for jaunty, but probably it can be successfully installed in intrepid as well.
Looks like it works well, but, however, just in case, there is no any warranty, so use it at your own risk.

Lauri Niskanen (ape3000) wrote :

Please add this to Jaunty.

Sebastien Bacher (seb128) wrote :

thank you for your work there, subscribing the universe sponsors is not correct since the software is not in universe, the change you added doesn't seem to have been accepted upstream yet so that's not something that should be used in ubuntu either, could you update your work and maybe sync on the debian experimental version?

Sebastien Bacher (seb128) wrote :

unsubscribing the sponsor team since the patch should not be used there and it requires merging on debian

I'm not very expert of ubuntu/debian sync, but looking at pidgin source changelog (https://launchpad.net/ubuntu/+source/pidgin) I've seen that 1:2.5.3-0ubuntu1 and 1:2.5.3-0ubuntu2 haven't any Ubuntu specific patch...so is it possible do an automatic sync to 2.5.4 or the newest 2.5.4-1?

Daniel Holbach (dholbach) wrote :

Alessio: The "ubuntu1" in "1:2.5.3-0ubuntu1" says: this is a change done in Ubuntu. How did you figure out there's no Ubuntu change? Did you check the diff between the two source packages?

Changed in pidgin:
status: Confirmed → Incomplete

Yes, you're right! There are some Ubuntu patches in 2.5.3-0ubuntu1/2.5.3-0ubuntu2 that must be merged with 2.5.4-1!

Didier Roche (didrocks) wrote :

Work on it

Changed in pidgin:
assignee: nobody → didrocks
status: Incomplete → In Progress

I don't know if this is the right way to do the merge, but maybe it can be useful: I've done a merge between 2.5.3-0ubuntu2 and 2.5.4-1: I've only added Ubuntu patch and some build deps to the original Debian version.. it builds fine in my PPA for Jaunty. I attach the debdiff between the Debian version 2.5.4-1 and my version 2.5.4-1ubuntu1

Didier Roche (didrocks) wrote :

Alessio: Ok, I will let you if you are still on it :)

Just, there is a new version in ubuntu (2.5.3-0ubuntu3) can you please merge it against this one and post again your debdiff?

Changed in pidgin:
assignee: didrocks → nobody
Changed in pidgin:
assignee: nobody → spinus1

Here the new debdiff, I've added the patch "fix-icons-backport-from-2.5.5mtn" introduced in version 2.5.3-0ubuntu3.
Didier, can you have a look at my debdiff, please?

I Don't know if I'm correct but you should keep track of the history
in the changelog: you completely removed version 2.5.3-0ubuntu3.
you should also remove ~ppa3 from the package name

Nicolò Chieffo (yelo3) wrote :

Question to developers to correctly do the merge (just to learn how to do it).
Are these steps correct?

- apt-get source pidgin
- download pidgin 2.5.4 from pidgin site
- untarbz2
- targz it to pidgin-2.5.4-orig.tar.gz
- cp -r pidgin-2.5.3/debian pidgin-2.5.4/
- cd pidgin-2.5.4
- dch -i
- correct the version in the changelog and add a description
- debuild -S -sa -us -uc
- debdiff pidgin_2.5.3-0ubuntu3.dsc pidgin_2.5.4-0ubuntu1.dsc > big_debdiff
- attach here the debdiff

Thanks for the informations

I attach a cleaned debdiff between pidgin_2.5.4-1 (Debian version) and pidgin_2.5.4-1ubuntu1 (merge from pidgin_2.5.3-0ubuntu3) I should attach even a debdiff from pidgin_2.5.3-0ubuntu3?

Sebastien Bacher (seb128) wrote :

the steps to do a merge on debian:

- get the current debian version and use that to do the update
- diff the debian directories between the debian and ubuntu versions
- reapply all the required changes to the debian version and summarize those in the changelog

Sebastien Bacher (seb128) wrote :

the current debdiff is not correct, you dropped several ubuntu changes and didn't summarize all the changes

I'm attacching new debdiff from pidgin_2.5.3-0ubuntu3 to pidgin_2.5.4-1ubuntu1...I've seen that pidgin_2.5.4-1ubuntu2 is just released..I must do the merge against the latest version?

Sebastien Bacher (seb128) wrote :

thank you for your work there but there is still some issue, how do you resync the version? the changelog entry should have all the debian uploads listed (2.5.2-1 is not listed in your upgrade for example) and only one ubuntu entry which summarize all the ubuntu change, you should also be descriptive about the changes and list what files are been changed and why there

Sebastien Bacher (seb128) wrote :

you also revert debian changes, they updated the rules to not generate a specific shlibs and fix bash specify usage there and your version roll back those change, you should try to understand what ubuntu changes are there and listing those in a detailed changelog would make that easier

Anyway I think we should wait for 2.5.5 since 2.5.4 crashes a lot (in msn)

Nicolò i havent had any crashs specific to MSN protocol.
I do have some, but are related to pulse audio or music apps writing to pidgin.
2.5.5 will only come after Feature Freeze, unless Sebastien gives it a FFE.

Nicolò Chieffo (yelo3) wrote :

I don't know if my crashes are msn specific. But I'm also experiencing
lost messages from windows live messages users. I hope the new pidgin
will be uploaded, since it has lots of closed bugs!

Didier Roche (didrocks) wrote :

After a talk with spinus, I handle it and he will try to begin with a bitsize bug to start packaging :)

Changed in pidgin:
assignee: spinus → didrocks
Didier Roche (didrocks) wrote :

diff.gz uploaded.

description: updated
Changed in pidgin:
assignee: didrocks → nobody
status: In Progress → Triaged
Didier Roche (didrocks) on 2009-02-23
description: updated
Sebastien Bacher (seb128) wrote :

thanks didier your work is mostly good, could you just keep your current changelog entry which summarize the change rather than copying all the other ones? those are not really required there, you also dropped the intltool-update call in the debian rules which is required for language packs to work

Changed in pidgin:
status: Triaged → Incomplete
Didier Roche (didrocks) wrote :

New diff.gz taking into account Sebastien's remarks.

Didier Roche (didrocks) wrote :
Changed in pidgin:
status: Incomplete → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.5.4-2ubuntu1

---------------
pidgin (1:2.5.4-2ubuntu1) jaunty; urgency=low

  * Merge from debian, remaining changes: (LP: #316636)
    - debian/control:
      + Add Build-Deps on liblaunchpad-integration-dev, intltool,
      network-manager-dev
      + Add epoch in dependencies
      + Drop the libpurple0 dependency on libpurple-bin
    - debian/libpurple0.symbols: add epoch to symbol
    - debian/pidgin-dbg.preinst, debian/pidgin-dev.preinst,
      debian/pidgin.preinst: add epoch
    - Update debian/prefs.xml to set the notify plugin prefs
      /plugins/gtk/X11/notify/*, set /pidgin/plugins/loaded to load
      the notify plugin and enable the standard logging options by default
    - debian/rules:
      + remove --disable-nm as nm has been fixed in Ubuntu
      + Add X-Ubuntu-Gettext-Domain to the desktop file and update the
        translation templates in common-install-impl::
    - debian/patches:
      + 02_lpi.patch for LP integration
      + 04_let_crasher_for_apport.patch to stop catching the SIGSEGV signal
        and let apport handle it
      + 05_default_to_irc_ubuntu_com.patch to set the default IRC
        server to irc.ubuntu.com
      + 70_autoconf.patch
      + fix-icons-backport-from-2.5.5mtn.diff:
        Fix to see buddy icons for new Windows Live users.
        The patch will be included in pidgin-2.5.5

 -- Didier Roche <email address hidden> Mon, 23 Feb 2009 18:30:20 +0100

Changed in pidgin:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.