pidgin text input box moves on text input (Gutsy Beta)

Bug #150428 reported by Brian Burger on 2007-10-08
38
Affects Status Importance Assigned to Milestone
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: pidgin

Pidgin 2.2.0 in Gutsy Beta - while typing in the text-input box while on IRC, the text you are entering moves up and down with each new character.

I asked in #pidgin on Freenode, and the dev there suggested it was either a font error, or a GTK/Gnome theme error causing it.

All text causes this annoying bouncing up and down - upper case, lower case, characters with ascenders or descender or without, puctuation - anything.

ciastek (ciastek) wrote :

Text-input box is simple too small. Resize it.

Brian Burger (bburger) wrote :

Surely the default text box size should be increased?

Resizing does work, but you have to drag it bigger every time you open a new window - hardly ideal.

Florian Boucault (fboucault) wrote :

Confirmed here.

Ka-Hing Cheung (kahing) wrote :

The jumpy behavior looks like a gtk/theme bug, I can reproduce by decreasing gedit's height and setting the font to monospace size 56.

Brian Burger (bburger) on 2007-10-09
Changed in pidgin:
status: New → Confirmed
Ka-Hing Cheung (kahing) wrote :

I committed a workaround e7a18c70a00a0534e1e6f7956970e10d6d0b69ec (and the couple commits before that) to make our auto-resize code correctly increase the size so it only jumps once. Note that the jumpy gtk bug is still there and this merely works around it.

Ka-Hing Cheung (kahing) wrote :

oh, and re comment #2, if you resize it the new size is remembered, so you don't actually need to resize every single time.

Ka-Hing Cheung (kahing) wrote :

hmm I can't set "E-mail me about changes to this bug report" without leaving a comment...

>hmm I can't set "E-mail me about changes to this bug report" without leaving a comment...

You can click on "Subscribe" under "Actions"

Tony Yarusso (tonyyarusso) wrote :

Confirming in Gutsy Final, fresh install.
Resolution: 1024x768
Graphics: ATI Radeon Mobility X300, free driver
Confirming that resizing the box height fixes the issue, but you have to do it separately for every window you open and every time you start Pidgin.

Mikael Nilsson (mini) wrote :

I have the jumping text issue in both pidgin and firefox now...

crf (chrisfahlman) wrote :

ogg/theora screencapture video of the bouncing text in pidgin.

Tony Yarusso (tonyyarusso) wrote :

This is fixed now, is it not?

Yes, it is fixed. Bug closed.

Changed in pidgin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments