cannot install PEAR modules (edgy, amd64)

Bug #76846 reported by Matt Galvin on 2006-12-22
4
This bug affects 1 person
Affects Status Importance Assigned to Milestone
php5 (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: php-pear

When I try to install any pear module I get a memory allocation error. Below is an example.

--- snip ---
sudo pear install MDB2
/tmp/glibctest8GOtvu:1:22: error: features.h: No such file or directory
downloading MDB2-2.3.0.tgz ...
Starting to download MDB2-2.3.0.tgz (103,322 bytes)
........................done: 103,322 bytes

Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 7680 bytes) in /usr/share/php/PEAR/PackageFile/v2/Validator.php on line 1515
--- snip ---

Well, since I found this page while Googling for more or less the exact same error message that I received on RHEL 5 x64, I think this can safely be classified as an upstream issue.

The PHP bug report is here: http://pear.php.net/bugs/bug.php?id=1596 . It's marked Bogus.

Mathias Gug (mathiaz) wrote :

As suggested in the bug report mentioned above, could you try to use peardev instead of pear to install your pear module ?

Changed in php5:
importance: Undecided → Low
status: New → Incomplete
Soren Hansen (soren) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, I am closing it because the bug has been fixed in the latest development version of Ubuntu - the Gutsy Gibbon.

If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at [WWW] https://help.ubuntu.com/community/UbuntuBackports#request-new-packages

Changed in php5:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers