iMac G3 DV SE reboots instead of halting

Bug #46445 reported by Stefan Güls on 2006-05-24
14
Affects Status Importance Assigned to Milestone
pbbuttonsd (Ubuntu)
Medium
Unassigned

Bug Description

After having installed and upgraded from dapper flight 7 i had to update the firmware on above mentioned machine.

After the firmware upgrade (and 'zapping the PRAM' several times) neither ubuntu nor xubuntu is able to halt the machine.

Shutdown process looks normal, harddisk goes to parking, CRT goes black, but after a second or so the machine inevitably goes to reboot in a strange way. kernel messages complain about missing modules and login is possible, but desktop is messed ub in Gnome and Xfce.

If the machine is forcefully halted during this (by holding power button for 4 seconds) , at next power-up (or intendend reboot) everything is back to normal.

Stefan Güls (sguels) wrote :

Further investigation showed that this only appears with the original iMac keyboard, which has a power button. So this is obviously not solely an ubuntu problem, but an unfortunate combination of bad timings during shutdown. Somehow the keyboards 'thinks', its power button is pressed again, and restarts the machine.
*BUT* this doesn't happen with the Apple OS's on that machine, so I#d still call it a bug

Stefan Güls (sguels) wrote :

One day later the problem could be tracked down to pbbuttonsd.

I removed it (since it's an bubble-iMac, not a powerbook anyway) and the problem went away.

So maybe

Stefan Güls (sguels) wrote :

.... the installer should not install/enable pbbuttonsd when it identifies the machine as not being a powerbook

Timothy Smith (tas50) wrote :

Can someone test this under a Feisty build so we can see if this bug still exists?

http://cdimage.ubuntu.com/ports/releases/feisty/herd-5/

hendrikwout (hendrikwout) wrote :

I created a bug report (Bug #57069) some months ago (please read), which describes the same problem. It didn't help when uninstalling ppbuttonsd. Feisty stll have this problem.

So someone should join the duplicates.

I don't have no more access to the machine, but can confirm that the
problem reappeared even after the deinstallation of pbuttonsd.
IIRC the reboot did not happen when i disconnected the keyboard from the
USB port before the machine was completly shut down.

So what i found was that it happended after firmware update to the most
recenr one, and that the keyboard might have something to do with it.

hendrikwout (hendrikwout) wrote :

In some rare cases, the mac doesn't power on again (with an efficiëntie of 1/40)

The same problem happens when I use another usb keyboard (not the original mac keyboard with the powerbuton).

It doesn't happen with a blue imac g3 500 mhz.

PS. I'm using feisty

Chascon (chascone) wrote :

To furtehr complicate the keyboard and firmware theories, I get the problem when I manually cast "sudo shutdown -h now" but not when I shutdown from gdm or perhaps gnome or xfce. Unless basic unix commands have changed in the last few years I've been away from Gnu-Linux, the "-h" should still tell the computer to shutdown, with the -h for halting the hd?.

I run the iMac DV 400 Mhz with a keyboard with the power button and I never noticed this problem back when I ran warty or hoary on this same hardware.

Strange.

Chascon (chascone) wrote :
Download full text (4.1 KiB)

I know it's been a few years and considering that Canonical dumped PPC, this probably isn't being worked upon. Gad, I assume as much as this bug has been around 2006. I'm writing this in 2009. The only real chance of it being solved is reporting it to Debian, which has never stopped supporting PPC, officially or otherwise. I'll report it to Debian and post a copy of this to my blog for reference to other PPC users. For reference, I had this problem with Jaunty (Ubuntu-PPC) and have it with Lenny (Debian).

UPDATE: I've done a bit of research and this is what I've thought it could be, although no machead in #macosx (at least, when I've asked) dares hypothesize or cares. I did not consider that pbbuttonsd was causing the problem because I don't have it installed.

1. Could be a dead or dying battery. Fix: replace it.
2. Could be corrupt firmware, on the off chance --although I don't quite see how. Fix: start up command(open apple key)+opt+p+r and hold till you hear 3 chimes. This will reset the internal clock (which supposedly will need updating) --among other things. I hope you set your OS to use external clock settings and not the open firmware ones.
3. Jammed power button. Fix: make sure it pops out (ease it with your finger) at boot up.

Now for the deductive (or inductive) part. Since this problem didn't present itself with OS X, which I recently had installed, it isn't a firmware, battery issue, or a jammed power button (especially since I've checked them and verified they pop out when powering up).

Still, I reset the pram settings just in case they were at fault. This doesn't change the behavior. In fact, what does is unplugging the USB keyboard immediately after issuing shutdown.

Earlier, I thought it might NOT have been the keyboard because the problem inconsistently presented itself --with it and without it plugged in. I thought it had to do with from where the shutdown routine had originated (X11 or not) and maybe had to do with the type of shutdown command issued, "halt" or "shutdown -h now". I had better luck with "shutdown -h now". I've had the unwanted automatic reboot enough times with both the command and X11 environments to know it has nothing to do with the type of shutdown command issued or the environment origin.

Work around #1
So, I've been unplugging my keyboard immediately after issuing a shutdown and it works faithfully. That is, until I started to leave a USB audio device --which is picked up as a sound card by alsamixergui-- plugged in. at first, I thought back to square one. It isn't my keyboard. But then I thought, could it be my keyboard and my newly introduced external gadget? A certain Niel that posted on an Apple discussion thread thinks so (some OS X users have been having the same issue).

"Some external USB devices send out a boot signal;"

His work around consists of,
"... placing a self-powered USB hub between your computer and the device will filter out boot signals."
http://discussions.apple.com/thread.jspa?messageID=5034481

Notice that there is not mention of "timings" and that the Apple thread demonstrates that users of Apple's OS do (sometimes) have this problem.

Work around #2
So that's another...

Read more...

Chascon (chascone) wrote :

"2. Could be corrupt firmware" should be "2. Could be corrupt PRAM".

I'm working on fixing the above and will post a link when done, but suffice to say that the powered USB hub fix works and that I no longer think changing the shutdown would work.

Chascon (chascone) wrote :

Ok, the hardware work-around worked for a bit, but now the problem is back. Clearing my pram didn't help, either. I'm at a loss. The only thing that helps is taking out the USB peripherals. The thing that has me is that I honestly doubt it's the externals (signaling the reboot) because the HUB filtering work-around actually filters boot signals, so that my keyboard power button doesn't power-on my iMac.

And a dead battery would be causing a power-on problem, not a power-down/reboot one. So, it must be purely software related at the source interacting with the keyboard. I have no clue what it might be, although I have noticed firestarter attempting to start as powering down. The thing is, I've powered firestarter down before issuing a shutdown and it doesn't always prevent a reboot. So, I don't know if it's at fault. I've also killed the associated xscreensaver daemon before shutting down without luck.

I'm grasping at straws here, but I guess it could still be firestarter caused as it's only a front end to iptables and if's set something amiss ...

Chascon (chascone) wrote :

I should note to those that might read this and that might be suffering from the above symptoms, this computer finally died and so I assume that the mentioned behavior was symptomatic of failing hardware. The iMac DV does boot anymore. The from lights up and that's about it.

I spent some time reading up on it and it could be one of two things if I recall correctly.

It could be a capacitor, which should show up deformed (from over heating upon inspection, in which case it could be replaced fairly easily by a tech. This has been reported to be a common design problem with all the fruits colored iMacs.

Or the tube could be dead, which might be preemptively cutting the boot sequence. To remedy the latter case, disconnecting the cable leading to the tube and then running it with an external monitor (connected to the external monitor "jack" at the back) might be a solution.

Note that I have not had the time or patience to test either of these solutions above and they are not guaranteed in any way. You're on your own if you try to service it yourself (or have anyone else do it, for that matter) and something bad happens.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers