Please update to the newer version of patchelf in bionic

Bug #1753482 reported by Sergio Schvezov on 2018-03-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
patchelf (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]

 * New architecture support in xenial where the current version has FTBS e.g.; armhf, s390x
 * The new code adds logic to reorder Program Headers appropriately.
 * New feature (specific flag, --no-default-lib) to disable LD_LIBRARY_PATH

[Test Case]

 * Use snapcraft's test suite which is a heavy user of patchelf.
 * snapcraft's test suite on the new architectures
 * patchelf's integrated tests
 * exploratory testing of patchelf.

[Regression Potential]

 * Minimal possibility of patching to break on obscure binaries
 * 0.9-1 has already been available on artful and bionic with no bugs reported
 * No deb dependes on patchelf, snapcraft installs patchelf during runtime
   during runtime due to the FTBS. This would change that.

[Other Info]

 * NixOS upstream https://github.com/NixOS/patchelf
 * Current version in artful and bionic: 0.9-1
 * Current version in xenial: 0.8-4. With FTBS for armhf and s390x

description: updated
no longer affects: patchelf (Ubuntu Bionic)
summary: - Please update to a newer version of patchelf
+ Please update to the newer version of patchelf in bionic
no longer affects: patchelf (Ubuntu Artful)
description: updated

Hello Sergio, or anyone else affected,

Accepted patchelf into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/patchelf/0.9-1~ubuntu16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in patchelf (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
Sergio Schvezov (sergiusens) wrote :

We have (snapcraft team) extensively tested this. Also verified it works on armhf as expected (a missing architecture in xenial).

The snapcraft upstream autopkgtests, which make use of patchelf in its tests, albeit with a `copy-package -b` of what is in xenial-proposed due to trigger limitations due to the nature of how autopkgtests is setup for upstream also pass as expected:

- amd64 https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial-snappy-dev-snapcraft-daily/xenial/amd64/s/snapcraft/20180322_055150_7b75c@/log.gz
- arm64 https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial-snappy-dev-snapcraft-daily/xenial/arm64/s/snapcraft/20180322_113409_7b75c@/log.gz
- armhf https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial-snappy-dev-snapcraft-daily/xenial/armhf/s/snapcraft/20180322_055044_7b75c@/log.gz
- i386 https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial-snappy-dev-snapcraft-daily/xenial/i386/s/snapcraft/20180322_044844_7b75c@/log.gz

git-ubuntu, through buildd's was also tested with this new patchelf, here are the build logs: https://launchpadlibrarian.net/361571861/buildlog_snap_ubuntu_xenial_amd64_git-ubuntu-test_BUILDING.txt.gz
git-ubuntu built as a snap passes its self-tests

A previously non available architecture, s390x is now also usable for patchelf, here's the output of a subiquity build driven by snapcraft on buildd https://launchpadlibrarian.net/361513081/buildlog_snap_ubuntu_xenial_s390x_subiquity-test_BUILDING.txt.gz

tags: added: verification-done-xenial
removed: verification-needed-xenial
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package patchelf - 0.9-1~ubuntu16.04.1

---------------
patchelf (0.9-1~ubuntu16.04.1) xenial; urgency=medium

  * No-change backport to xenial (LP: #1753482)

 -- Sergio Schvezov <email address hidden> Tue, 13 Mar 2018 10:06:55 +0000

Changed in patchelf (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for patchelf has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers