new sizes are undocumentedly in megabytes

Bug #82848 reported by Martin Pitt on 2007-02-02
12
Affects Status Importance Assigned to Milestone
partman-partitioning (Ubuntu)
Low
Unassigned
ubiquity (Ubuntu)
Medium
Colin Watson

Bug Description

Binary package hint: ubiquity

ubiquity ppc, 20070201.1 (herd-3 candidate), manual partitioning: I removed all partitions but the tiny /dev/hda1 and the bootstrap partition hda2, then created swap as hda3, a 6 MB / as hda4. Afterwards I'm unable to create a hda5 (about 23 GB) as /home with either ext3 or reiserfs. The dialog closes, it re-thinks about partitions, but it does not appear, and there is no feedback.

I gradually made the partition smaller, and then it finally worked when I set it to 21 GB. It displays 23'492'787'200 bytes of free space, and even 23'400'000'000 didn't work yet. OTOH, if I use 23'000'000'000, it actually allocates 20'633'190'912 bytes, wasting 3 GB.

Related branches

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :
Colin Watson (cjwatson) wrote :

The problem is actually that new partition sizes are in megabytes if you don't specify a unit; "23492700000B" would have worked. The partman-partitioning/new_partition_size template should be fixed to make this clear.

Changed in partman-partitioning:
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

In the meantime, ubiquity could definitely make this clearer in the UI somehow (maybe a spinbutton in megabytes or similar) and needs to handle partman/exception_handler_note.

Changed in ubiquity:
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) on 2007-02-02
Changed in ubiquity:
assignee: nobody → kamion
status: Confirmed → Fix Committed
Colin Watson (cjwatson) wrote :

ubiquity (1.3.18) feisty; urgency=low

  * New partitioner:
    - Disable the mountpoint combo box when creating or editing a partition
      if the method is changed to something other than a filesystem.
    - Handle partman/exception_handler and partman/exception_handler_note
      (LP: #82848).
    - Note that unadorned sizes are assumed to be in megabytes (LP: #82848).
    - Display current partition sizes in megabytes (part of LP: #83166).
    - Implement resizing. Ask for the size using a spinbutton (in megabytes)
      rather than a text entry field.
    - Offer 'fat16' and 'fat32' filesystem types for new partitions rather
      than the non-existent 'fat' (LP: #83211).
    - Fix crash when backing up to automatic partitioning page (LP: #83230).
  * doc/README: Add comment about language pack installation following a
    query from Telmo Baía.
  * Fix crash due to underqualification of debconf.DebconfError (thanks,
    Joel Bryan Juliano; LP: #83008).
  * Automatic update of included source packages: partman-partitioning
    45ubuntu1.

 -- Colin Watson <email address hidden> Mon, 5 Feb 2007 13:17:27 +0000

Changed in ubiquity:
status: Fix Committed → Fix Released
Changed in partman-partitioning:
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers