Ubuntu

Installation doesn't change partition ID

Reported by Joosep-Georg on 2007-10-06
100
This bug affects 1 person
Affects Status Importance Assigned to Milestone
partman-base (Debian)
Fix Released
Unknown
partman-base (Ubuntu)
Critical
Colin Watson
Hardy
Critical
Colin Watson
Intrepid
Critical
Colin Watson

Bug Description

In the installer's partitioner, if you change an existing partition (say, NTFS) to ext3 so that you can install Ubuntu there but make no other changes (e.g. do not resize any partitions), partman mistakenly does not record the partition table as changed, and so the partition type field in the partition table remains as HPFS/NTFS. This causes GRUB to fail to install because it's fussy about the partition type.

I believe this is a fairly common reason for installation failures, and so I think it's worth backporting this fix to Ubuntu 8.04.2.

This bug was fixed for Ubuntu 8.10 as follows:

  http://bazaar.launchpad.net/~ubuntu-core-dev/partman-base/ubuntu/revision/109

... and backported to hardy-proposed here:

  http://bazaar.launchpad.net/~ubuntu-core-dev/partman-base/hardy-proposed/revision/88

TEST CASE: Install Windows (for example, taking the whole disk), then start the Ubuntu installer and use manual partitioning. Be careful not to create, delete, or resize any partitions; instead, just edit the existing NTFS partition, set it to "Use as: ext3", and mount it on /. Finish partitioning, ignoring the "no swap" warning. Before this fix, GRUB should fail to install towards the end of installation; afterwards, it should succeed.

At present I know of no plausible regressions likely to happen with this patch, other than the partitioner breaking completely due to some kind of miscompilation. It's probably worth testing an LVM installation on general principles.

Colin Watson (cjwatson) wrote :

I've reproduced this, although I don't yet know where it belongs.

Changed in partman-base:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → kamion
milestone: none → ubuntu-8.10
Colin Watson (cjwatson) wrote :
Changed in partman-base:
status: Unknown → New
Colin Watson (cjwatson) on 2008-10-10
Changed in partman-base:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 121ubuntu7

---------------
partman-base (121ubuntu7) intrepid; urgency=low

  [ Colin Watson ]
  * Exit straight away if a called script is killed by a signal.
  * Disable backup while displaying device/partition locked errors; it makes
    no sense and it can cause us to exit without closing the FIFO to
    parted_server (LP: #274219).
  * Record that CHANGE_FILE_SYSTEM changes the partition table
    (LP: #149832).

  [ Evan Dandrea ]
  * Exclude devices that have mounted partitions. Useful for when installing
    from a disk (LP: #276656). This can be disabled by preseeding
    partman/filter_mounted to false.

 -- Evan Dandrea <email address hidden> Sun, 12 Oct 2008 02:32:41 -0400

Changed in partman-base:
status: Fix Committed → Fix Released
Colin Watson (cjwatson) wrote :

I think we should backport this for Ubuntu 8.04.2. I'm discovering quite a few installation failure reports due to this (I suspect many of those that say "the file /boot/grub/stage1 not read correctly" are due to this, since grub will fail to mount a filesystem using its internal filesystem libraries if the partition has the wrong type), and I think backporting this one would be an easy big win.

Changed in partman-base:
importance: Undecided → Critical
milestone: none → ubuntu-8.04.2
status: New → Triaged
Changed in partman-base:
status: New → Fix Released
Colin Watson (cjwatson) on 2008-11-03
Changed in partman-base:
assignee: nobody → kamion
Colin Watson (cjwatson) on 2008-11-03
Changed in partman-base:
status: Triaged → In Progress
Colin Watson (cjwatson) on 2008-11-20
description: updated
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in partman-base:
milestone: ubuntu-8.04.2 → none
status: In Progress → Fix Committed
Colin Watson (cjwatson) wrote :

I've just uploaded ubiquity 1.8.13 to hardy-proposed, including this fix. (Prior to this, testing was only possible with alternate/server CDs.)

Dave Morley (davmor2) wrote :

Tested on cd 20090112.1.

Grub now boots the system correctly and looking at gparted the partition is now listed as ext3.

Steve Beattie (sbeattie) wrote :

I have also verified that, using the desktop hardy CD from 20090112.1, the partitioner properly sets the partition type to ext3 from HPFS/NTFS if no changes have been made to the partition layout. Marking verification-done.

Steve Beattie (sbeattie) wrote :

Oh, yes, using the alternate hardy CD image from 20090112.3, I verified that setting up an LVM install over a former ntfs partition also works correctly.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package partman-base - 114ubuntu6

---------------
partman-base (114ubuntu6) hardy-proposed; urgency=low

  * Record that CHANGE_FILE_SYSTEM changes the partition table
    (LP: #149832).

 -- Colin Watson <email address hidden> Thu, 20 Nov 2008 12:40:40 +0000

Changed in partman-base:
status: Fix Committed → Fix Released
Raoul Bhatia (raoul-bhatia) wrote :

hi. thank you for resolving this issue. as far as i can see this has been also pushed upstream to debian into partman-base128. cheers,

Colin Watson (cjwatson) wrote :

Yes, as you can see from the upstream changelog, I did that myself.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.