[amd64] partimage not synced or build

Bug #198724 reported by KBios
112
This bug affects 18 people
Affects Status Importance Assigned to Milestone
partimage (Debian)
Fix Released
Unknown
partimage (Ubuntu)
High
Unassigned
Declined for Karmic by Sebastien Bacher
Declined for Lucid by Sebastien Bacher
Declined for Maverick by Sebastien Bacher

Bug Description

Binary package hint: partimage

Partimage 0.6.7 has been recently released and packaged for i386, powerpc and sparc. Would be nice to have also the amd64 version.

Revision history for this message
Brian Pitts (bpitts) wrote :

Why does hardy have 0.6.7-1 for i386 but 0.6.4-17 for amd64?

Revision history for this message
Uwe Naumann (naumannu) wrote :
Revision history for this message
Alessio Treglia (quadrispro) wrote :

Already fixed.

Changed in partimage (Ubuntu):
status: New → Fix Released
Revision history for this message
Steve (stupendoussteve-deactivatedaccount) wrote :

This package was never built for AMD64 in Jaunty, and is still not slated to be built for Karmic at the moment.

See: https://launchpad.net/ubuntu/jaunty/+source/partimage/+builds and https://launchpad.net/ubuntu/jaunty/amd64/partimage

Changed in partimage (Ubuntu):
status: Fix Released → Confirmed
Revision history for this message
Steve (stupendoussteve-deactivatedaccount) wrote :

Partimage AMD64 was previously deleted from the archive due to it being broken on the architecture. New and fixed builds of Partimage have not been built for AMD64 in Jaunty or now Karmic.

Revision history for this message
Morten Kjeldgaard (mok0) wrote :

I can confirm that partimage compiles under amd64.

However, it does not seem to work correctly for me. It gets stuck in dialogue that asks the user if the /dev/dm inode should be created. You can select "Yes" or "No" it doesn't matter; partimage just keeps re-displaying the dialogue.

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) wrote :

The /dev/dm is an old bug and not specific to AMD64. You wouldn't happen to be using lvm would you?

See bug 120497 as well as the linked Debian bug, also http://article.gmane.org/gmane.comp.sysutils.partimage.user/53

Revision history for this message
Morten Kjeldgaard (mok0) wrote :

Yes, I do use lvm.

Revision history for this message
Steve Kowalik (stevenk) wrote :

Unsubscribing ubuntu-archive, since there is nothing for us to do.

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) wrote :

Is anyone successfully using the Debian released version of partimage on amd64? If it is not broken I will look into creating a Debian bug to remove the Packages-arch-specific flag, which should allow it to build on Karmic.

Revision history for this message
trtl (pdersjant) wrote :

Running 9.04 amd64 here, I did the following:

$ sudo aptitude remove partimage
$ wget http://ftp.nl.debian.org/debian/pool/main/p/partimage/partimage_0.6.7-2_amd64.deb
$ dpkg -i partimage_0.6.7-2_amd64.deb
(downloaded from squueze repository, installed without errors).

Tried backing up my NTFS partition, which worked without any problems.

So, Steven, it seems the answer is yes ;-).

Revision history for this message
Tuomas Jormola (tjormola) wrote :

I guess we're missing partimage for amd64 also for karmic. What a shame. Why does it have to take years to fix something simple like this?

Revision history for this message
Germán Bassi (germanbassi) wrote :

I installed 64-bit karmic yesterday in a brand new intel core 2 duo E7500. I needed partimage in order to backup a NTFS partition, and thanks to trtl, I downloaded the debian package from lenny. It finished with a "successful" message.

I think there must me some way to bring this package into ubuntu's repos.

Revision history for this message
Dominik Stadler (dominik-stadler) wrote :

I built partimage on my PPA at https://launchpad.net/~dominik-stadler/+archive/ppa for Karmic and at https://launchpad.net/~dominik-stadler/+archive/dsta-jaunty-ppa for Jaunty. Both have been used successfully on 64-bit installations.

Nominating this for Lucid as I don't see any reason why this is still not included for amd64/x86_64-architecture.

Changed in partimage (Ubuntu):
importance: Undecided → Low
Revision history for this message
izzyb (izzyb) wrote :

I can confirm that downloading the debian squeeze package as explained in #11 works without issue. The package version has changed though, so best to check the debian site for the correct file to download.

http://packages.debian.org/squeeze/partimage

Given that I just wasted several hours trying to find out why I couldn't install partimage, I think the importance of this bug should be bumped up a little. I thought I was having a problem with my apt-sources configuration because others I talked to reported that it worked just fine for them. I didn't even think about it being a x86 vs amd64.

Perhaps a stub package could be provided in the short term that at least notifies the user of the problem. Its sad to see that this has been an ongoing issue for nearly 2 years. Especially given that there has been an obvious solution for 6 months. :(

Revision history for this message
Michael Vogt (mvo) wrote :

This is still a issue on lucid, could someone please have a look if partimage is in some sync blacklist ?

Changed in partimage (Ubuntu):
importance: Low → High
Michael Vogt (mvo)
summary: - [amd64] partimage not synced
+ [amd64] partimage not synced or build
Revision history for this message
James Westby (james-w) wrote :
Revision history for this message
Michael Vogt (mvo) wrote :

Thanks James,

it turned out that its in lp:~ubuntu-core-dev/packages-arch-specific/ubuntu and comes from debian. I did a local build of partimage and was able to create image with it. I have not tried restoring yet, but it appears that the 64 bit issues are fixed (but no reply from the upstream report yet).

Revision history for this message
C Pirnat (histoplasmosis) wrote :

Also confirming partimage can't be installed on Lucid. Whould be nice to have partimage.

Revision history for this message
James Westby (james-w) wrote :

Unsubscribing ubuntu-archive as we have the latest version synced.

Thanks,

James

Changed in partimage (Debian):
status: Unknown → New
Revision history for this message
Malte S. Stretz (mss) wrote :

I installed partimage-server_0.6.8-1+b1_amd64 on lucid, created an image and wrote it back to another system, all worked fine it seems.

Revision history for this message
agent 8131 (agent-8131) wrote :

This is still broken in Lucid. No partimage or partimage-server for amd64. Debian versions work fine.

http://packages.ubuntu.com/lucid/partimage

http://packages.debian.org/lenny/partimage

http://packages.debian.org/squeeze/partimage

Not sure why this is still a problem for Ubuntu.

Revision history for this message
WaywardGeek (waywardgeek) wrote :

Vinux users find this package useful, so I'm going to upload it to the Vinux/Lucid PPA so they can get it on amd64.

Revision history for this message
jerico (jerico-dev) wrote :

Bump. I just did a source install of partimage on lucid and built from source on amd64 without any trouble. Creating a partition image worked perfectly on this arch. The only problem seems to be that the Debian buildd team is waiting for the Debian maintainer to remove the arch from the blacklist. And the maintainer is not responding. Is there a way to fix this locally in Ubuntu? I'd like to fix this but unfortunately I don't know enough about Ubuntu's sync system to make a proposal let alone have the rights to do something. If I can help: please let me know how.

Revision history for this message
izzyb (izzyb) wrote : Re: [Bug 198724] Re: [amd64] partimage not synced or build

Strange, as I understand it, the problem is on Ubuntu's side. I used
the package from Debian to install on my Ubuntu system without a
problem. My understanding was that the Debian version was a 32 bit
version running on the 64bit platform because there were issues in the
partimage code making it unsafe for 64bit systems. Of course, this is
based on memory of a problem I don't fully understand so take it for
what it's worth. For me the fix was to install the .deb file as
provided by Debian and it's been working without issue since my post to
that effect on this bug.

...Izzy

jerico wrote:
> Bump. I just did a source install of partimage on lucid and built from
> source on amd64 without any trouble. Creating a partition image worked
> perfectly on this arch. The only problem seems to be that the Debian
> buildd team is waiting for the Debian maintainer to remove the arch from
> the blacklist. And the maintainer is not responding. Is there a way to
> fix this locally in Ubuntu? I'd like to fix this but unfortunately I
> don't know enough about Ubuntu's sync system to make a proposal let
> alone have the rights to do something. If I can help: please let me know
> how.
>
>

Revision history for this message
Steve (stupendoussteve-deactivatedaccount) wrote :

That problem was fixed some time ago.

The issue is all explained at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=572641

partimage is blacklisted in Debian, however they also have a binary available (created through a different process than the one Ubuntu uses). Ubuntu has it blacklisted for the arch because Debian does, thus Ubuntu's build system does not grab the source code and compile a binary for the arch.

Changed in partimage (Debian):
status: New → Fix Released
Revision history for this message
Shahar Or (mightyiam) wrote :

So... does this needs manual packaging in Ubuntu, also?

Revision history for this message
Fabrice Coutadeur (fabricesp) wrote :

Fixed since Natty. Closing as Fix Released.

thanks,
Fabrice

Changed in partimage (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.