partimage crashed with SIGSEGV

Bug #149930 reported by Martin Emrich on 2007-10-06
36
This bug affects 3 people
Affects Status Importance Assigned to Milestone
partimage (Ubuntu)
Medium
Unassigned
Nominated for Jaunty by Patrick T.

Bug Description

Binary package hint: partimage

I tried to create an image of a NTFS partition (WinXP x64) on gutsy amd64. After entering the image description, partimage crashed.

I tried it again with gdb, but the backtrace does not look helpful:

(gdb) where
#0 0x0000000000427833 in ?? ()
#1 0x0000000000428886 in ?? ()
#2 0x000000000041ece9 in ?? ()
#3 0x000000000040ed74 in ?? ()
#4 0x000000000041702a in ?? ()
#5 0x00002b94cc18cb44 in __libc_start_main () from /lib/libc.so.6
#6 0x0000000000404229 in ?? ()
#7 0x00007fffe0a6efc8 in ?? ()
#8 0x0000000000000000 in ?? ()

Ciao

Martin

ProblemType: Crash
Architecture: amd64
Date: Sat Oct 6 19:32:06 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/sbin/partimage
NonfreeKernelModules: cdrom floppy
Package: partimage 0.6.4-17
PackageArchitecture: amd64
ProcCmdline: partimage
ProcCwd: /home/martin
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=de_DE.UTF-8
 LANGUAGE=de_DE.UTF-8
Signal: 11
SourcePackage: partimage
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: partimage crashed with SIGSEGV
Uname: Linux garrett 2.6.22-13-generic #1 SMP Thu Oct 4 17:52:26 GMT 2007 x86_64 GNU/Linux
UserGroups:
SegvAnalysis:
 Segfault happened at: 0x427833 <_ZNSt8ios_base4InitD1Ev@plt+144963>: cmpb $0x0,0x8(%rbx)
 PC (0x00427833) ok
 source "$0x0" ok
 destination "0x8(%rbx)" (0x180000006d91a8) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA

Martin Emrich (emme) wrote :

StacktraceTop:CNtfsPart::readSuperBlock (this=0x6d0ea0) at fs_ntfs.cpp:100
CFSBase::saveToImage (this=0x6d0ea0, image=<value optimized out>, options=0x7ffff6e903e0,
savePartition (szDevice=0x7ffff6e96100 "/dev/sda1", szImageName=0x7ffff6e8e5c0 "/dev/sda",
main (argc=0, argv=0x7ffff6e96428) at main.cpp:562
__libc_start_main () from /lib/libc.so.6

Changed in partimage:
importance: Undecided → Medium
Uwe Naumann (naumannu) wrote :

I can reproduce this problem.

I found similiar tipps in www, that thi problem is obsolete with partimage 0.6.6 and 0.6.7, but at the moment the amd64-package for hardy is 0.6.4 :-(

Roger Binns (ubuntu-rogerbinns) wrote :

Confirmed still a problem on Hardy. If I compile 0.6.7 then everything is fine so the underlying cause is debian/ubuntu shipping a version of partimage from February 2004.

Changed in partimage:
status: New → Confirmed
Patrick T. (p1703) wrote :

Confirmed on Hardy + Intrepid Alpha6 on AMD Athon64 X2. Partimage version 0.6.7 is marked stable on http://www.partimage.org/Download - so why it is not upgraded in the repositories? please, MOTU upgrade it!

Alessio Treglia (quadrispro) wrote :

This should be fixed in the package currently available in jaunty.

Changed in partimage (Ubuntu):
status: Confirmed → Fix Released
Tuomas Jormola (tjormola) wrote :

This bug is not solved since still there is no amd64 binary even in karmic. See bug https://bugs.launchpad.net/ubuntu/+source/partimage/+bug/198724

Changed in partimage (Ubuntu):
status: Fix Released → New
Kees Cook (kees) on 2009-09-16
description: updated

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported should be reproducible with the live environment of the Desktop CD development release - Maverick Meerkat. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/. Thanks again and we appreciate your help.

Changed in partimage (Ubuntu):
status: New → Confirmed
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for partimage (Ubuntu) because there has been no activity for 60 days.]

Changed in partimage (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers