Parole reports "Gstreamer backend error, could not initialise supporting library"

Bug #1278089 reported by Migou on 2014-02-09
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
parole
Fix Released
High
parole (Ubuntu)
High
Sean Davis

Bug Description

same result with any file from http://samples.mplayerhq.hu/ I tried.

tested files :
ogg/md_ogg.ogm, avi/2-audio-streams.avi, ABRACADA.mid, [A-Destiny]_Konjiki_no_Gash_Bell_-_65_[71EE362C].mp4
Playing CD : same problem, Playing DVD : same problem.

details for md_ogg.ogm :

in command line$ parole md_ogg.ogm
=> Le folllowing message appears in command line :
Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started

----
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
----
$ apt-cache policy parole
parole:
  Installed: 0.6.0-0ubuntu1
  Candidate: 0.6.0-0ubuntu1
  Version table:
 *** 0.6.0-0ubuntu1 0
        500 http://fr.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
        100 /var/lib/dpkg/status

---
Other details

Before I tested Parole, I had some troubles updating ubuntu Trusty. I performed the following steps
1) 25/01/2014 : installing xubuntu
2) 09/02
  a) Software Updater > update => some package failed (download failed I think)
  b) sudo apt-get update; sudo apt-get upgrade => Success
  c) reboot
  d) Software updater > update => Success

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1278089

tags: added: package-qa-testing

Created attachment 5380
The error that i recieve

Hello XFCE community
Since i am trying xubuntu 14.04LTS for one week i recieve the error
Unable to start the support library.
GStreamer error and i can't see any video on it.

The only way i found to see videos is with VLC.
So i'm with a big doubts of the bug being from GStreamer or Parole.
But i decided that could be a good ideia to report this.

Keep up the good work.
Pedro Nunes

Greetings Pedro. Thanks for your bug report. Could you provide more information on your environment? Are you running Parole in a virtual machine? What kind of graphics card does your computer have? Are you using the proprietary or open source graphics drivers? Let me know if you need any help getting this data.

(In reply to Sean Davis from comment #1)
> Greetings Pedro. Thanks for your bug report. Could you provide more
> information on your environment? Are you running Parole in a virtual
> machine? What kind of graphics card does your computer have? Are you using
> the proprietary or open source graphics drivers? Let me know if you need any
> help getting this data.

Ye ofcourse
I have an Asus 1000H but with upgrade 2gb of ram.
I have a dual boot between W8.1 and xubuntu 14.04 LTS fully updated.
My GPU is a Intel GMA 945 i am running Open source drivers and i think its mesa 10.1.

I guess the problem is more with GStreamer than parole, that happened when i installed the codecs needed to play a H264/MP4 video, and then asked to install the codecs, i installed all of them, and no i just had that error.

I am almost sure that is GStreamer, but could be the parole 6.0 too, thats why i reported it :D

Thanks for the quick answer
Loving XFCE

Changed in parole:
importance: Unknown → High
status: Unknown → Incomplete

OK, nothing out of the ordinary. Could you possibly test if Totem (GNOME Videos) works for you. That will help us identify if it is an issue with GStreamer or Parole.

Changed in parole (Ubuntu):
assignee: nobody → Sean Davis (smd-seandavis)

This is potentially a duplicate of bug #1155151, as running "parole --xv false" fixes this bug as well.

Changed in parole (Ubuntu):
status: New → Confirmed

For me, Totem can play this video.

Furthermore, running "parole --xv false" and then opening the file in Parole again plays the video correctly.

Funny i installed totem now.
And now i can play videos on parole and totem.

I uninstall totem and videos on parole still working.
After i performed an sudo apt-get autoclean and autoremove, PAROLE STARTED To get ERROR again

I think parole is not gettint the codec dependences right. :(

PS: And this is how I confirmed this issue for myself so far: For desktop-files that specify only an extension, but not the full path (e.g. skype specifies skype.png) you can simply add the file extension another time to confirm this issue, e.g. renaming it to "skype.png.png" (and updating the icon-cache) results in the icon being found by gtk_image_new_from_icon_name.

(In reply to Simon Steinbeiss from comment #6)
> PS: And this is how I confirmed this issue for myself so far: For
> desktop-files that specify only an extension, but not the full path (e.g.
> skype specifies skype.png) you can simply add the file extension another
> time to confirm this issue, e.g. renaming it to "skype.png.png" (and
> updating the icon-cache) results in the icon being found by
> gtk_image_new_from_icon_name.

Haha great, wrong tab. Note to self: don't open too many bugreports at once!

Pasi Lallinaho (knome) on 2014-03-29
Changed in parole (Ubuntu):
importance: Undecided → High

http://gstreamer.freedesktop.org/documentation/plugins.html

According to this list, gstreamer1.0-plugins-base is needed to play .ogm video files. However, parole does not depend on this package, so it is not installed automatically (totem also installs gstreamer1.0-plugins-good by default).

Paul Tobias (tobias.pal) wrote :

I can confirm that installing the gstreamer1.0-plugins-base package fixes this bug for me, no other package is needed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parole - 0.6.1-0ubuntu3

---------------
parole (0.6.1-0ubuntu3) trusty; urgency=medium

  * Add recommends on gstreamer1.0-plugins-base. LP: #1278089
 -- Jackson Doak <email address hidden> Fri, 11 Apr 2014 08:03:22 +1000

Changed in parole (Ubuntu):
status: Confirmed → Fix Released

Hi,

I'm new here and I had a similar error on Archlinux+XFCE. The problem was because gst-plugins-base was marked as an optional dependancy while without it Parole always showed a GStreamer backend error. Don't know whether it is relevent for Xubuntu.

Pasi Lallinaho (knome) on 2014-04-16
summary: - parole reports "Gstreamer backend error, could not initialise supporting
- library" in trusty
+ Parole reports "Gstreamer backend error, could not initialise supporting
+ library"

(In reply to Frisbee Whisperwind from comment #8)
> Hi,
>
> I'm new here and I had a similar error on Archlinux+XFCE. The problem was
> because gst-plugins-base was marked as an optional dependancy while without
> it Parole always showed a GStreamer backend error. Don't know whether it is
> relevent for Xubuntu.

Yup, this issue has in fact been solved in Xubuntu 14.04 meanwhile (by making gst-plugins-base a recommend).

Changed in parole:
status: Incomplete → Fix Released

Hi,

It seems worth noting that this same error will come up in Parole on a 'vanilla' install of Xubuntu 14.04 LTS (fresh from GA and updated on 2014.04.29).

There doesn't actually seem to be a package available called 'gst-plugins-base' as recommended in the previous comment. Packages named gstreamer1.0-plugins-base and gstreamer0.10-plugins-base do exist. (Note I am not using 'multiverse'; perhaps the referenced package is in there).

I eventually tracked down the problem to the package 'gstreamer1.0-pulseaudio' not being installed.

After installing that, the error is no longer displayed when trying to play an audio file (mp3 via fluendo) in Parole.

Definitely not a Parole bug, but I figure someone else may end up here looking for a solution so it was worth addding a comment.

Ronald Duncan (ronaldduncan) wrote :

I upgraded to 14.04 LTS, and was switched back to Parole which does not work. I had previously uninstalled it and switched to VLC which pretty well always works with anything.

I have tried the following so far to get rid of this error:

parole --xv false
no affect (not this bug there is a decent message that indicates this as a fix)
sudo apt-get install xubuntu-restricted-extras
no affect
sudo apt-get install gstreamer1.0-plugins-base
already installed no affect
sudo apt-get install gstreamer1.0-pulseaudio
not installed still no affect I am trying to play a .mp4

Trying installing totem
The following extra packages will be installed:
  gir1.2-peas-1.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 libgmime-2.6-0
  libpeas-1.0-0 libpeas-common libtotem-plparser18 libtotem0
  libzeitgeist-2.0-0 python-zeitgeist totem-common totem-plugins zeitgeist
  zeitgeist-core zeitgeist-datahub
Suggested packages:
  totem-mozilla gromit
The following NEW packages will be installed
  gir1.2-peas-1.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 libgmime-2.6-0
  libpeas-1.0-0 libpeas-common libtotem-plparser18 libtotem0
  libzeitgeist-2.0-0 python-zeitgeist totem totem-common totem-plugins
  zeitgeist zeitgeist-core zeitgeist-datahub

Parole still does not work
Plays on totem

Tried closing and reopening Parole, so one of the above steps fixed it.

removed totem
The following packages were automatically installed and are no longer required:
  gir1.2-peas-1.0 gir1.2-totem-1.0 gir1.2-totem-plparser-1.0 libgmime-2.6-0
  libpeas-1.0-0 libpeas-common libtotem-plparser18 libtotem0
  libzeitgeist-2.0-0 python-zeitgeist totem-common zeitgeist zeitgeist-core
  zeitgeist-datahub

parole still works
sudo apt-get remove gstreamer1.0-pulseaudio
parole still works - but no sound

put back gstreamer1.0-pulseaudio

sudo apt-get remove gstreamer1.0-plugins-base
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED
  gnome-control-center gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad
  gstreamer1.0-plugins-bad-videoparsers gstreamer1.0-plugins-base
  gstreamer1.0-plugins-good libcheese-gtk23 libcheese7

Got a different error
GStreamer Error
Unable to load "playbin" plugin, check your GStreamer installation.
Parole Media Player cannot start.

Put gstreamer1.0-plugins-base back
Got unable to load "autoaudiosink"

 sudo apt-get install gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad

repeat of error Got unable to load "autoaudiosink"

installed gstreamer1.0-plugins-good libcheese-gtk23 libcheese7
WORKING - again

Not able to recreate the "Gstreamer backend error, could not initialise supporting library"

(A really vague horrible error message - sums up Parole for me no idea why it is the default)

The patch for that is already in the sponsors queue, we're waiting for it to be uploaded and SRU'd to 14.04 (add gstreamer1.0-pulseaudio to recommends).

I also encountered this in fresh Trusty install. The bug here isn't (just) missing dependency. There are always going to be codecs that aren't (can't be legally) supported out of the box.

The bug is crappy reporting of the issue in Parole. Showing on what source code line issue is noticed instead of reporting what the issue actually is and what user can do to fix it: i.e. "Support for codec XYZ hasn't been installed (install package ABC to have it)".

Gstreamer has support for finding that out and it's done by other media players (e.g. in gstreamer based players already in Maemo devices from previous decade).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.