Can't login in Windows live acount using empathy

Bug #887349 reported by Anderson on 2011-11-07
516
This bug affects 129 people
Affects Status Importance Assigned to Milestone
papyon
Unknown
Unknown
papyon (Ubuntu)
Undecided
Jean-Louis Dupond
Natty
Undecided
Unassigned
Oneiric
High
Unassigned
Precise
Undecided
Jean-Louis Dupond

Bug Description

I can not sign in my windows live acount, i think it's papyon related.
Below is my atachment with the log file
Thanks in advance.
The same error happens using emesene 2.11.9.
Anderson.

Anderson (andersonkoerich-live) wrote :
Phil. V (philip.v) wrote :

Thanks for your bug report. This is similar to bug 887380 and its many duplicates, but I wont mark this as a duplicate as it has a different package. I'll leave the packaging decision up to someone more familiar with the matter.

Changed in papyon (Ubuntu):
status: New → Confirmed
tags: added: metabug
Jean-Louis Dupond (dupondje) wrote :

You can find a fixed package on my ppa:
https://launchpad.net/~dupondje/+archive/ppa/+packages

Attached the debdiff to fix it.

Changed in papyon (Ubuntu Oneiric):
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package papyon - 0.5.5-1ubuntu4

---------------
papyon (0.5.5-1ubuntu4) precise; urgency=low

  * Fix login failure due to trying to interact to an obsolete
    server (LP: #887349).
 -- Jean-Louis Dupond <email address hidden> Tue, 08 Nov 2011 13:58:21 +0100

Changed in papyon (Ubuntu):
status: Confirmed → Fix Released
Ken VanDine (ken-vandine) wrote :

To verify the fix, simply attempt to signin to MSN with empathy. Without the fix, signin will fail.

Emerson Joucoski (joucoski) wrote :

How to install the fixed package?

Forest Bond (forest-bond) wrote :

We need SRUs for this fix if someone has time to go through the SRU process.

Jean-Louis Dupond (dupondje) wrote :
martincasc (martincasco) wrote :

I've tried to install Jean-Louis Dupond package built 2 hours ago but my package manager said that I have a newer version installed :S

Jean-Louis Dupond (dupondje) wrote :

You can just do 'wget https://launchpad.net/~dupondje/+archive/ppa/+files/python-papyon_0.5.5-1ubuntu3%7Edupondje_all.deb'.
And then dpkg -i python-papyon_0.5.5-1ubuntu3%7Edupondje_all.deb

This is only for oneiric.
Precise is fixed, Oneiric can be fixed with above & patch is uploaded in proposed.

Lucid is getting fixed in some minutes also.

Changed in papyon (Ubuntu Lucid):
status: New → Confirmed
importance: Undecided → High
Jean-Louis Dupond (dupondje) wrote :
Jean-Louis Dupond (dupondje) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in papyon (Ubuntu Maverick):
status: New → Confirmed
Changed in papyon (Ubuntu Natty):
status: New → Confirmed
1 comments hidden view all 114 comments
Larika (matteo-tanca) wrote :

the fix doesn't help me : i'm on an updated 11.10. I think my situation is different becouse im using a @gmail Windows Live Account. I tested it with a @live.it and it work. Still cant understand why i cant connect with a @gmail.com account!

Valter Vicente (vallovic) wrote :

@Larika: I'm using a @gmail.com account and, with the fix provided (patched by hand on my system), I can connect to my Windows Live account. So, I think that's not the problem.

Larika (matteo-tanca) wrote :

@Valter : Very strange, after your comment i setup a fresh ubuntu 11.10 install in another machine, updated and patch installed. My @gmail.com account wont work(i know is a good and valid account because in windows it works). Only @hotmail or @live accounts work for me, but only if i apply the patch.

Problem solved with patch, thanks.

martincasc (martincasco) wrote :

Problem Solved on Oneiric! Thanks.

Dario Egea (egea-dario) wrote :

Hi, how to install lucid patch? I have installed python-papyon 0.4.8-0ubuntu2.
Regards.

Léo Studer (leo-studer) wrote :

I installed the new papyon and killed all telepathy related process before relaunching empathy, but still my msn account won't get connected…

Please note that this patch won't work for all users. This needs to be fixed supporting WLM redirect server. AFAIK papyon upstream is working on this.

Jonas Pedersen (jonasped) wrote :

Agree with Devid. Just tried to install Jean-Louis' package and that does not the solve the issue for me. Apparently further changes need to be made as well.

Jean-Louis Dupond (dupondje) wrote :

For people that don't get it working yet on Oneiric. Is it possible to try the following .deb:
http://ubuntu.dupondje.be/python-papyon_0.5.5-1ubuntu3.2_all.deb

Tell me if it fixes the issues for you now.

Hi,

python-papyon 0.5.5-1ubuntu3 doesn't work either,

Marcel

On Tue, Nov 8, 2011 at 10:05 PM, Jonas Pedersen
<email address hidden>wrote:

> Agree with Devid. Just tried to install Jean-Louis' package and that
> does not the solve the issue for me. Apparently further changes need to
> be made as well.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (887568).
> https://bugs.launchpad.net/bugs/887349
>
> Title:
> Can't login in Windows live acount using empathy
>
> Status in papyon:
> Unknown
> Status in “papyon” package in Ubuntu:
> Fix Released
> Status in “papyon” source package in Lucid:
> Confirmed
> Status in “papyon” source package in Maverick:
> Confirmed
> Status in “papyon” source package in Natty:
> Confirmed
> Status in “papyon” source package in Oneiric:
> Confirmed
>
> Bug description:
> I can not sign in my windows live acount, i think it's papyon related.
> Below is my atachment with the log file
> Thanks in advance.
> The same error happens using emesene 2.11.9.
> Anderson.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/papyon/+bug/887349/+subscriptions
>

But,

python-papyon 0.5.5-1ubuntu3.2

Fixed it for me!

Marcel

On Tue, Nov 8, 2011 at 10:32 PM, Jean-Louis Dupond <email address hidden>wrote:

> For people that don't get it working yet on Oneiric. Is it possible to try
> the following .deb:
> http://ubuntu.dupondje.be/python-papyon_0.5.5-1ubuntu3.2_all.deb
>
> Tell me if it fixes the issues for you now.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (887568).
> https://bugs.launchpad.net/bugs/887349
>
> Title:
> Can't login in Windows live acount using empathy
>
> Status in papyon:
> Unknown
> Status in “papyon” package in Ubuntu:
> Fix Released
> Status in “papyon” source package in Lucid:
> Confirmed
> Status in “papyon” source package in Maverick:
> Confirmed
> Status in “papyon” source package in Natty:
> Confirmed
> Status in “papyon” source package in Oneiric:
> Confirmed
>
> Bug description:
> I can not sign in my windows live acount, i think it's papyon related.
> Below is my atachment with the log file
> Thanks in advance.
> The same error happens using emesene 2.11.9.
> Anderson.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/papyon/+bug/887349/+subscriptions
>

Jean-Louis Dupond (dupondje) wrote :

eijkvanmarcel:
0.5.5-1ubuntu3 is not patched, so its normal it doesn't work.
0.5.5-1ubuntu3.1 should work
0.5.5-1ubuntu3.2 is for people where 0.5.5-1ubuntu3.1 doesn't work.

We just need to know if 0.5.5-1ubuntu3.1 is working for everybody.

Jean-Louis Dupond (dupondje) wrote :

d.filoni: 0.5.5-1ubuntu3.2 is with that patch.

Larika (matteo-tanca) wrote :

python-papyon 0.5.5-1ubuntu3.2

Fixed it for me! Thank you guys!!!

Bruno Bigras (brunoqc) wrote :

@Jean-Louis Dupond : I can't find 0.5.5-1ubuntu3.1 is it on your PPA or in proposed?

Bruno Bigras (brunoqc) wrote :

Updating to 0.5.5-1ubuntu3~dupondje got rid of the bug on my side.

Steve G. (sgo.ger) wrote :

Neither solution works for me. :(

Michael Leow (jweng-leow) wrote :

Just to note; upstream's fix as pointed (at http://cgit.collabora.com/git/user/maiku/papyon.git/commit/?h=bug-42689&id=011201e47004538e732f247bfeb21634c6e1d97f) by Bug #887512 is incomplete.

The correct behavior would be to correctly handle the 301 redirect and maybe cache the location somewhere. For example; in my 301 redirect; it points to local-sn.contacts.msn.com (Singapore) instead of local-bay.contacts.msn.com (US, California).

tbys (tbys) wrote :

Trying the .deb, but how do I restart empathy (this has always confused me)?

tbys (tbys) wrote :

Sorry, it seems Empathy has a quit option that works fine now, ignore my question.

tbys (tbys) wrote :

Doesn't connect to MSN here, even with the .deb file installed.

Léo Studer (leo-studer) wrote :

Neither 0.5.5-1ubuntu3.1 or 0.5.5-1ubuntu3.2 work for me, still msn won't connect !

Latest deb doesn't work for me.

Apologies, immediately after posting that, it decided to work. Thanks :)

Martin Pitt (pitti) on 2011-11-10
Changed in papyon (Ubuntu Oneiric):
status: Confirmed → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) on 2011-11-10
Changed in papyon (Ubuntu Natty):
status: Confirmed → Fix Committed
Changed in papyon (Ubuntu Lucid):
status: Confirmed → Fix Committed
Sven Baars (sbte) on 2011-11-10
Changed in papyon (Ubuntu):
status: Fix Released → Confirmed
Changed in papyon (Ubuntu Lucid):
status: Fix Committed → Fix Released
Changed in papyon (Ubuntu Maverick):
status: Confirmed → Fix Released
Changed in papyon (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in papyon (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Martin Pitt (pitti) on 2011-11-14
Changed in papyon (Ubuntu Lucid):
status: Fix Released → Confirmed
Changed in papyon (Ubuntu Maverick):
status: Fix Released → Confirmed
Changed in papyon (Ubuntu Natty):
status: Fix Released → Confirmed
Changed in papyon (Ubuntu Oneiric):
status: Fix Released → Confirmed
34 comments hidden view all 114 comments
Martin Pitt (pitti) wrote :

All uploaded, unsub'ing sponsors. Precise is also affected, please provide a fix there as well. Thanks muchly!

Hello Anderson, or anyone else affected,

Accepted papyon into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in papyon (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in papyon (Ubuntu Lucid):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Hello Anderson, or anyone else affected,

Accepted papyon into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in papyon (Ubuntu Maverick):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Hello Anderson, or anyone else affected,

Accepted papyon into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in papyon (Ubuntu Natty):
status: Confirmed → Fix Committed
Martin Pitt (pitti) wrote :

Hello Anderson, or anyone else affected,

Accepted papyon into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Martin Pitt (pitti) wrote :

lucid/maverick failed to build, the patches don't apply.

Changed in papyon (Ubuntu Lucid):
status: Fix Committed → Triaged
Changed in papyon (Ubuntu Maverick):
status: Fix Committed → Triaged
Changed in papyon (Ubuntu Precise):
assignee: nobody → Jean-Louis Dupond (dupondje)
Jean-Louis Dupond (dupondje) wrote :

Ok I modified the patches so they work fine on older versions like in lucid & maverick.

For Lucid:
Could somebody try the following deb on lucid:
http://ubuntu.dupondje.be/python-papyon_0.4.8-0ubuntu2.3_all.deb

For Maverick:
http://ubuntu.dupondje.be/python-papyon_0.5.1-0ubuntu2.3_all.deb

Could you confirm if its working correctly. (It should, but I want to know first :))

Dario Egea (egea-dario) wrote :

Jean-Louis, in my Lucid AMD64, the patch isn't working.

Brandon Mayes (bdmayes) wrote :

I had resolved this problem in 11.10 a few days ago by manually updating the url in /usr/share/pyshared/papyon/service/description/AB/__init__.py from this:

url = "http://contacts.msn.com/abservice/abservice.asmx"

to this:

url = "http://local-sn.contacts.msn.com/abservice/abservice.asmx"

Many others on ubuntuforums.org suggested that the local-bay address worked for them:

url = "http://local-bay.contacts.msn.com/abservice/abservice.asmx"

However I tried this URL and was still unable to connect. Now that I am using the local-sn address everything is working fine. After I updated this morning (in update-manager) I found that I was unable to connect again and the URL in this file was changed back to the local-bay address. I can only assume the update changed the URL, but unfortunately it still does not work for me. As soon as I changed it to the local-sn address and restarted empathy my contacts loaded right up.

Is the URL somehow different by geography? I am in the USA and the local-bay address failed for both me and another individual in Canada. It seems to work fine for others throughout the world however. But I don't think this is quite solved yet since applying the update today actually broke empathy for me (only after I had manually fixed it, of course).

Jean-Louis Dupond (dupondje) wrote :

@bdmayes:

This is also what got fixed in the newest version that got uploaded.

Forest Bond (forest-bond) wrote :

@dupondje:

The Lucid package is broken:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/papyon/gnet/protocol/HTTP.py", line 131, in _on_response_received
    self.close()
  File "/usr/lib/pymodules/python2.6/papyon/gnet/protocol/HTTP.py", line 186, in close
    self._clean_transport()
  File "/usr/lib/pymodules/python2.6/papyon/gnet/protocol/HTTP.py", line 105, in _clean_transport
    self._http_parser.disable()
AttributeError: 'HTTPParser' object has no attribute 'disable'

Jean-Louis Dupond (dupondje) wrote :

@forest-bond:

New fixed uploaded on http://ubuntu.dupondje.be/python-papyon_0.4.8-0ubuntu2.3_all.deb
Could you test if its working fine?

Thanks!

Forest Bond (forest-bond) wrote :

@dupondje

Yes, that seems to fix things.

Dario Egea (egea-dario) wrote :

I confirm, it's working now in:
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 10.04.3 LTS
Release: 10.04
Codename: lucid

THANKS!

I have python-papyon-0.5.5-1ubuntu3.1 and am affected by this bug (oneiric). Have not tried the 3.2 package yet.

dr.spock (dr.spock) wrote :

Still not working in Natty AMD64, with natty-proposed enabled and up to date (installed python-papyon version: 0.5.5-1ubuntu1.3).

I can log in with one of my accounts but not with the other (both working in pidgin for windows).

Thank you very much for your help. Your first solution didn't work for
me, but this one works perfectly. Thanks a lot.
Javier

El lun, 14-11-2011 a las 16:47 +0000, Brandon Mayes escribió:

> "http://local-bay.contacts.msn.com/abservice/abservice.asmx

An Yang (euroford) wrote :

I'm in China, http://local-bay.contacts.msn.com/ won't work for me.
I'm using https://local-sn.contacts.msn.com/ , it works fine.
And upstream 0.5.6, it use https://omega.contacts.msn.com/ , it also works for me.

Please fix it ASAP.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package papyon - 0.5.5-1ubuntu5

---------------
papyon (0.5.5-1ubuntu5) precise; urgency=low

  * Allow HTTP redirection and use correct AB server. (LP: #887349)
 -- Jean-Louis Dupond <email address hidden> Thu, 10 Nov 2011 18:14:18 +0100

Changed in papyon (Ubuntu Precise):
status: Confirmed → Fix Released
dr.spock (dr.spock) wrote :

Working at last for both accounts, after getting new update for Natty (0.5.5-1ubuntu4).

Thank you very much =)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package papyon - 0.5.5-1ubuntu1.4

---------------
papyon (0.5.5-1ubuntu1.4) natty-proposed; urgency=low

  * Allow HTTP redirection and use correct AB server. (LP: #887349)
 -- Jean-Louis Dupond <email address hidden> Thu, 10 Nov 2011 18:11:53 +0100

Changed in papyon (Ubuntu Natty):
status: Fix Committed → Fix Released
Lino Barreca (linobarreca) wrote :
Download full text (7.4 KiB)

in python-papyon 0.5.5-1ubuntu3.1 there's still the problem.

Content-Length: 1898

Proxy-Connection: Keep-Alive

SOAPAction: http://www.msn.com/webservices/AddressBook/FindMembership

Host: local-bay.contacts.msn.com:80

Accept: text/*

User-Agent: gnet/0.1 (Linux x86_64)

Connection: Keep-Alive

Cache-Control: no-cache

Content-Type: text/xml; charset=utf-8

Accept-Encoding: gzip

<?xml version='1.0' encoding='utf-8'?><soap:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><ABApplicationHeader xmlns="http://www.msn.com/webservices/AddressBook"><ApplicationId xmlns="http://www.msn.com/webservices/AddressBook">CFE80F9D-180F-4399-82AB-413F33A1FA11</ApplicationId><IsMigration xmlns="http://www.msn.com/webservices/AddressBook">false</IsMigration><PartnerScenario xmlns="http://www.msn.com/webservices/AddressBook">Initial</PartnerScenario></ABApplicationHeader><ABAuthHeader xmlns="http://www.msn.com/webservices/AddressBook"><ManagedGroupRequest xmlns="http://www.msn.com/webservices/AddressBook">false</ManagedGroupRequest><TicketToken xmlns="http://www.msn.com/webservices/AddressBook">t=EwDoAcBdAAAURnMnP0xNtZi9ugdf902M4Br/7wKAAKAPlQbV+DjSVmBie1t+AmFvSUV2nD6fkhwq66fJ6nBWTqXToAiQQXelpJn+ujr+wiS78+CqNrDHdJrh/8S1oPigNLm0THvifjOaF8xSMeJ/yW2g2hjPXRyx4QK3jNlbbSfkLcPjtJWH7ZDcPdOQ2A1TTIFVyDhEoealKmn/olkzA2YAAAhhnfmAbTPi3DgBv2FTvnSENTx9J3b+k41Lbvf3ns5WDZXbwvAlMjxuwByrEnx98vt/zSQNSaJXi2ExH37P6Awtfi4FINiTKKKiSAZbasOdbE7dgmcJHX/fazWMSIIUw8VBJFY53aA76hrmpaZgKJQH/kzNGc4t35NB1JImhSHAzUpQvq655rqvZjP6tBJHxrg/JKuTKPw2Du+KBDnx9aS8BETJQ71hpvMG41fPyrt5igB/IyhWCz9kphpKJ4FlZLe2iR3PnHLzDQQ8Vv3IZghI6sa4QqgVLTgRY40AYI42OPPCPUK9KvWEVFMb5wH0CDO61rqUxWNAwSGV/qBv84ST6KmN5ktmaZ8eTvNIhOPmYz7Yo7u6p2RREwLMlX687CEPnSZiTg+2yP4ZuiWyruxTblMc4SMCB3H0inK8v0hF4gf+ZwE=&amp;p=</TicketToken></ABAuthHeader></soap:Header><soap:Body><FindMembership xmlns="http://www.msn.com/webservices/AddressBook"><serviceFilter xmlns="http://www.msn.com/webservices/AddressBook"><Types xmlns="http://www.msn.com/webservices/AddressBook"><ServiceType xmlns="http://www.msn.com/webservices/AddressBook">Messenger</ServiceType></Types></serviceFilter></FindMembership></soap:Body></soap:Envelope>
papyon/papyon.service-DEBUG: 15/11/2011 20:51:07.335810: <<< Received response for ABFindAll
papyon/papyon.service-DEBUG: 15/11/2011 20:51:07.336230: <<<<?xml version="1.0" encoding="utf-8"?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><soap:Header><ServiceHeader xmlns="http://www.msn.com/webservices/AddressBook"><Version>16.02.2225.0001</Version><CacheKey>14r2;QMkRKrQMrwIyP3n+5L8oj2neB+xmgsV3FSJ7kQTm/LMZj7Brw82zHDoIgTZ7V6exfeSWa2rPi2j/MS7lJ/4a8MkOxqDUwUWAEKAFKcFcOInkn7LTvN/f9mqkw3f3bMKi9RKeDwS5L88AHdrVDh5kjIHatyjOqfbR6zdRsCthGdg=</CacheKey><CacheKeyChanged>true</CacheKeyChanged><PreferredHostName>proxy-sn.contacts.msn.com</PreferredHostName><SessionId>ABCH.603133d7-b724-4a30-818d-07e45cb893e2</SessionId></ServiceHeader></soap:Header><soap:Body><ABFindAllResponse xmlns="http://...

Read more...

Simone (tigerjack89) wrote :

It works, but I can't view msn list when starts empathy. All the contacts are under "ungrouped".

Simone (tigerjack89) wrote :

How can I install the latest patch on Ubuntu 11.10 64 bit? I don't know which version I have and when I search for updates terminal give me a "404 error" for the " https://launchpadlibrarian.net/84701822/papyon.debdiff "; so I just turn off updates from this ppa.

Mark Schneider (mc-monti) wrote :

I tried to apply the patch, but I don't know if I did it right. I copied it into /usr/share/pyshared and entered
patch -p1 <lucid2.debdiff

I got the following error messages:

patching file debian/changelog
Hunk #1 FAILED at 1.
1 out of 1 hunk FAILED -- saving rejects to file debian/changelog.rej
patching file debian/patches/11_lp_887349.patch
Hunk #1 FAILED at 1.
Hunk #2 FAILED at 28.
Hunk #3 FAILED at 44.
3 out of 3 hunks FAILED -- saving rejects to file debian/patches/11_lp_887349.patch.rej

So it is still not working. Can somebody help me?

Bye
Mark

Jean-Louis Dupond (dupondje) wrote :

mail-mark-schneider:
You can just wget http://ubuntu.dupondje.be/python-papyon_0.4.8-0ubuntu2.3_all.deb
Then dpkg -i python-papyon_0.4.8-0ubuntu2.3_all.deb

This will install the fixed package.
Would it be possible to test that?

Mark Schneider (mc-monti) wrote :

Jean-Lous:

Thank you, that works fine. I wonder, why the other patch did not work.

I need to fix two computers, so I will test it once more again.

Empathy works five but emesene is still stuck at "Set contact flags at 1"

Mark Schneider (mc-monti) wrote :

Ok, it works fine on both computers. I still wonder, what I did wrong with the other patch.
Well anyway. Thank you so much for your help!

Jean-Louis Dupond (dupondje) wrote :

Ok,

Attached the debdiff for Maverick with the newest patches.
This builds fine (tested with pbuilder).

Jean-Louis Dupond (dupondje) wrote :
Pedro Villavicencio (pedro) wrote :

Been using python-papyon 0.5.5-1ubuntu3.2 on Oneiric and it works fine , I'm able to login to MSN again, marking this as verification-done so it can go into updates. Please note that this is only for the Oneiric task. Thanks.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package papyon - 0.5.5-1ubuntu3.2

---------------
papyon (0.5.5-1ubuntu3.2) oneiric-proposed; urgency=low

  * Allow HTTP redirection and use correct AB server. (LP: #887349)
 -- Jean-Louis Dupond <email address hidden> Thu, 10 Nov 2011 18:14:18 +0100

Changed in papyon (Ubuntu Oneiric):
status: Fix Committed → Fix Released

Hello Anderson, or anyone else affected,

Accepted papyon into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in papyon (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Changed in papyon (Ubuntu Maverick):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Hello Anderson, or anyone else affected,

Accepted papyon into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Øyvind Stegard (oyvinst) wrote :

I can no longer log in after updating to python-papyon 0.4.8-0ubuntu2.3 (started hanging again). Ubuntu Lucid, connecting from Norway.

Øyvind Stegard (oyvinst) wrote :

It did work fine for a couple of versions, though I cannot say for sure if problem re-appeared after 0.4.8-0ubuntu2.2 or after 0.4.8-0ubuntu2.3.

Martin Pitt (pitti) on 2011-11-25
tags: added: verification-failed
removed: verification-needed
Øyvind Stegard (oyvinst) wrote :

Switching server from omega to local-bay makes it work again, and I can log in..

$ pwd
/usr/share/pyshared/papyon/service
$ grep -r local-bay .
./description/AB/__init__.py:url = "https://local-bay.contacts.msn.com/abservice/abservice.asmx"
./description/Sharing/__init__.py:url = "https://local-bay.contacts.msn.com/abservice/SharingService.asmx"

(python-papyon 0.4.8-0ubuntu2.3)

Filipo Rviz (filipo747) wrote :

Hi!

Empathy works whit MSN account for me after upgrading python-papyon 0.5.5-1ubuntu3.1
(Automatic upgrade at 22-nov-2011)

The modification of the file
./description/AB/__init__.py:url = "https://local-bay.contacts.msn.com/abservice/abservice.asmx"
doesn't work, I'm in Colombia, I don't know if it affects.

(Ubuntu 11.10)

kirkhelek (zergun-wizzard-17) wrote :

Till today, I had that problem... I solved it removing telepathy-butterfly packet and reinstalling my python paquet ( 2.6.5 ).

My __init__.py was ok.

Hope it helps.

Adolfo Jayme (fitojb) on 2013-06-22
Changed in papyon (Ubuntu Maverick):
status: Fix Committed → Won't Fix
Adolfo Jayme (fitojb) on 2014-10-18
no longer affects: papyon (Ubuntu Lucid)
no longer affects: papyon (Ubuntu Maverick)
Displaying first 40 and last 40 comments. View all 114 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.