Word order error in RTL language

Bug #953801 reported by Gheyret T.Kenji on 2012-03-13
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Medium
Unassigned
unity-2d
Undecided
Unassigned
pango1.0 (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Dear maintainer and developer:

I am from Ubuntu Uyghur Translation group.
When displaying strings which starts with English words, the position of the English word in not correct.
please look at attached sreenshot.
Translation of the "Ubuntu Software Center" in Uyghur is not correctly displayed on right top corner. On the other two places is displayed correctly.

This problem occured in Ubuntu, when translation starts whith English words(in Uyghur language).

This is very seriues problem.
Please fix this bug.

Tags: rtl Edit Tag help
Gheyret T.Kenji (gheyretkenji) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/953801/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Gheyret T.Kenji (gheyretkenji) wrote :

this is another screent shot.
In the sceenshot:
Uyghurix is my computers name. gheyret is my account name.
Uyghur is RTL language, so the Uyghurix must be first word in the string.

C de-Avillez (hggdh2) wrote :

adding Ubuntu Translations to the mix.

affects: ubuntu → ubuntu-translations
Changed in ubuntu-translations:
status: New → Confirmed
David Planella (dpm) on 2012-03-23
tags: added: rtl
removed: bot-comment
Changed in ubuntu-translations:
status: Confirmed → Triaged
importance: Undecided → Medium
David Planella (dpm) wrote :

Maybe a libdbusmenu issue?

Albert Astals Cid (aacid) wrote :

Changing the issue to fix released since in Unity 5.10 (current precise) i see all three texts to be the same, attaching a screenshot in a second. If you still have this issue after upgrading to precise please reopen it.

Albert Astals Cid (aacid) wrote :
Changed in unity-2d:
status: New → Fix Released
Gheyret T.Kenji (gheyretkenji) wrote :

This bug still exist in Ubuntu 12.04 Beta.
I think this bug related to a library, not a specific package.

When translation starts with non Uyghur words, Menu Text is not displayed correctly.
Please look the attachments.

Gheyret T.Kenji (gheyretkenji) wrote :
Gheyret T.Kenji (gheyretkenji) wrote :
Albert Astals Cid (aacid) wrote :

Hi Gheyret, none of us here speak Uyghur, could you please highlight the non correct texts and explain what would be the correct ordering for them?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-2d (Ubuntu):
status: New → Confirmed

Hello Albert,

thank you for giving attention to this bug.

Sorry for the lack of the explanation.

This time i have attached the current order of the words (wireles_menu.png)
which is reported as bug,and the correct one which is highlighted.
(wireles_menu_right_one.png)

If you still having trouble to figure out please give a look at
wireles_menu_with_mark.png which is current order
that marked by number and the right order should be �,�,�

Hope this bug get fixed ASAP.

With best regards
Rustam.

> Date: Mon, 23 Apr 2012 09:35:44 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 953801] Re: Word order error in RTL language
>
> Hi Gheyret, none of us here speak Uyghur, could you please highlight the
> non correct texts and explain what would be the correct ordering for
> them?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/953801
>
> Title:
> Word order error in RTL language
>
> Status in Ubuntu Translations:
> Triaged
> Status in Unity 2D:
> Fix Released
> Status in “unity-2d” package in Ubuntu:
> New
>
> Bug description:
> Dear maintainer and developer:
>
> I am from Ubuntu Uyghur Translation group.
> When displaying strings which starts with English words, the position of the English word in not correct.
> please look at attached sreenshot.
> Translation of the "Ubuntu Software Center" in Uyghur is not correctly displayed on right top corner. On the other two places is displayed correctly.
>
> This problem occured in Ubuntu, when translation starts whith English
> words(in Uyghur language).
>
> This is very seriues problem.
> Please fix this bug.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/953801/+subscriptions

Rustam (rustam-hotmail) wrote :
Download full text (3.8 KiB)

Sorry for the previous email , seems like include incorrect character at the end of the message , I mean the order should be 1,2,3(right to left)

With regards
Rustam

> Date: Mon, 23 Apr 2012 15:53:58 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 953801] Re: Word order error in RTL language
>
> Hello Albert,
>
> thank you for giving attention to this bug.
>
> Sorry for the lack of the explanation.
>
> This time i have attached the current order of the words (wireles_menu.png)
> which is reported as bug,and the correct one which is highlighted.
> (wireles_menu_right_one.png)
>
> If you still having trouble to figure out please give a look at
> wireles_menu_with_mark.png which is current order
> that marked by number and the right order should be �,�,�
>
> Hope this bug get fixed ASAP.
>
> With best regards
> Rustam.
>
>
>
> > Date: Mon, 23 Apr 2012 09:35:44 +0000
> > From: <email address hidden>
> > To: <email address hidden>
> > Subject: [Bug 953801] Re: Word order error in RTL language
> >
> > Hi Gheyret, none of us here speak Uyghur, could you please highlight the
> > non correct texts and explain what would be the correct ordering for
> > them?
> >
> > --
> > You received this bug notification because you are subscribed to the bug
> > report.
> > https://bugs.launchpad.net/bugs/953801
> >
> > Title:
> > Word order error in RTL language
> >
> > Status in Ubuntu Translations:
> > Triaged
> > Status in Unity 2D:
> > Fix Released
> > Status in “unity-2d” package in Ubuntu:
> > New
> >
> > Bug description:
> > Dear maintainer and developer:
> >
> > I am from Ubuntu Uyghur Translation group.
> > When displaying strings which starts with English words, the position of the English word in not correct.
> > please look at attached sreenshot.
> > Translation of the "Ubuntu Software Center" in Uyghur is not correctly displayed on right top corner. On the other two places is displayed correctly.
> >
> > This problem occured in Ubuntu, when translation starts whith English
> > words(in Uyghur language).
> >
> > This is very seriues problem.
> > Please fix this bug.
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/ubuntu-translations/+bug/953801/+subscriptions
>
>
> ** Attachment added: "wireles_menu.png"
> https://bugs.launchpad.net/bugs/953801/+attachment/3100237/+files/wireles_menu.png
>
> ** Attachment added: "wireles_menu_right_one.png"
> https://bugs.launchpad.net/bugs/953801/+attachment/3100238/+files/wireles_menu_right_one.png
>
> ** Attachment added: "wireles_menu_with_mark.png"
> https://bugs.launchpad.net/bugs/953801/+attachment/3100239/+files/wireles_menu_with_mark.png
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/953801
>
> Title:
> Word order error in RTL language
>
> Status in Ubuntu Translations:
> Triaged
> Status in Unity 2D:
> Fix Released
> Status in “unity-2d” package in Ubuntu:
> Confirmed
>
> Bug description:
...

Read more...

Gheyret T.Kenji (gheyretkenji) wrote :

Hi Albert Astals Cid,
I uploaded the three screenshot again. I marked wrong ordered text.

Gheyret T.Kenji (gheyretkenji) wrote :
Gheyret T.Kenji (gheyretkenji) wrote :
Gheyret T.Kenji (gheyretkenji) wrote :
Gheyret T.Kenji (gheyretkenji) wrote :

Hi Albert Astals Cid,

The text file contains Uyghur translations of wrong ordered text.

In command line I am using pango-view converted the text file to png file.

For translation.png using command :

pango-view -q --rtl --font="UKIJ Tuz" translation.txt -o translation.png

the result is the same in above three screenshot. Text order is wrong.

and I am using

pango-view -q --rtl --no-auto-dir --font="UKIJ Tuz" translation.txt -o translation_no_auto.png

command, converted the text to translation_no_auto.png.
The result is correct. This is correct text order.

Gheyret T.Kenji (gheyretkenji) wrote :
Gheyret T.Kenji (gheyretkenji) wrote :
Albert Astals Cid (aacid) wrote :

Adding Pango to this bug then, since it seems a problem there and not in unity-2d as far as i see it

Gheyret T.Kenji (gheyretkenji) wrote :

I think, this is a library problem, which displaying MENU and LABEL using Pango.
I don`t now, which library is responsible displaying MENU and LABEL in UI.

Changed in unity-2d (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers