Comment 24 for bug 871083

aptitude is not the recommended interface for commandline-based upgrades; it's recommended that you use apt-get instead. And aptitude is known to not work right with multiarch packages (which is what libpam-modules:i386 is). I'm sorry, but it sounds like aptitude has made a real mess of your system.

You may be able to fix this by running 'sudo apt-get install ubuntu-desktop'. But if that doesn't solve it, I think you'll want to take this question to one of the support forums. (ubuntuforums.org, askubuntu.com, etc)