Ubuntu

padevchooser does not start, fails with message ** (padevchooser:12362): WARNING **: pa_browser_new() failed.

Reported by Mikael Olenfalk on 2007-04-19
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
padevchooser (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: padevchooser

mikael@devcon-x:~/Desktop$ padevchooser

** (padevchooser:12561): WARNING **: pa_browser_new() failed.

This is a fresh Feisty upgrade (was initially upgrade before release); pulseaudio works nice, however, the only gui tool working is paprefs, all other fail with similar messages as above

mikael@devcon-x:~/Desktop$ dpkg -l | grep PulseAudio
ii libao-pulse 0.9.3-1 libao PulseAudio driver
ii libgstreamer-plugins-pulse0.10-0 0.9.4-1ubuntu1 PulseAudio plugin for GStreamer
ii libpulse-browse0 0.9.5-5ubuntu4 PulseAudio client libraries
ii libpulse-dev 0.9.5-5ubuntu4 PulseAudio client development headers and li
ii libpulse-mainloop-glib0 0.9.5-5ubuntu4 PulseAudio client libraries
ii libpulse0 0.9.5-5ubuntu4 PulseAudio client libraries
ii padevchooser 0.9.3-1 PulseAudio Device Chooser
ii paman 0.9.3-1 PulseAudio Manager
ii paprefs 0.9.5-1 PulseAudio Preferences
ii pavucontrol 0.9.4-1 PulseAudio Volume Control
ii pavumeter 0.9.2-1 PulseAudio Volume Meter
ii pulseaudio 0.9.5-5ubuntu4 PulseAudio sound server
ii pulseaudio-esound-compat 0.9.5-5ubuntu4 PulseAudio sound server
ii pulseaudio-module-gconf 0.9.5-5ubuntu4 gconf module for PulseAudio sound server
ii pulseaudio-module-hal 0.9.5-5ubuntu4 HAL device detection module for PulseAudio s
ii pulseaudio-module-x11 0.9.5-5ubuntu4 X11 module for PulseAudio sound server
ii pulseaudio-module-zeroconf 0.9.5-5ubuntu4 Zeroconf module for PulseAudio sound server
ii pulseaudio-utils 0.9.5-5ubuntu4 Command line tools for the PulseAudio sound

I am sorry, as it turns out; both pavucontrol and pavumeter works; its just pabrowse and padevchooser which fail

Jason Smith (jassmith) wrote :

I am also experiencing this issue, so its not just you

FuzzyHeadDave (stoberd) wrote :

Just thought I would share what I found:
I was getting the same error. I found after some searching installing
the package 'avahi-daemon' fixes the problem, but I don't see why.
Other posts list the D-Bus session daemon is not started properly -
maybe this starts the daemon correctly.

Luca Falavigna (dktrkranz) wrote :

Fixed in Debian with version 0.9.3-2.

Changed in padevchooser:
assignee: nobody → dktrkranz
status: New → Fix Committed
Luca Falavigna (dktrkranz) wrote :

Version 0.9.3-2 is now in Gutsy.

Changed in padevchooser:
assignee: dktrkranz → nobody
status: Fix Committed → Fix Released
Pablo Di Noto (pablo-dinoto) wrote :

Hello,

padevchooser is refusing to start because it relies on Avahi to provide some network services discovery.

The reason Avahi is not working is explained here:
https://bugs.launchpad.net/ubuntu/+source/avahi/+bug/327362

But the short answer is:

# vi /etc/default/avahi-daemon

make sure the line that reads
AVAHI_DAEMON_DETECT_LOCAL=1
becomes
AVAHI_DAEMON_DETECT_LOCAL=0

This change avoids a check done at boot which prevents Avahi from running. For immediate pleasure, do
# /etc/init.d/avahi-daemon start

which should start the service without any error. Once Avahi is working, PulseAudio will work as expected.
This last statement is no longer necessary, as the Avahi will now start on each reboot.

Thanks everybody for your work!
///Pablo

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers