Installed Software Partly Displayed

Bug #691474 reported by Alain ANDERLINI on 2010-12-17
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
packagekit (Ubuntu)
Undecided
Unassigned
Maverick
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: kpackagekit

Kubuntu 10.10, KDE 4.5.4

kpackagekit:
  Installed: 0.6.2-0ubuntu1
  Candidate: 0.6.2-0ubuntu1
  Version table:
 *** 0.6.2-0ubuntu1 0
        500 http://be.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages
        100 /var/lib/dpkg/status

KPackageKit displays installed software in alphabetical order up to (not including) a certain item, presently a piece of software named 'homebank':

homebank:
  Installed: 3.33
  Candidate: 3.33
  Package pin: 3.33
  Version table:
     4.2.1-1 1001
        500 http://be.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
 *** 3.33 1001
        100 /var/lib/dpkg/status

All software packages alphabetically following this homebank package are not displayed.

I used to hold the version of this homebank software as it is a third-party software that was in conflict with another official homebank software available through the Ubuntu repository, and I did not want to have this piece of software upgraded. I hold the version of this software package by adding the following lines to /etc/apt/preferences:

> more /etc/apt/preferences
  Package: homebank
  Pin: version 3.33
  Pin-Priority: 1001

Also, as you can see in the herewith enclosed dump of all installed software (dkpg -l), KPackageKit displays all installed software up to this homebank software put on hold ('hi' is displayed in front of the homebank software package, instead of 'ii'). I think this KPackageKit software bug is closely related to this hold operation.

By the way, there is no GUI in KpackageKit to hold the version of a specific software package and to prevent this software from being updated, e.g. because we are glad with the present version and we don't want to see any regression because of a new software update, or (as it is the case presently) because the package name of a third-party software conflicts with another 'official' package name.

Hope all these information would be helpful for identifying and fixing this bug in KPackageKit. I am available if you need any further information, or for testing a patch before an official delivery.

Daniel Nicoletti (dantti) wrote :

I could not reproduce your issue, but this might be related to a bug fixed in packagekit-backend-aptcc version 0.6.8-0ubuntu3.1 If you don't have the .1 try updating.

Daniel Nicoletti (dantti) wrote :
Daniel Nicoletti (dantti) wrote :

And holding the package through /etc/apt/preferences didn't work so I did:
echo homebank hold | dpkg --set-selections
(but my preferences file is like yours)

Here is the version of packagekit-backend-aptcc which I use:

> apt-cache policy packagekit-backend-aptcc
packagekit-backend-aptcc:
  Installed: 0.6.8-0ubuntu3.1
  Candidate: 0.6.8-0ubuntu3.1
  Version table:
 *** 0.6.8-0ubuntu3.1 0
        500 http://be.archive.ubuntu.com/ubuntu/ maverick-updates/main i386 Packages
        100 /var/lib/dpkg/status
     0.6.8-0ubuntu3 0
        500 http://be.archive.ubuntu.com/ubuntu/ maverick/main i386 Packages

As you can see, this is the correct one.

So maybe the problem is elsewhere. You did install the official homebank software as I can see from your snapshot, while I installed a third-party one from my own bank. I remember that the Debian package from that bank was not properly built and I had to install several extra libraries myself. Now my homebank software is running fine, yet it causes this strange behaviour in KPackageKit. So maybe the bug is related to this issue, or the hold operation which I told you before (to not have it overwritten by the official homebank software package, I mean the one of your snapshot). Yet, I can't figure out why dpkg -l is able to list all installed softwares while KPackageKit is not.

If you want me to carry out some trace on my station or to upload some APT/dpkg files, please let me know: I will be keen to do so.

Download full text (4.3 KiB)

Here some extra information about this homebank package that causes all these troubles.

> apt-cache policy homebank
homebank:
  Installed: 3.33
  Candidate: 3.33
  Package pin: 3.33
  Version table:
     4.2.1-1 1001
        500 http://be.archive.ubuntu.com/ubuntu/ maverick/universe i386 Packages
 *** 3.33 1001
        100 /var/lib/dpkg/status
anderlia@BEANTN0L019620:~$ apt-cache s homebank
search show showpkg showsrc stats
anderlia@BEANTN0L019620:~$ apt-cache s homebank
search show showpkg showsrc stats
anderlia@BEANTN0L019620:~$ apt-cache showpkg homebank
Package: homebank
Versions:
4.2.1-1 (/var/lib/apt/lists/be.archive.ubuntu.com_ubuntu_dists_maverick_universe_binary-i386_Packages)
 Description Language:
                 File: /var/lib/apt/lists/be.archive.ubuntu.com_ubuntu_dists_maverick_universe_binary-i386_Packages
                  MD5: 15995eee902f229162ae1106f12efc4a

3.33 (/var/lib/dpkg/status)
 Description Language:
                 File: /var/lib/dpkg/status
                  MD5: 8d92d828041b582abc468a00a4672287

Reverse Depends:
  homebank-data,homebank 4.2.1-1
  datafreedom-perl,homebank

Dependencies:
4.2.1-1 - homebank-data (2 4.2.1-1) libatk1.0-0 (2 1.29.3) libc6...

Read more...

a few more words to add with respect to my homebank installation.

homebank 3.33 is the version I have installed and held.
homebank 4.2.1-1 is the version from the official Ubuntu repository that, without the hold flag, should have overwritten the 3.33 version.

Maybe KPackageKit is messing up when confronted to such an up version on top of an held lower version. Don't think you tested such a configuration Daniel. You may try to install first a lower version of homebank (or another piece of software), then hold it and update the apt cache. Don't know, but may be worth trying.

Daniel Nicoletti (dantti) wrote :

I think I also tryied with my libc update, but I'll check again.

BTW can you test search for "ho" and see if it also happens.
Another important test would be to run packagekitd --verbose
so that we may know if this package is somehow crashing
packagekit-backend-aptcc if that's the case it needs fixing.

Best.

Search through 'installed software' and 'all software' by entering 'ho' or 'home' in the search text box, result > no homebank software or alike is returned, neither the official one available through the Maverick universe repository (http://packages.ubuntu.com/maverick/homebank), neither mine. So, something is definitively wrong with kPackageKit or my software configuration.

Don't know how to run your packagekitd utility: I have nothing as such installed, nor I could find it on the Internet. How can I install it so as I can make the necessary traces. Also, when do you want me to perform this trace, e.g. running kpackagekitd before starting KPackageKit, and then click on 'installed software' to query the apt-cache, and then observing packagekitd output?

A few extra information that might be helpful for you: this was working fine with previous KpackageKit versions (Kubuntu 9.10, 10.04) with my homebank software installed and held, and stops working since the new re-designed version available for Kubuntu 10.10 (BTW, congratulations for the brand new design and improvements!). Also, I regularly checked this issue on several KPackageKit upgrades since this new re-designed version: the problem was/is persistent and systematic.

Daniel Nicoletti (dantti) wrote :

OK,
so we have a bug in packagekit-backend-aptcc package,
in earlier versions of kubuntu this wasn't the default backend.
Now so that we can get closer to finding the bug please run:

sudo -s "pkill packagekitd;/usr/lib/packagekit/packagekitd --verbose"

KPackageKit is only an interface to packagekitd, so this will kill any running
instances and start a new one in verbose mode. After that run
you search and if I'm not wrong packagekitd will crash if
that happens we can do more tests.
(please post the output of the command if possible)

Also if you can send me your homebank package (if it's not ilegal to do so),
I can try again to reproduce which would make this fixing much faster.

Thanks.

Daniel,

Herewith attached packagekitd's output while i am checking the installed software through KPackageKit. Indeed, we see a crash at the end of the log while hitting homebank package.

Debian package for my homebank software is availabale here > http://download2.ing.be/homebank/security/linux/HomeBank333.deb

You will also have to install the following libraries and patches to make it working (not sure whether it is strictly necessary for the bug to show up):

Install additional required software packages libexpat1, libstdc++2.10-glibc2.2, libtiff4.
Create corresponding symbolic links in /usr/lib
> cd /usr/lib
> sudo ln -s libtlniff.so.4 libtiff.so.3
> sudo ln -s libexpat.so.0 /lib/libexpat.so.1

Regards

Daniel Nicoletti (dantti) wrote :

Thank you for the help on finding this issue :D
The problem was that your bank package didn't contain a section string.
I have fixed it today and will send the package so that a new package can be created.

http://gitorious.org/packagekit/packagekit/commit/acd6cb4b68c21418a4cd7a8c4c121d86d6b57aa5

Best.

Thanks Daniel for your prompt reaction, and congratulations for your findings. When will the new package be pushed into the Maverick update repository?

BTW, a minor mistake: the fix is for bug LP#691474 (and not LP#591474).

Best Regards

Daniel Nicoletti (dantti) wrote :

The process is not very fast probably in a few weeks.
I'll update this bug when it's out.

Best.

Jonathan Riddell (jr) on 2010-12-20
affects: kpackagekit (Ubuntu) → packagekit (Ubuntu)
Changed in packagekit (Ubuntu Natty):
status: New → Fix Released
Jonathan Riddell (jr) wrote :

Fix uploaded to natty.

Fix uploaded to maverick-proposed, debdiff attached, awaiting approval.

Jonathan Riddell (jr) wrote :

<dantii> test case is just install his bank .deb file

Accepted packagekit into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in packagekit (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed

Successfully tested with maverick-proposed upgrades: the list of all software installed on my station, inc. the ones following the third-party homebank package, is now correctly displayed by KPackageKit. Thank for your very prompt and effective feedback and fix.

Best Regards
Alain

Martin Pitt (pitti) on 2010-12-23
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package packagekit - 0.6.8-0ubuntu3.2

---------------
packagekit (0.6.8-0ubuntu3.2) maverick-proposed; urgency=low

  * Add ubuntu_01_null_selection_crash.diff from
    http://gitorious.org/packagekit/packagekit/commit/acd6cb4b68c21418a4
    cd7a8c4c121d86d6b57aa5 Fix LP: #691474 bug which caused a crash when
    the Section() of a package was NULL
 -- Jonathan Riddell <email address hidden> Mon, 20 Dec 2010 17:37:19 +0000

Changed in packagekit (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers