owncloud network access is disabled

Bug #1572321 reported by Fernando on 2016-04-19
378
This bug affects 77 people
Affects Status Importance Assigned to Milestone
owncloud-client (Ubuntu)
High
Unassigned
qtbase-opensource-src (Ubuntu)
High
Unassigned

Bug Description

Hi! In Xenial, with the client from the repos (2.2.1+dfsg-1), if I suspend and resume the laptop, or if the internet connection is lost for whatever reason and comes back, this is not detected by owncloud, which shows a message saying that "No connection to owncloud at .... Network access is disabled". The only way of getting it back is killing owncloud and starting it again, which is very annoying. I would appreciate very much any help with this, as it really interferes with my workflow.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in owncloud-client (Ubuntu):
status: New → Confirmed
luca (l-savio) wrote :

Same behaviour on xubuntu 16.04 64 bit owncloud-client 2.1.1+dfsg-1ubuntu1.1 (from proposed repo)

Andreas Haupt (ah78) wrote :

Looks like this is rather a qt5 bug. At least upstream reports indicate this:

https://github.com/owncloud/client/issues/3600
https://github.com/owncloud/client/issues/3888

Patch for qt5 is referenced here (not in Ubuntu's 5.5.1 version, yet):

https://codereview.qt-project.org/#/c/121724/

Since this is a QT bug in the Ubuntu distribution, what is the correct procedure for requesting (begging?) the QT maintainers to backport the patch?

Andreas Haupt (ah78) wrote :

Should be resolvable by backporting

https://codereview.qt-project.org/#/c/121724/

to qt5 package in 16.04

Timo Jyrinki (timo-jyrinki) wrote :

We have the patch already in 16.04 LTS too: http://anonscm.debian.org/cgit/pkg-kde/qt/qtbase.git/tree/debian/patches/qnetworkaccessmanager_accessibility.diff?h=ubuntu (since 5.5.1+dfsg-6ubuntu1 originally).

Changed in qtbase-opensource-src (Ubuntu):
status: New → Incomplete
KDontenville (kevin-keepnet) wrote :

This is still constant pain for me and is reported as an error based on building from a bug in QT5 shipping with 16.04.

After every suspend on all 16.04 laptops we use, owncloud client refuses to find the reappearance of the network connection. Quit app and restart before it will find it.

I have collated a few of the reports here which may help identify the key patches needed, but at the moment the solution for the build does not seem to be in place.

See here: https://github.com/owncloud/client/issues/3888

Last comments:

(For OS X and Windows, we add the patch https://github.com/owncloud/client/blob/master/admin/qt/patches/0012-Make-sure-networkAccessibilityChanged-is-emitted.patch which did not make it into Qt 5.1.1 release)

and here: https://github.com/owncloud/client/issues/4839

with a comment of:
$SOMEONE needs to get Ubuntu to update their Qt packages to check if there is a need to add any of the patches listed in https://github.com/owncloud/client/tree/2.2/admin/qt/patches

And also here: https://github.com/owncloud/client/issues/4720

Comment:
Could be that we also need https://codereview.qt-project.org/#/c/146115/ .. maybe you want to try that out and report back.
(On Windows, OS X we don't ship the Qt bearer plugins, that's why this patch is not needed)

Might help identify the patches!

Carlo Zanella (zanella-carlo) wrote :

Until the issue is properly resolved and Ubuntu's Qt packages are updated, I have found that installing the Qt 5.6 libraries from the PPA here https://launchpad.net/~beineri/+archive/ubuntu/opt-qt56-xenial solves this problem.

The libraries are installed to /opt and so they shouldn't interfere with the rest of the system.

To use the Qt 5.6 libraries, owncloud can be started as follows:

LD_LIBRARY_PATH=/opt/qt56/lib/ /usr/bin/owncloud

Note: I am not sure if Qt 5.6 is officially supported by owncloud (there are at least problems on OSX - see here for a discussion: https://github.com/owncloud/client/issues/3449), but for me everything seems to work. This also fixes the issue that the owncloud icon does not appear in the system tray.

KDontenville (kevin-keepnet) wrote :

Hi Carlo, thanks very much for posting that fix, QT5.6 in /opt works perfectly for us. We just modified the startup apps entry to include the path so ownCloud starts as needed without user intervention.

Does anyone know if Ubuntu is going to address this qt5 bug in its repos?

Timo Jyrinki (timo-jyrinki) wrote :

As mentioned in comment #6, the currently reported fix from upstream is already in Ubuntu 16.04 LTS. There is no known other suggested fix reported so far, but it'd be welcome to know one.

I'm still having this issue. Any news? ownCloud icon shows up with three dots and never resumes connection after suspend (only after suspend). Losing internet connection and resuming it during the session does not affect it.

Correction: after suspend AND after locking the screen.

Just got an update (few minutes ago) and it seems to be fixed. Restarted, suspended, locked and lost internet connectivity (because of the current network-manager bug)... and ownCloud is still up and running and reconnecting as it's supposed to do. Please confirm.

I saw a few changes for glib-networking pushed today. However, owncloud-client doesn't depend on these. But just to confirm one way or the other, I upgraded and rebooted. I can report the same broken behavior as in the original post.

Henry: can you be more specific? What packages did you update?

Martin, I received two updates at 18:31 GMT for "owncloud-client" and "libqt5keychain1". ownCloud is now version 2.2.1-5.2 and libqt5keychain1 is 0.7.0-1.1. I don't know what the latter is, but it may be worth mentioning. So far, ownCloud has been running fine. I made several tests with suspend and screen lock.

Thank you for that extra info, Henry!

So, with a minor bit of sleuthing, I figured out that you are using the opensuse repository rather than 'universe' for your owncloud-client. I was hoping to stick to the Ubuntu-maintained repository for consistency.

However, I can confirm that the owncloud-client (together with the libqt5keychain1) in the opensuse repository does solve the problem for me as well.

See here for respository and installation details:

https://software.opensuse.org/download/package?project=isv:ownCloud:desktop&package=owncloud-client

ilaiho (ilaiho) wrote :

https://github.com/owncloud/client/issues/4720

Recently there is a comment: "Seems to be resolved for me with Version 2.2.2-1.1 from official repo.". Maybe Ubuntu should bump up the version.

Iiro Laiho (iiro) wrote :

https://packages.debian.org/search?keywords=owncloud-client

The new version is available on Debian testing.

tags: added: xenial
Brian Murray (brian-murray) wrote :

This commit was made to upstream as a workaround, for missing qt patches, so would be a minimal fix suitable for an SRU.

https://github.com/owncloud/client/commit/de82d8fcdb06ce993ac5788176e41ff64fc828c4

Alternatively, reading the upstream bug it seems a qt patch is missing in the Xenial package version. This also would be eligible for an SRU.

https://codereview.qt-project.org/#/c/146115/

Changed in qtbase-opensource-src (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → High
Changed in owncloud-client (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Timo Jyrinki (timo-jyrinki) wrote :

We have also carried https://codereview.qt-project.org/#/c/146115/ in Ubuntu since February, as part of the qnam-ubuntu-fix6.patch. The author of the upstream patch works on Ubuntu.

Changed in qtbase-opensource-src (Ubuntu):
status: Triaged → Incomplete
Malin Bruland (malinkb) wrote :

When is this bug fixed through the official repos?

The bug is still present as of Ubuntu 16.04.1 64-bit, on two computers, with latest updates and no external ppa for qt or owncloud.

Pere (pere-pala) wrote :

This is still happening on a new laptop with ubuntu 16.04.01 at december 2016

Mark O'Donovan (shiftee) wrote :

Still present on my 3 machines. I have tried scripts to restart it but it's too messy for my liking

iGadget (igadget) wrote :

Have you tried Nextcloud? Working flawlessly here on several machines.

Mark O'Donovan (shiftee) wrote :

I am synching with a next-cloud instance but I prefer to use the sync-clients from the distro repository.

I believe the newer owncloud/nextcloud clients in the ppas don't have this issue but they may well contain other bugs

Fernando (fmuro) wrote :

I don't think that the idea is switching software, many of us connect to an owncloud server that we don't manage. I switched to Fedora, but this doesn't solve the bug in Ubuntu.

slash (slash-tux) wrote :

Any hope that the package version will be bumped ?
I'm struggling with my armhf version... owncloud repos doesn't provide one.
Thanks

iGadget (igadget) wrote :

@slash (slash-tux): IMHO you'd be better of to switch to Nextcloud, even though they don't seem to provide a native arm build of their client either. I did find a guide to build it from source though (assuming you're using a machine like RPi): https://help.nextcloud.com/t/nextcloud-client-for-raspberry-pi/27989/5

slash (slash-tux) wrote :

Thanks I'll look at it, it's for Ubuntu touch phone under Xenial.

This shouldn't be the final solution as not all the ubuntu users have the faculty to compile the client by themself.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers