i can't install new software..

Bug #238153 reported by Pruimenvlaai on 2008-06-07
24
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openssl-blacklist (Ubuntu)
Undecided
Unassigned
ssl-cert (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: openssl-blacklist

i'm a linux noob, and this is about the third time i run ubuntu... But i wanted tot install the new firefox 3 and update the whole system, but it came with this error message... i don't really know how to fix this :-P

ProblemType: Package
Architecture: i386
Date: Tue Jun 3 16:35:02 2008
Dependencies:

DistroRelease: Ubuntu 8.04
ErrorMessage: short read in buffer_copy (backend dpkg-deb during `./usr/share/openssl-blacklist/blacklist.RSA-1024')
Package: openssl-blacklist None [modified: /var/lib/dpkg/info/openssl-blacklist.list]
PackageArchitecture: all
SourcePackage: openssl-blacklist
Title: package openssl-blacklist None [modified: /var/lib/dpkg/info/openssl-blacklist.list] failed to install/upgrade: short read in buffer_copy (backend dpkg-deb during `./usr/share/openssl-blacklist/blacklist.RSA-1024')
Uname: Linux 2.6.24-17-generic i686

Pruimenvlaai (wouterr5) wrote :
Nick Ellery (nick.ellery) wrote :

Hi, and thanks for reporting this bug. What application were you using when you tried to install this? Was it through Update Manager or Synaptic Package Manager?

Changed in openssl-blacklist:
status: New → Incomplete
AMDave (amd-ave) wrote :

I have the identical error.
Package appeared in updates list as a security update.
I was using a local mirror, so I also checked the "main" server after an " apt-get clean".
Problem seems to exist on the published package.
postgres (latest version 8.3) has a dependency on ssl-cert which has a dependency on openssl-blacklist, if that helps.

AMDave (amd-ave) wrote :

The key is the "short read in buffer_copy"

After many repeated cycles of
 (1) delete the screwed up file and
 (2) try a different mirror
I finally got a copy of the file that worked.

aside - Getting a lot of those "short read in buffer_copy" - a problem only experienced by ubuntu in my network - but that's a different issue.

I recon that this issue should be marked [CLOSED]

Jamie Strandboge (jdstrand) wrote :

Marking Invalid per user comments

Changed in openssl-blacklist:
status: Incomplete → Invalid
Changed in ssl-cert:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers