OpenOffice Writer crashes when loading a document with form/check boxes if openoffice.org-base not installed

Bug #52847 reported by Carlos F.
42
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
High
Unassigned
Gutsy
Undecided
Unassigned

Bug Description

Binary package hint: openoffice.org-writer

I'm writing a document with OpenOffice both at home and at work. At work I have Windows XP + OpenOffice.org 2.0.0, and at home I have Ubuntu 6.06 installed.

The document loads and saves perfectly on the windows version, but when I try to open it on Ubuntu, the program completely crashes. The document is in ODF format, but if I save it as a .sxw, OOo on Ubuntu also crashes.

This problem doesn't reproduce when I save the file as a .doc or as a .rtf.

I'll try to attach the document, because can't figure where the problem is.

TEST CASE:

Open the document in the bug thread, if it opens without crashing the bug is corrected.

Revision history for this message
Carlos F. (topopardo-deactivatedaccount) wrote :
Revision history for this message
Carlos F. (topopardo-deactivatedaccount) wrote :

More info: I asked a friend to open the document on his OOo (Ubuntu, also) and he reported that it didn't crash.

So how can I debug or provide a backtrace? OOo lauches with a helper app, and gdb complains about debugging it :(

Revision history for this message
John Vivirito (gnomefreak) wrote :

Thanks for your bug report. Could you please try to obtain a
backtrace by following the instructions on
       http://wiki.ubuntu.com/DebuggingProgramCrash.
This will greatly aid us in tracking down your problem.

Changed in openoffice.org:
status: Unconfirmed → Needs Info
Revision history for this message
Carlos F. (topopardo-deactivatedaccount) wrote :

okay, the backtrace. Hope this helps.

I added a note in the backtrace telling the exact moment when I open the file

Revision history for this message
Carlos F. (topopardo-deactivatedaccount) wrote :

With the lastest OOo update from the ubuntu repositories (Version: 2.0.2-2ubuntu12.1) the crash no longer happens. Maybe it was a conflict with some other package, don't know.

Thanks anyway!

Revision history for this message
John Vivirito (gnomefreak) wrote :

Has been fixed.

Changed in openoffice.org:
status: Needs Info → Fix Released
Revision history for this message
Jérôme Guelfucci (jerome-guelfucci-deactivatedaccount) wrote :

Still happens for some people (bug #113760 marked as duplicate) with Feisty and Ooo 2.2.0 so I reopen the bug.

Changed in openoffice.org:
status: Fix Released → Confirmed
Revision history for this message
Chris Cheney (ccheney) wrote :

The quick solution to this problem is to just install openoffice.org meta package and/or the openoffice.org-base package. Something that writer needs to display the checkboxes/forms is in the openoffice.org-base package. I intend to track down more of these related issue during UDS next week.

Thanks,

Chris Cheney

Changed in openoffice.org:
importance: Undecided → High
Chris Cheney (ccheney)
Changed in openoffice.org:
milestone: none → gutsy-updates
Revision history for this message
Chris Cheney (ccheney) wrote :

The documents in these bug reports need the following library installed for the crash to stop happening:

/usr/lib/openoffice/program/libdba680li.so

Thanks,

Chris Cheney

Revision history for this message
Peter Wagner (o-petris) wrote :

I haven't found this library in Synaptic. On the given address there is already a file with this name, but anyway it doesn't work. Or do I missunderstand the meaning of "install"?

Revision history for this message
Chris Cheney (ccheney) wrote :

A different meaning of "install" :-)... It is a library inside of the openoffice.org-base package, I just noted that it not being installed was the root cause of the crash. It will be moved to openoffice.org-core in the near future.

Thanks,

Chris Cheney

Chris Cheney (ccheney)
description: updated
Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

This has been fixed in openoffice.org 2.3.0-1ubuntu5.3

Changed in openoffice.org:
status: Confirmed → Fix Released
Revision history for this message
Peter Wagner (o-petris) wrote :

I do have openoffice.org 2.3.0-1ubuntu5.3, but the bug still hasn't fixed. I'll attach the file

Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

The file in the first post did open correctly without crashing, so this bug was fixed.
Your document still crashes, please file a separate bug report on the issue.

Changed in openoffice.org:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers