OpenOffice.org writer crashes when trying to run the launcher macros (eg install dictionaries) without openoffice.org-base installed

Bug #24975 reported by ivan helguera
148
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
High
Unassigned
Gutsy
Undecided
Unassigned

Bug Description

I load oo2.
I go to macros - 002 macros - get to launcher -
And oo2 just disappears without trace.
The error is repeatable.I reloaded oo2, inc. a full 2.0 (no rc2) version. I use java
1.4
Best
MG

TEST CASE:

Follow above instructions or go to File -> Wizard -> Install new dictionaries. If the wizard comes up without crashing then the bug is fixed.

Revision history for this message
Matthias Klose (doko) wrote :

confirmed with 2.0.2

Changed in openoffice.org2-amd64:
status: Unconfirmed → Confirmed
Revision history for this message
Matthias Klose (doko) wrote :

How to reproduce:

- Tools / Macros ... / Run macro
- Select OpenOffice.org macros
- Select Launcher ... OOo crashes

Revision history for this message
ivan helguera (ivanhelguera) wrote :

because of some problem with reporting this bug, I repored it again as 31283

https://launchpad.net/distros/ubuntu/+bug/31283
I posted some info there, including the error output. It looks like a java problem
ih

Revision history for this message
ivan helguera (ivanhelguera) wrote :

BTW the problem is not only in Ubuntu. I obtained the very same result in SimplyMepis 3.4.3

Revision history for this message
Matthias Klose (doko) wrote :

fixed in 2.0.4-0ubuntu2

Changed in openoffice.org:
status: Confirmed → Fix Released
Revision history for this message
Alek Tarkowski (alek-tarkowski) wrote :

i try to install a new dictionary with the new dictionary wizard. oowriter crashes. I am using OO 2.2 on kubuntu.

Revision history for this message
Alek Tarkowski (alek-tarkowski) wrote :

this does not seem to be fixed in version 2.2 - i changed status, hope that's ok!

Changed in openoffice.org:
status: Fix Released → Incomplete
Matthias Klose (doko)
Changed in openoffice.org:
assignee: doko → nobody
status: Incomplete → New
Revision history for this message
Chris Cheney (ccheney) wrote :

I tested this on Ubuntu 7.10 on both amd64 and i386. It works on both but only when openoffice.org-base is installed if you have "openoffice.org" package installed it will pull that in also.

Chris

Changed in openoffice.org:
status: New → Confirmed
Chris Cheney (ccheney)
Changed in openoffice.org:
importance: Medium → High
Chris Cheney (ccheney)
Changed in openoffice.org:
milestone: none → gutsy-updates
Revision history for this message
Chris Cheney (ccheney) wrote :

the install dictionaries wizard needs to have the following library

/usr/lib/openoffice/program/libdba680li.so

Revision history for this message
ppedrok (ppedrok) wrote :

Confirmed on Kubuntu 7.10, clean install on laptop and desktop machines: on both, OOo 2.3 (wirter or calc!) crashes with almost all macros, incl. dictionary wizard. Installing oo-base fixed the problem.
Note to ubuntu developers: please let oo-base be installed by default! For us newbies it is quite difficult to find this workaround.

Revision history for this message
ppedrok (ppedrok) wrote :

Confirmed: I copied /usr/lib/openoffice/program/libdba680li.so from my laptop (OOo-base installed) to the desktop machine, without OOo-base. That was enough to fix the macro crashing problem.
New note to ubuntu developers: if there is not enough room on the Kubuntu Life CD for ooo-base, at least make sure /usr/lib/openoffice/program/libdba680li.so is installed by default.
Thanks!

Chris Cheney (ccheney)
description: updated
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into gutsy-proposed, please test:

openoffice.org (1:2.3.0-1ubuntu5.2) gutsy-proposed; urgency=low

  * debian/rules: Rename intro.bmp to openintro_ubuntu.bmp.
    Closes LP: #155125
  * debian/rules move libdba680lx.so from openoffice.org-base to
    openoffice.org-core.
    Closes LP: #24975, #52847, #117648, #134276, #156852, #157512
  * ooo-build/patches/src680/pyuno-rpath-ooodir.diff:
    Closes LP: #132583
  * ooo-build/patches/src680/ooo82608.vcl.gtkbadfree.diff:
    Closes LP: #131526
  * ubuntu/openintro_ubuntu.bmp:
    Update splash screen to right bitmap depth. Closes LP: #157176

 -- Chris Cheney <email address hidden> Sat, 24 Nov 2007 20:07:29 -0600

Changed in openoffice.org:
status: New → Fix Committed
Revision history for this message
Benoit St-André (benoit-st-andre) wrote :

Just tested 2.3.0-1ubuntu5.3 (don't know why, it seems 2.3.0-1ubuntu5.2 never appeared on any gutsy-proposed mirror).

The fix works for Installing new dictionnairies, I suppose for all macros too. It works as expected, doesn't crash at all.

Thanks for the fix !

Revision history for this message
Pedro Villavicencio (pedro) wrote :

Verification done:

Test with openoffice.org 1:2.3.0-1ubuntu5 after follow the test case it crashed.
Test with openoffice.org 1:2.3.0-1ubuntu5.3 after follow the test case it doesn't crash and it show the wizard. the bug is fixed, thanks.

Revision history for this message
Martin Pitt (pitti) wrote :

Copied to gutsy-updates.

Changed in openoffice.org:
status: Fix Committed → Fix Released
Revision history for this message
Pelládi Gábor (pelladigabor) wrote :

This has been fixed in openoffice.org 2.3.0-1ubuntu5.3

Changed in openoffice.org:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.