Ubuntu

OpenOffice.org's Install new dicionaries wizard crashes OpenOffice.org Writer

Reported by ehamberg on 2007-03-24
20
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org-writer

When choosing File -> Wizards -> "Install new dictionaries...", OpenOffice.org Writer crashes. When restarting, it wants to recover DicOOo, but letting it do this results in a dialogue window telling me that the document contains document macros and asking me if I want to enable og disable macros. Choosing either crashes Writer again. To quit this loop I have to choose Cancel to cancel the document recovery.

Version info:
Kubuntu 7.04 beta
openoffice.org 2.2.0rc3oof680m10-0ubuntu3, Thu Mar 8 14:02:29 UTC 2

ehamberg (hamberg) wrote :

I still get this crash on the now released 2.2 packages

Matthias Klose (doko) wrote :

works with 2.2.0-0ubuntu2

Changed in openoffice.org:
assignee: nobody → doko
status: Unconfirmed → Fix Released
ehamberg (hamberg) wrote :

I still get this crash on 2.2.0-0ubuntu2, even when deleting ~/.openoffice.org2/ and starting from scratch.

carutsu (carlos-licea) wrote :

Same problem over here.

jeroenl (jeroenl) wrote :

I can confirm this with a fresh install of the (test) RC of Feisty and with updates afterwards. This doesn't happen on an existing (updated) install. It says 'fix released', but when?

jeroenl (jeroenl) wrote :

See my latest post. This still does not work! Only on a fresh install.

Changed in openoffice.org:
status: Fix Released → Confirmed
Matthias Klose (doko) wrote :

jeroen69 schrieb:
> I can confirm this with a fresh install of the (test) RC of Feisty and
> with updates afterwards. This doesn't happen on an existing (updated)
> install. It says 'fix released', but when?

you should read the report: "works with 2.2.0-0ubuntu2"

it still works for me on the live CD, new installs and updates from edgy.

Changed in openoffice.org:
status: Confirmed → Unconfirmed
Brian Murray (brian-murray) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. Since you reported your bug a newer version of the OpenOffice.org package is available. Could you please retest with the latest version and let us know if this is still an issue? Thanks in advance.

Changed in openoffice.org:
assignee: doko → brian-murray
status: Unconfirmed → Needs Info
ehamberg (hamberg) wrote :

I still get this crash with 2.2.0-1ubuntu3.

Brian Murray (brian-murray) wrote :

I have been unable to reproduce this using openoffice.org writer version 2.2.0-1ubuntu3 on amd64.

Changed in openoffice.org:
assignee: brian-murray → nobody
status: Needs Info → Unconfirmed
loom (kyatsenko) wrote :

I have the same problem with version 2.2.0-1ubuntu3

Chris Cheney (ccheney) wrote :

I am also unable to reproduce this on a fresh installed 7.04 (Fiesty) i386 with 2.2.0-1ubuntu3.

Does anyone who is subscribed to this bug have any further information with regards to how to reproduce this issue?

Thanks,

Chris Cheney

Changed in openoffice.org:
assignee: nobody → ccheney
status: Unconfirmed → Needs Info
loom (kyatsenko) wrote :

This bug appears on Kubuntu.

Chris Cheney (ccheney) on 2007-06-19
Changed in openoffice.org:
assignee: ccheney → nobody
importance: Undecided → Low
status: Needs Info → Confirmed

This is happening to me in Kubuntu 7.04. Perhaps its because of openoffice 2.2?

jazzuban (jazzuban) wrote :

Confirmed crash on Ubuntu Gutsy 7.10, openoffice 2.2.1

This is bug should be rated High Importance.

rodrigo (rodrigocio) wrote :

Im with jazzuban this should be rated as high importance I'm a mexican writter and journalist and this bug makes oppen office less competitive than microsoft office

Basti (basfrank) wrote :

same here with kubuntu feisty (german language) and OOO 2.2.0

Henk Bos (henk-bos) wrote :

Same problem with kubuntu feisty. It should realy have an High Importance. I need to install the new Dutch spell for my users. Usually they should be able to do this by them selves!
The only way is to install the new dictionarys woth OO on a Windows machine. Look for the changed files, and then copy it manually on the kubuntu installations as root to the ooo/dict directory (very cumbersome).

Spell and grammarchecking is just the one reason to switch back to MSWord if it does not work properly! For anything else OO and Koffice work even better than MSWord!

Kyle Bishop (kybishop) wrote :

Same problem with Gutsy Kubuntu and latest openoffice. This should be high importance.

Spell checking is a BIG deal when you need to write college papers.

Download full text (3.8 KiB)

So Gutsy users also have this problem? If anyone wants to contribute to a fix, then please subscribe to this bug (So that you get notified when someone posts a new comment). Great, we know what the problem is - now we need to start finding out what makes Dapper different from the newer versions. I've found the following instructions from DicOOo-1.8 (The dictionary installation thingy) which should give us some clues...

/*
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
*** Instructions from DicOOo-1.8 on Dapper, which mentions a number of OO's configuration directories ***
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Debian GNU/Linux: (thanks Claude)
If you are using an OOo packaged by Debian (.deb), please note that in order to use the wizard, you first need to delete the symbolic link @dictionary.lst in the directory-folder:
 /usr/lib/openoffice/share/dict/ooo
and copy in its place the existing dictionary.lst file located in:
 /etc/openoffice
To do this you need to be logged in as root.
You also need to grant all users write permissions on the dictionary.lst file, if you want them to be able to install the dictionaries:
 chmod go+w dictionary.lst
Alternatively, if your users belong to the group users:
 chown root.users dictionary.lst
You can also start the wizard as root, if you do not want your users to be able to add dictionaries themselves.
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
*/

/*
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
*** This is my "/etc/openoffice/dictionary.lst" file (Probably won't be useful to anyone, but I posted here anyway) ***
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
## !!! BEGIN AUTOMATIC SECTION -- DO NOT CHANGE !!!
## !!! ADD YOUR ADDITIONAL ENTRIES BELOW THIS SECTION !!!
DICT en GB en_GB
DICT en US en_US
THES en US th_en_US_v2
THES en GB th_en_US_v2
## !!! END AUTOMATIC SECTION -- DO NOT CHANGE !!!
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
*/

... so, now we know where OO keeps its configuration data. It says some stuff about permissions too (In the DicOOo-1.8 instructions), whi...

Read more...

Urbán Dániel (urban.dani) wrote :

My dictionary.lst has the same permissions (and I'm affected by the bug).

Well, it isn't a permission related problem then. It sounds like we need to add a dictionary without using the graphical interface - we have to add it manually. The question is: how the heck do we do this?

Go into "/usr/lib/openoffice/share/dict/ooo" via the CLI and do "ls". I get the following...

user@host:/usr/lib/openoffice/share/dict/ooo$ ls
DicOOo.sxw en_GB.aff en_GB.dic en_US.aff en_US.dic th_en_US_v2.dat
dictionary.lst en-GB.aff en-GB.dic en-US.aff en-US.dic th_en_US_v2.idx
user@host:/usr/lib/openoffice/share/dict/ooo$

... what's more interesting is that when I open "en-US.dic" it shows a huge list of words. "en-US.dic" appears to be the dictionary. I believe that "dictionary.lst" is the file in OO which tells it what dictionaries to use (As seen in writer aids). I have uploaded "en-US.dic" to Launchpad as seen in this comment. I think that someone should try copying it into "/usr/lib/openoffice/share/dict/ooo" and then edit "dictionary.lst" to make the dictionary visible. Your "dictionary.lst" file works like this:

## !!! BEGIN AUTOMATIC SECTION -- DO NOT CHANGE !!!
## !!! ADD YOUR ADDITIONAL ENTRIES BELOW THIS SECTION !!!
DICT en GB en_GB
DICT en US en_US ## Edit: This is where it makes the US_English dictionary show up. (Read next line)
                                ##(Continued) If you don't have this line (DICT en US en_US) then please add it!
THES en US th_en_US_v2
THES en GB th_en_US_v2
## !!! END AUTOMATIC SECTION -- DO NOT CHANGE !!!

... I don't know if this will work, but it's probably worth a try. It says "DO NOT CHANGE" so I get a feeling that we could screw something up. If anyone is willing to conduct this experiment then I would be very greatful :-)

Good luck everyone.

joedekangeroe (curd-delsemme) wrote :

You need to have the package "openoffice.org" installed. Not only parts of it like "open-office.org-writer" or "open-office.org-calc". On my install, ubuntu by default has only the parts.

Urbán Dániel (urban.dani) wrote :

Thanks, joedekangeroe!
I installed the "openoffice.org" package (and its dependencies) and seems that this solved the problem.
(I think, that this is not default because it depends on "openoffice.org-base", which is not used frequently.)

Henk Bos (henk-bos) wrote :

Great job, joedekangeroe!

This should be mentioned in the official (K)ubuntu guide!
One expect that the default installation holds the stuff you (basically) need, but for some strange reason this package has been left out.

Thank you very much, joedekangeroe!

I had problems with installing the swedish dictionary on my english Kubuntu 7.04 machine, and you solved it!

kymoie (kymoie) wrote :

I didn't try joedekangeroe's solution, but another solution is to search for your country's name in the repositories so I searched for Australia, and found myspell-en-au and openoffice.org-thesaurus-en-au. I downloaded both of these packages and restarted openoffice 2.3 and openoffice had already made the link to them (if it doesn't make the link check in oo.org Tools->options->language settings -> default languages that your country/language is selected)

This problem bugs me everytime I get a new version of Kubuntu (I'm currently running Kubuntu 7.10) hopefully someone will fix it soon.

®om (rom1v) wrote :

Same problem here...

Why is the importance low? I can't use open-office without a french dictionnary lol...

®om (rom1v) wrote :

It works with myspell-fr, but it's annoying to crash the soft only clicking on Wizard...

Moreover, there is no thesaurus-fr on ubuntu repository :(

Same thing here, tried on Gusty, and OOo crashes. The other problem besides that is that OOo keeps on crashing when it tries to recover DicOOO , which causes it to crash again, and again.

You have to cancel the recovery process to make it work again. Not sure that a "normal" user will do that.

Tried it with an en_US locale , and with a fr_CA locale, with an english interface, and a french interface.

Not, Wizard don't crash if you install openoffice.org package, it's
the workaround.

I didn't say openoffice-writer package and others, that crash our
wizards, I says "openoffice.org" package, try it.

Regards,

On 10/16/07, (r)om <email address hidden> wrote:
> It works with myspell-fr, but it's annoying to crash the soft only
> clicking on Wizard...
>
> Moreover, there is no thesaurus-fr on ubuntu repository :(
>
> --
> OpenOffice.org's Install new dicionaries wizard crashes OpenOffice.org Writer
> https://bugs.launchpad.net/bugs/95274
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

®om (rom1v) wrote :

But it crashes with the official Ubuntu/Kubuntu Gutsy CD !!!...

®om (rom1v) wrote :

Even with http://fr.openoffice.org/DicOOo/index_dicooo.htm it crashes...

Please higher the level of the importance !

Chris Cheney (ccheney) wrote :

This bug is the same as #24975 so I am marking it as a duplicate. The solution is to install openoffice.org-base at a minimum or to install the openoffice.org meta package which pulls it in. I will be working on trying to isolate what part of base it needs to actually work at UDS.

Thanks,

Chris

VlaDar (vdaric) wrote :

I meet this bug under Kubuntu after upgrade from Feisty to Gutsy.

It only affects dictionary installation by doing [File -> Wizards -> "Install new dictionaries..."] from OOo.

You can still install you dictionaries by using apt-get, Adept or Synapric.

For example to add Spanish dict : sudo apt-get install myspell-es

Sun Wukong (sunwukong) wrote :

Yesterday, I run into this bug with a fresh out-of-the-box Kubuntu Gutsy.
The About box says : openoffice.org-core 1:2.3.0-1ubuntu5, Monday Oct 15 09:22:18 GMT 2007

Removing ~/.openoffice2 didn't change a thing.

Finally, I uninstalled completely openoffice with aptitude, and re-installed it. I installed the openoffice.org package which wasn't installed before and managed to install the dictionaries the way it should be.

Thus, this package openoffice.org should probably be forced installed as a work-around as none seems to be interested in fixing this bug which may be encountered by 99% of OOo users. That's a big population.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments