[jaunty] openoffice javaldx could not find a java runtime environment

Bug #249352 reported by jordilin on 2008-07-17
48
This bug affects 5 people
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Wishlist
Chris Cheney

Bug Description

Binary package hint: openoffice.org

when executing oowriter from the command line, I get:
jordilin@jordilin-laptop:~$ oowriter
javaldx: Could not find a Java Runtime Environment!

but, then openoffice starts flawlessly, without any problems. I already have the java runtime installed.

jordilin@jordilin-laptop:~$ java -version
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode)
jordilin@jordilin-laptop:~$

So, this is low priority bug I would say
I'm using Ubuntu 8.04 Hardy Heron 64 bit AMD processor.

Chris Cheney (ccheney) wrote :

Does going to Tools->Options->Java and selecting your JRE resolve this problem?

Thanks,

Chris Cheney

Changed in openoffice.org:
status: New → Incomplete
jordilin (jordilin) wrote :

Interestingly enough when I go to tools-> options-> java and selecting the sun jre installed using synaptic, openoffice says that the jre folder does not include any jre, when in fact I'm choosing jre folder located in
/usr/lib/jvm/java-6-sun-1.6.0.06/jre
See screenshot. I have to admit that openoffice works fine for me, and I'm not sure if java is ever used in some parts of openoffice for document processing, but in any case choosing jre does not work

Chris Cheney (ccheney) wrote :

You shouldn't need to manually add the JRE via the add button. OpenOffice.org searches and finds all JRE's by default and you only have to select which one is to be used by clicking on a radio button (circle with dot in the center of it).

You may want to try removing the ~/.openoffice.org2 directory if you don't have any special configuration changes and see if it will then detect the JRE properly after doing that. Also make certain you have the 'sun-java6-jre' package installed, though it sounds like you do if that directory exists on your system.

Chris

jordilin (jordilin) wrote :

~$ rm -rf .openoffice.org2/
~$ oowriter
javaldx: Could not find a Java Runtime Environment!
~$

I have done this with my other laptop and still the same. Openoffice does not find a java runtime with Hardy Heron 8.04 64bits. Two different boxes, same version of Ubuntu.
I have the package sun-java6-jre installed as well.
In any case I don't know if that is really important or not :(
Best regards,
Jordi

Chris Cheney (ccheney) wrote :

Do you have all of openoffice.org installed? You can do this by installing the 'openoffice.org' meta-package.

jordilin (jordilin) wrote :

Yep, the problem was not having installed the openoffice.org meta package. The thing is Ubuntu "default installation" does not install this metapackage that includes the java support.
regards,
jordi

Chris Cheney (ccheney) wrote :

The fact that it is not installed by default, due to lack of space on the cd, and should be installed if Java support is wanted is documented in the Ubuntu 8.04 release notes, so I am closing this bug as invalid.

Thanks,

Chris Cheney

Changed in openoffice.org:
status: Incomplete → Invalid
Paul (paul-peters) wrote :

An error message when one starts oowriter after default ubuntu installation is unacceptable.

But the bug seems to be an upstream issue, since the
error message does not point to the problem, and the message under tools-> options-> java "that the jre folder does not include any jre" is plainly wrong·
Since report a bug in oowriter lead me to this page, I think the bug is still valid.

Martijn vdS (martijn) wrote :

I agree that the "No jvm found" message could be a lot clearer, maybe it could even suggest the same thing as the release notes do ("install the openoffice.org metapackage")

Jesper de Jong (jespdj) wrote :

See also bug # 270467

Charles Twardy (ctwardy) wrote :

Some additional info. Mine appeared to break worse, but it's better now. Unfortunately, there are too many changes to be diagnostic.

Yesterday my OO ran fine. Today it began to complain. I accepted a lot of updates today.

My problem started with the javadlx complaint when trying to run ooimpress, but unlike previous posters, my OO never ran. It complained and failed. (Or at least appeared to. It's possible there was a window hiding on another desktop, though I thought I had checked.)

Figuring there was a java problem, I installed sun-java6-jdk. Then "ooimpress" or other commands just hung with no process started, no cpu load. So they were finding java, but failing to use it. Adding sun-java5-jre didn't help.

I removed sun-java* (which took out ubuntu-desktop) and tried again.

$ ooimpress
javaldx: Could not find a Java Runtime Environment!

$ sudo aptitude install ubuntu-desktop sun-java5-jdk
$ ooimpress

Back to just sitting there, though I've noticed it does create .openoffice.org2/user/config/javasettings_Linux_x86.xml.

Tried removing sun-java5-jdk. No help. Tried installing gij. No help.

$ sudo aptitude install sun-java6-jdk openoffice.org
$ oowriter

Same thing -- just sits there.

However, at this point I noticed a minimized ooimpress startup window on another desktop. It had appeared somewhere in the process. After I closed that, suddenly about a dozen OO processes started up, and everything was OK.

Jesper de Jong (jespdj) wrote :

Installing the meta-package openoffice.org indeed fixes the problem. After installing that, OpenOffice automatically finds both the Sun and the OpenJDK JREs.

However, this is not a solution, but a workaround to the problem. The error message that you get when you don't have the meta-package installed is still wrong and misleading, and that's still a valid bug. The fact that this workaround is mentioned in the Ubuntu release notes is not a solution to the bug.

Changed in openoffice.org:
status: Invalid → New
Chris Cheney (ccheney) wrote :

Note to self:

Solve this by changing the error message to tell the user to install openoffice.org meta-package.

Changed in openoffice.org:
assignee: nobody → ccheney
importance: Undecided → Wishlist
milestone: none → later
status: New → Triaged
Chris Cheney (ccheney) on 2008-11-01
Changed in openoffice.org:
milestone: later → jaunty-alpha-1
Chris Cheney (ccheney) on 2008-12-01
Changed in openoffice.org:
milestone: jaunty-alpha-1 → ubuntu-9.04-beta
Chris Cheney (ccheney) on 2009-01-17
Changed in openoffice.org:
milestone: ubuntu-9.04-beta → jaunty-alpha-4
Martin Pitt (pitti) wrote :

Relaying feedback from Matt Zimmerman, which I agree to:

- Installing "openoffice.org" will also pull in OO.o base and other applications, so it's much more than the user asked for. Shouldn't -java-common be enough?

- Can the message box be extended to have an "Install..." button which would call synaptic if it is available?

  echo "openoffice.org-java-common install" | gksu /usr/sbin/synaptic --set-selections --non-interactive --hide-main-window

Chris Cheney (ccheney) on 2009-01-28
Changed in openoffice.org:
milestone: jaunty-alpha-4 → jaunty-alpha-5
Shirish Agarwal (shirishag75) wrote :

Hi all,
 Martin, had the same issue, had to google and got this bug-report and somebody commenting about openoffice.org-java-common package installation in openoffice.org to solve the situation. So this needs to be fixed as soon as possible.

Tux (peter-hoogkamer) wrote :

I had the issue with the javaldx: Could not find a Java Runtime Environment! and installed the openoffice.org package, but now openoffice only starts with the window border and nothing more. Process does not use extra memory or processor time. The java version I am using is java-6-sun and running Jaunty 9.04 Alpha 3 with the latest updates from today on a vmware workstation 5.5. Also I have the same installation running on an Acer 5051 and there the same thing happens. See attachment.

Tux

Chanchao (custom) wrote :

I have the same problem. Ubuntu 8.10, installed Sun Java 5 ( I need 5 because 6 doesn't work with Oracle forms), but OO doesn't see it and trying to add it is unsuccessful. (It claims there is no Java in the folder I select, but it's lying to me.) Pointing it to /usr/lib/jvm/java-1.5.0-sun-1.5.0.16 is unsuccessful.

Exporting to Word 2003 doesn't work without Java apparently. This shouldn't be this hard IMHO.

Chris Cheney (ccheney) wrote :

Does default-jre (openjdk-6) work for the two of you, Tux and Chanchao? Sun Java is proprietary and we can't really support it, so if it has bugs there is nothing really we can do. OpenJDK is the open source version of Sun Java and should work with OOo.

Chris

Chris Cheney (ccheney) on 2009-02-14
Changed in openoffice.org:
milestone: jaunty-alpha-5 → jaunty-alpha-6
sebastian-s (sebastian-s) wrote :

I have the same issue with 8.10

~$ java -version
java version "1.6.0_0"
IcedTea6 1.3.1 (6b12-0ubuntu6.1) Runtime Environment (build 1.6.0_0-b12)
OpenJDK Client VM (build 1.6.0_0-b12, mixed mode, sharing)

I have read about this isue and the solution i found was to instal que OpenOffice_Java_common on Synaptic.

I will doit right now, wish me luck.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.0.1-4ubuntu1

---------------
openoffice.org (1:3.0.1-4ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (r1417). Remaining changes:
    - Add Launchpad integration support.
    - Add Launchpad translations support.
    - Add package openoffice.org-style-human.
    - Add some Ubuntu-specific bitmaps. Adjust broffice diversions for these.
    - Add support for compressing debs with lzma.
    - Add support for shared /usr/share/doc directories.
    - Add support to build l10n as a separate source.
    - Add support to build on lpia.
    - Add support to turn off building on sparc.
    - Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - Set startcenter.desktop to not display in the menu.
    - Use imagemagick instead of graphicsmagick.
    - openoffice.org-help switch to internal copy of lucene.
    - Add support for DEB_BUILD_OPTIONS noopt. LP: #252226
    - Change name of desktop files to openoffice.org-(app).desktop. LP: #331768
    - Update rebuild-gcj-db snippet. Closes LP: #299229
    - Update splash screen.
  * Resynchronise with ooo-build-3-0-1 (r15493).
    - Fedora fix for OpenOffice.org crash when fontconfig sees new fonts.
    - javaldx error message now tells user to install openoffice.org-java-common
      and remove the javasettings_Linux_*.xml file. LP: #249352

 -- Chris Cheney <email address hidden> Thu, 05 Mar 2009 22:00:00 -0600

Changed in openoffice.org:
status: Triaged → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers