[Upstream] Writer AutoSpellcheck flags capitalized words as misspelled despite being added lowercase in the custom dictionary

Bug #220703 reported by cmalacara on 2008-04-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
LibreOffice
Fix Released
Low
OpenOffice
Unknown
Low
libreoffice (Ubuntu)
Medium
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer is when one adds the word "extrusión" to the custom dictionary, AutoSpellcheck does not underline the words "Extrusión" and "EXTRUSIÓN" as misspelled.

4) What happens instead is AutoSpellcheck does underline these case variations and suggests it to be the lowercased version.

WORKAROUND: Add each case variant.

Guys, I don't know if this issue refer only to pt-br language or to all
spellcheck tool, but you know what to do:

When I'm spellcheking a file the Ooo find the word "palavra", e.g., and ask me
what to do. I add the word to my dic, 'cause the word is correct. In the next
line, the Ooo find the word "Palavra", e.g., and ask me again what to do.

Note that second word have just a first character in capital letter, but is the
same word.

I think the Ooo should ignore these cases.
_________________________________________________
Using:
Ooo 1.1 RC3 English
Windows 98 SE Brazilian Portuguese
PC AMD Athlon XP 1700+
256 RAM

This is a generic problem where the spellchecker does not automatically know that
"Mizspelled" is the same word as "mizspelled", and therefore when I accept the first it
does not automatcially accpe tthe second.

Why I can't vote for this issue ?

Hi,

This is NOT a lingucomponent issue. The internal dictionary is not a source of
suggestions for MySpell. So I am changing this to the sw project in the hopes
someone there can figure out a solution.

Kevin

HI->TL: The Options in Writing Aids (Here Capitalization Check) should
also valid for user dictionary.

It looks like if
- either the user dictionry should accept a word with starting capital
letter if the word is correct (according to the user-dictionaries) if
it where written with a lowercase letter.
- or for such a word with a matching lowercase entrie the the error
flag shoul indicate a capitalization error. The latter being usually
ignored if the word starts with a capital letter because the word may
be at the beginning of a sentence.

The second solution may implictly also fix the case with using the
respective flag from the options.

Time is short. Can't be solved for OO 2.0.

Replicated the bug under both Redhat Linux and Windows XP, in OOo 1.1.0 and
1.1.4. I add the word "sateesh" in the dictionary of Spellchecker.
Next time when "Sateesh" is found, the Spellchecker cannot distinguish.
This is related to issue 18737.
This appears to be the bug in OOo 1.1.x.

There is a typo in the prev comment.
This bug actually has some relation to issue 25786.

*** Issue 27246 has been marked as a duplicate of this issue. ***

*** Issue 58860 has been marked as a duplicate of this issue. ***

Clarify summary to make QA easier with lots of similar looking issues.

still an open issue?

Yes... Still valid...

OOo-dev 2.3.0 680m1 WinXP

Hwoarang

Chris Cheney (ccheney) wrote :

Do you still have this problem with Ubuntu 8.04 openoffice.org 1:2.4.1-1ubuntu2? I can not reproduce this problem.

Thanks,

Chris Cheney

Changed in openoffice.org:
status: New → Incomplete
Chris Cheney (ccheney) wrote :

Actually nevermind, I can. I think I added the first word incorrectly the first time.

Changed in openoffice.org:
status: Incomplete → Confirmed
Chris Cheney (ccheney) on 2008-10-21
Changed in openoffice.org:
importance: Undecided → Medium
status: Confirmed → Triaged

this is not a ubuntu bug, this is a openoffice problem

Changed in openoffice.org:
status: Triaged → Invalid
Chris Cheney (ccheney) wrote :

Juan,

WHAT ARE YOU DOING?!

Stop closing bugs that are real bugs, just because it is an upstream bug does not mean that you should close it in Launchpad.

Chris

Changed in openoffice.org:
status: Invalid → Triaged
Changed in openoffice:
status: Unknown → In Progress

*** Issue 114571 has been marked as a duplicate of this issue. ***

We’re 3 years later, OOo 3.2 and this still is an issue…

A suggestion which makes sense once this is handled properly: when adding a
capitalized word to the user dictionary, ask whether it should be added
capitalized or not.

description: updated
summary: - OpenOffice doesn't recognize capitalized words if they are already in
- the custom dictionary in lower case
+ [Upstream] Writer AutoSpellcheck flags capitalized words as misspelled
+ despite being added lowercase in the custom dictionary

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/220703

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer is when one adds the word "extrusión" to the custom dictionary, AutoSpellcheck does not underline the words "Extrusión" and "EXTRUSIÓN" as misspelled.

4) What happens instead is AutoSpellcheck does underline these case variations and suggests it to be the lowercased version.

WORKAROUND: Add each case variant.

tags: added: lo33
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in openoffice.org (Ubuntu):
importance: Medium → Low
Changed in df-libreoffice:
importance: Unknown → Low
status: Unknown → Confirmed

Not a Bug, but a feature?
Seems to be INVALID without evidences for the expected behavior:

1. German Wort "man" is correct, bug "Man" would be wrong, so I doubt that
assumption "... does not underline the words "Extrusión" ..." from original
report is correct, why should spellcheck accept misspelled word "Man"?
IMHO assumption in report only is correct for unchecked preference "Check Capitalization".

2. The "EXTRUSIÓN" problem might be something different. The option "Check uppercase words" seems to mean:
- unchecked option: No uppercase word will be marked as misspelled, even nonsense
  words like "GANOIRIEJKTGTKJTRINZROSAAAAAAAAAA"
- Checked option: onl words known in lowercase or with leading uppercase first
  letter will be accepted as correct in complete uppercase
So I agree with the assumption, but that seems to be completely broken in 3.4.1, I will file a separate report after some more investigation.

@Christopher:
Can you please add some information concerning my question in 1.?

Rainer Bielefeld:

Unchecking "Check Capitalization" has no impact on this issue.

In Microsoft Office Word 2003 (11.5604.6505), if one adds extrusión in the Custom Dictionary, Extrusión and EXTRUSIÓN are not flagged as misspelled.

The OOo bug for this may be found at: http://openoffice.org/bugzilla/show_bug.cgi?id=18737

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html

Changed in df-libreoffice:
status: Confirmed → Incomplete

This persists in 3.5.0beta2.

Scott M. Sanders, please do not toggle the Version. For more on this please see:
http://wiki.documentfoundation.org/BugReport_Details#Version

As well, please do not toggle the Platform without documenting the OS and hardware platform tested against.

Changed in df-libreoffice:
status: Incomplete → Confirmed

Um it affects Win 7 64-bit on latest beta, so feel free to toggle it back to what I set.

*** Bug 39997 has been marked as a duplicate of this bug. ***

Fucking impotents.

Of course programmers are busy with more serious issues, as colorful sheet labels or new footer separators. One may wonder, do they use their product themselves?

Spam has entered Bugzilla as well? I’m quite curious how the previous comment is going to be reacted on by moderators here. Or does that guy need mediation?

(In reply to comment #2)
> [...]
> The OOo bug for this may be found at:
> http://openoffice.org/bugzilla/show_bug.cgi?id=18737

Removed outdated URL in 'See Also:'
Added correct URL for Apache OOo Bugzilla:
https://issues.apache.org/ooo/show_bug.cgi?id=18737

*** Bug 50294 has been marked as a duplicate of this bug. ***

Logan Rosen (logan) on 2012-07-05
Changed in openoffice:
status: In Progress → Unknown

Laszlo Nemeth committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d160f28b510ce9277b5d6f85eb83b87beb717fe

fdo#37954, #i18737# accept capitalized lowercase custom words

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.

Changed in df-libreoffice:
status: Confirmed → Fix Released
Changed in openoffice:
importance: Unknown → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libreoffice - 1:4.0.0~beta2-0ubuntu2

---------------
libreoffice (1:4.0.0~beta2-0ubuntu2) raring; urgency=low

  * Build using the internal libmspub for a first build.
 -- Matthias Klose <email address hidden> Tue, 19 Feb 2013 00:05:26 +0100

Changed in libreoffice (Ubuntu):
status: Triaged → Fix Released

This one has been hanging around for ten years, and it ought to be an easy fix, since this feature works right with dictionary modules, just not in user's custom dictionary.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.