[Upstream] Calc uses huge amount of ram and cpu to load 18MB .xls

Bug #148148 reported by Tollef Fog Heen on 2007-10-02
4
Affects Status Importance Assigned to Milestone
LibreOffice
Invalid
Medium
OpenOffice
New
Unknown
libreoffice (Ubuntu)
Undecided
Unassigned
openoffice.org (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: openoffice.org
1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Calc via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/148148/+attachment/151803/+files/Heroforge_5.1.2.7.zip && file-roller -h Heroforge_5.1.2.7.zip && localc -nologo Heroforge_5.1.2.7.xls

it opens quickly and successfully.

4) What happens instead is it takes 7 minutes+ to load on a PC with 1 GHz CPU, 512 MB RAM.

WORKAROUND: While LO was loading the document I loaded, clicked around, then closed a copy of the file in Gnumeric in less than a minute.

apt-cache policy gnumeric
gnumeric:
  Installed: 1.10.13-1ubuntu1
  Candidate: 1.10.13-1ubuntu1
  Version table:
 *** 1.10.13-1ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages
100 /var/lib/dpkg/status

Original Reporter Comments: OOo crashes calc on startup here. I get the "Openoffice crashed and will now restart and try to recover the documents", at which point it restarts into OOo writer.

Tollef Fog Heen (tfheen) wrote :
Chris Cheney (ccheney) wrote :

Tollef,

It loads without crashing here but takes an enormous amount of ram to do so and becomes rather unresponsive after I switch between sheets.

Chris

29184 ccheney 15 0 978m 402m 62m S 7 20.0 1:16.43 soffice.bin

Changed in openoffice.org:
importance: Undecided → Low
status: New → Confirmed

Confirmed with upstream's openoffice.org 2.4.0~rc2 though it appears to use less ram than it previously did.

Chris Cheney (ccheney) on 2008-03-18
Changed in openoffice:
importance: Undecided → Unknown
status: New → Unknown
Changed in openoffice:
status: Unknown → New
Chris Cheney (ccheney) on 2008-06-13
Changed in openoffice.org:
status: Confirmed → Triaged
Chris Cheney (ccheney) on 2010-05-13
tags: added: hardy
description: updated
Changed in libreoffice (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
summary: - [Upstream] [hardy] OpenOffice calc uses huge amount of ram and cpu to
- load heroforge 5.1.2.7
+ [Upstream] [hardy] Calc uses huge amount of ram and cpu to load 18MB
+ .xls
tags: added: lo33
description: updated
Changed in gnumeric (Ubuntu):
status: New → Invalid

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/148148

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386
Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Calc via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/148148/+attachment/151803/+files/Heroforge_5.1.2.7.zip && file-roller -h Heroforge_5.1.2.7.zip && localc -nologo Heroforge_5.1.2.7.xls

it opens quickly and successfully.

4) What happens instead is it takes 7 minutes+ to load on a PC with 1 GHz CPU, 512 MB RAM.

Most likely that is just how it is. I assume Excel does not take a huge amount of memory and CPU to open this document, but then, Excel is a different program with different internal data structures.

But sure, Kohei has in many cases managed to reduce Calc resource usage for some classes of pathological spreadsheet documents, let's hope something can be done for this one, too.

Changed in df-libreoffice:
importance: Unknown → Medium
status: Unknown → Confirmed

I modified Status to Assigned due to facts.

@Kohei:
I'm just trying to gather all Whiteboard key word recommendations. "perf" seems to be for "performance", is there any listing where I can find that definition and may be others, too?

Changed in df-libreoffice:
status: Confirmed → In Progress

(In reply to comment #2)

> @Kohei:
> I'm just trying to gather all Whiteboard key word recommendations. "perf" seems
> to be for "performance", is there any listing where I can find that definition
> and may be others, too?

Yes, I use 'perf' for performance related issues. This is my personal whiteboard keyword but feel free to use it globally.

Changed in openoffice.org (Ubuntu):
status: Triaged → Won't Fix

[This is an automated message.]
There are no new official OpenOffice.org releases in Ubuntu packaging anymore => Won't Fix

If the problem persists, please mark this bug as "also affects project Libreoffice" or "also affects distribution Libreoffice (Ubuntu)" if that has not happened already.

Please leave references to upstream OpenOffice.org bugs in place to allow cross pollination.

summary: - [Upstream] [hardy] Calc uses huge amount of ram and cpu to load 18MB
- .xls
+ [Upstream] Calc uses huge amount of ram and cpu to load 18MB .xls
Changed in df-libreoffice:
status: In Progress → Confirmed
Sergi Granell (xerpi-g-12) wrote :

This shit keeps crashing. Good job.

Opens and is responsive here on LibreOffice 4.0.3 with:

 9196 bjoern 20 0 1537m 561m 80m S 1.7 3.5 0:25.43 soffice.bin

thus closing as WORKSFORME.

closing as per upstream

Changed in libreoffice (Ubuntu):
status: Triaged → Won't Fix

Fix Released as this works fine in Raring.

lsb_release -rd
Description: Ubuntu 13.04
Release: 13.04

apt-cache policy libreoffice-calc
libreoffice-calc:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status

no longer affects: libreoffice (Ubuntu)
affects: gnumeric (Ubuntu) → libreoffice (Ubuntu)
Changed in libreoffice (Ubuntu):
status: Invalid → Fix Released
Changed in df-libreoffice:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.