[Ubuntu] [hardy] under KDE openoffice has no toolbar icons

Bug #138360 reported by jbmetal on 2007-09-09
16
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
Critical
Unassigned

Bug Description

Binary package hint: openoffice.org

the first time I used any openOffice.org applications, I saw the icons on every toolbar, specially on the Writer, but right now, i dont know why, only appears the names of each function on each toolbar. I have tried any setting, also I reinstalled the Suite.

jbmetal (jorge-berrios-maura) wrote :
Claudio Di Vita (cdivita) wrote :

I've also noticed this problem. This is very annoying, I'm not able to use OpenOffice.org suite

Gert Kulyk (gkulyk) wrote :

Could you please check which openoffice.org-style* packages are installed? If you try to use an icon-style that is actually not installed something like this may happen. You should be able to get the icons back by either installing the appropriate package or by selecting an installed style. Unfortunately the program seems not to check which styles actually are installed, so you are able to select a style in the preferences-dialog which is not present on your machine.

Claudio Di Vita (cdivita) wrote :

I've not selected any style from the preferences-dialog (maybe because I can't find this setting), but after looking the installed packages I've noticed that no one of openoffice.org-style* packages were installed.

Now I've installed these packages and finally always works fine. But my question is: why these packages, at least the one wich contains the default style, are not installed by default ??

Claudio Di Vita (cdivita) wrote :

Is not a bug, this problem raise when an appropriate openoffice.org-style* package is missing.

But maybe we have to investigate why the package that contains the default style is not installed by default on Edgy Eft.

Changed in openoffice.org:
status: New → Invalid
Per Ångström (autark) wrote :

I got the same problem in Ubuntu 7.10 (64-bit): no toolbar icons in OpenOffice.org 2.3.0 when running in KDE 3.5.8. When running in Gnome, there are icons.

Also, when running in KDE, some dialogs, such as "Define Names" in Spreadsheet, don't have any buttons, which makes them useless.

In my opinion, this is a bug. How are users supposed to find out how to fix this?

Changed in openoffice.org:
status: Invalid → New
Emilio Pozuelo Monfort (pochu) wrote :

I've just run into this bug, but I didn't change the icon set from OOo, but from GNOME. Anyway, OOo should check that the style is installed and if it isn't fall back to an installed one.

Changed in openoffice.org:
importance: Undecided → Low
status: New → Triaged
Chris Cheney (ccheney) on 2008-03-11
Changed in openoffice.org:
status: Triaged → In Progress
Chris Cheney (ccheney) on 2008-04-02
Changed in openoffice.org:
importance: Low → High
Chris Cheney (ccheney) on 2008-04-02
Changed in openoffice.org:
importance: High → Critical
Chris Cheney (ccheney) on 2008-04-05
Changed in openoffice.org:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:2.4.0-3ubuntu2

---------------
openoffice.org (1:2.4.0-3ubuntu2) hardy; urgency=low

  * debian/rules:
    - Reenable java on powerpc. Closes LP: #205923
  * ubuntu/ooo87965.execute.sh:
    - Added to work around bug executing launchpad-integration script.
  * Resynchronise with ooo-build (r12125).
    - ooo-build/patches/src680/human-icons-add.diff:
      . Fallback properly to human icon theme.
        Closes LP: #106186, #138360, #153598, #178455
    - ooo-build/patches/src680/ooo85931.inconsistent.getentrypos.diff:
      . Added to correct add templates issue on amd64. Closes LP: #62591
    - ooo-build/patches/src680/ubuntu-lpi.diff:
      . Changed to use launchpad-integration script. Closes LP: #46546

 -- Chris Cheney <email address hidden> Mon, 07 Apr 2008 20:05:52 -0500

Changed in openoffice.org:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers