package slapd 2.4.28-1.1ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #990759 reported by Chris Carroux on 2012-04-28
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
openldap (Ubuntu)
Undecided
Unassigned

Bug Description

package slapd 2.4.28-1.1ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

After this package failed to install during the upgrade to 12.04, I used "sudo apt-get purge slapd" then "sudo apt-get install slapd" to do a fresh install, yet the install problem keeps coming back.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: slapd 2.4.28-1.1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Sat Apr 28 14:23:18 2012
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: openldap
Title: package slapd 2.4.28-1.1ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-04-28 (0 days ago)

Chris Carroux (chrisc550) wrote :
tags: removed: need-duplicate-check
James Page (james-page) wrote :

Setting up slapd (2.4.28-1.1ubuntu4) ...
  Backing up /etc/ldap/slapd.d in /var/backups/slapd-2.4.25-1.1ubuntu4.1... done.
  Moving old database directories to /var/backups:

  Backup path /var/backups/dc=nodomain-2.4.25-1.1ubuntu4.1.ldapdb exists. Giving up...
dpkg: error processing slapd (--configure):
 subprocess installed post-installation script returned error exit status 1

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openldap (Ubuntu):
status: New → Confirmed
Adam Gandelman (gandelman-a) wrote :

Hi Chris-

Thanks for reporting this and helping make Ubuntu better. Can you confirm whether or not this report is from the same system as that described in Bug #990751 ? That is, was this generated from a subsequent attempt at repairing or working around the other previously reported bug? Thanks

Chris Carroux (chrisc550) wrote :

Hello Adam,

Yes, this is the same system that encountered Bug #990751. The difference is, that report was generated during the upgrade process from 11.10 to 12.04, whereas this bug was encountered after I restarted, purged the slapd package, then tried to do a fresh reinstallation of it. Hope that helps.

Chris

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers